Plex not support for new Vero 4K+ update

After the recent update Plex no longer works? Anyone know a work around or way to roll back the update?

My Plex works after 19.1 but the only issue is it takes about 90 seconds for a video to load where before the update Plex loaded videos instantly.

I should have taken my own advice and not updated so soon. But at least Plex plays the videos eventually

Are you using an old Plex add-on? It is working just fine for me with the add-on from the Kodi repository which show as version 0.3.3

Yea I’m on 0.3.3. As well and Plex works but is slower to start video playback

I was actually talking to the OP. It is a bit confusing if you cross post like this.

To the OP to more directly answer your question you cannot do a simple downgrade. You can do a backup of your Kodi settings and perform a clean install of the older build and then restore your Kodi userdata (results not guaranteed on how the restore will work out). I suspect you may want to omit restoring guisettings.xml

I did the upgrade and the Plex add on is working, but it did not at first. I had to do the SSH, command line upgrade process described in the troubleshooting post.

The only odd thing I have found is that it does not play SOME extras with SOME of my movies. I haven’t found a pattern yet or I would post about it.

3D-MVC seems to work fine as it did before though!

1 Like

I was just reiterating to the OP that my Plex works as well even with the slight delay in playing a video

After the august kodi 19.1 upgrade my plex plugin for kodi isnt also not working anymore. I tried to reinstall it but get error not compatible for python. Even tried to manually install version 0.3.3 in zip format from a micro sd card but same error. I think de plex plugin is not compatible with kodi 19.1.

After switching to the matrix repos for the Netflix and Amazon Prime Video I had various “python errors”.

  1. Removed disabled/orphaned addons as per these two comments AFAIR you could see that they were from the old Lelia repo for the Netflix plugin. So maybe same story for your plex plugin repo?

  2. Based on the following resolutions for issues with the Nextflix plugin #532 and #664 and tweaked them for python3.

# Not sure whether they're all required but afterwards everything worked again. 

sudo apt-get install python3-pip python3-crypto build-essential -y
sudo apt-get install python3-all-dev python3-crypto-dbg -y
sudo apt-get install libffi-dev libssl-dev libnss3  -y

sudo pip3 install setuptools  wheel pycryptodomex

Instead of trying to reinstall the add-on, or install a zip on top of it, did you try uninstalling it and then install from Kodi repository? Obviously the add-on is compatible with Kodi 19.1 as there is more than one person in this thread that have it working.

1 Like

Yes I already uninstalled plex for kodi and tried to install it from the repository. But i was unable to find it because there are many sub menus missing the only submenus that are available are game, information, look and feel and web interface. So i searched from teh search option for plex and then try to install it. but then i got a python error “Dependencies on the xmbc python version 2.26.0 could not be satisfied”. I got this error while trying to install youtube and several other add ons.

I am most decidedly NOT the expert in here, but my PfK add-on does work. Could be sheer luck, but here’s what I did to upgrade to v19 from the 3D-MVC test build:

  • Upgraded via “My OSMC” in the OSMC GUI

  • Rebooted, but PfK didn’t work and I don’t have any shares manually created to run Kodi natively. PfK would crash OSMC.

  • Ran the manual upgrade commands found here: Keeping your OSMC system up to date - General - OSMC

sudo apt-get update
sudo apt-get dist-upgrade
  • I then re-ran the same commands. When I did it prompted me to use the autoremove command to get rid of old packages so I did:

sudo apt autoremove

That got rid of old packages no longer needed.

  • Then I rebooted again and all worked.

Other than the slight refinements to the GUI I noticed no differences at all except that “My OSMC” is now a “Program” rather than a menu option. I don’t know if that is something I did or if it can be fixed, but early in the process I did get a message that said it was incompatible with Kodi or something to that effect.

Good luck!

1 Like

I solved my problem. By doing a factory reset. rebooted the vero and setup my network connection after that i was able to install my add ons again. And the add ons are working perfectly again.

1 Like

I’m closing this thread and ask that any further questions on this topic be brought up in this new one which contains how to fix the various Plex add-ons…