PoE fan issue

#1

Hi all,
I’ve added to my raspberry pi 3b+ the new official PoE Hat.
According to the guide on the rasperry pi website, the cpu fan should run automatically when temperature is above 50 degrees, my raspberry pi is well above that and the fan is still not working.

I’ve already tried to update/upgrade, only thing I didn’t try is rpi-update because is not included with osmc.

Any help or advise is well appreciated.

thanks

#2

Unfortunately I can’t advise as I don’t have a PoE HAT.

I know that all of the necessary patches to support this device are in OSMC however.

Sam

#3

you have to check it the official documentation for the POE hat in order to set fan limit, this isnt really a OSMC issue.

Which brand is the HAT ?

#4

Is the official Raspberry Pi PoE Hat.

it works fine when I use it on another Raspberry pi with the official raspbian OS.

https://www.raspberrypi.org/products/poe-hat/

Additional information
No modification to the main Raspberry Pi board is needed for this product to work. Please ensure that your Raspberry Pi’s software is up to date for all functionality to be available. The PoE HAT is fitted with a small fan that is controlled by the Raspberry Pi via I2C. The fan will turn on and off automatically depending on the temperature of the main processor on the Raspberry Pi.

#5

https://www.raspberrypi.org/forums/viewtopic.php?t=221639

this might be what your looking for, also might be worth looking at @sam_nazarko since there might be more PoE users popping up in the future.

2 Likes
#6

Exactly what I needed!
Thanks for that, will let you know if it works.

#7

The overlay should already be included in osmc

#8

Was thinking about the paramters thats needed :slight_smile: i know the overlay is there

#9

Yep, right parameters did the trick.

Thank you all!

#10

Having trouble figuring this out.

I’ve added dtparam=poe_fan_temp0=55000,poe_fan_temp1=60000 to my /boot/config.txt and rebooted after saving the file

I’ve stressed my Pi3 w/ POE hat to where i’m seeing the thermal warning on the screen.

Am I configuring it incorrectly? Currently running OSMC 2019.07-1 / Kodi 18.3 / Compiled 2019-07-04

#11

its running hot make sure that it has proper cooling where it is. simple as that …

and if its still running and getting power over ethernet then yes its working.

#12

Hi Toast,

It’s using POE with the official hat for power, but the fan never comes on when I am running OSMC. For now i’ve taken the cover off of the case to help cool it. I confirmed that using a micro sd card with Raspbian the fan turns on immediately and cools the CPU down.

#13

Can you try the 4.19 kernel in the staging repository?

To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

#14

Hi Sam,

I was able to get the updated version, the fan didn’t come on while playing a movie, I’ll let it run for a few hours to see if the tolerance is a bit different.

On my /boot/config.txt I removed the dtparam that I had added. I can wipe my microSD to a clean OSMC image and do the update to the 4.19 kernel if you’d like.

1 Like