Potential graphical glitches and freezes fix

Okay – you’ve waited long enough (I appreciate your patience). It’s time to get the device back and send a new one out.


Can you try with absolutely fresh Kodi and just streaming from the NAS with no add-ons whatsoever? @Guy’s box dies almost immediately, but I find it strange yours goes funny after a period of time.

I just want to remove as many variables as possible


Vero1 PSU.
Fresh Install using brand new 8 GB SD card picked up at the local store just for this test.
First boot post install failed before I could map.
Hard boot
Mapped main video share
Video failed less than 5 minutes in
Hard boot
Vero2 PSU, different TV (using RP2’s HDMI & Ethernet cables), Video failed about 20 minutes in
Place back onto original TV with Vero1 PSU.
Failed during OSMC splash screen

1 Like

G’day Sam,

I’ve completed a fresh install to the latest version. The lockups and crashes after 5-10 minutes usage have still persisted as per previous reports. The attached log occurred after the last crash whilst attempting to scrap my library and not during video playback.

The main difference since the update is that it now locks up (no ssh or other inputs respond) as opposed to the full graphical glitch. End result is still the same though. and can only be resolved by powering down for an extended period.

1 Like

I notice in your log a lot of CEC errors, assuming you don’t use CEC to control the device, does it still crash if you disable CEC in Settings->System->Input->Peripherals->CEC ?

If that does not help, try putting the following line in /etc/rc.local (before the exit 0) then saving and rebooting:

echo 0x0 > /sys/class/amhdmitx/amhdmitx0/cec_config

Note, I’m not actually sure if this echo line will disable cec now that we’ve switched to libCEC in the most recent update and I don’t have a box at hand to test, but give it a try. If it does not help remove the line again.

What else would you like me to try with the Vero2 Sam?


At what point do we call it enough messing and move with an RMA (Order #398)??


Hi Chris

Couldn’t agree more. If you’ve tested with another TV, another PSU and an older version of OSMC then it does seem you have exhausted your ability to diagnose this problem

I did send you RMA details this morning to your email.


@sam_nazarko Crazy, not in my email (not in spam/junk/trash/inbox). Personal message sent with Email Address.

Thanks Sam.

G’day DBMandrake,

I’ve disabled CEC as per your instructions. no change. I then inserted the line into /etc/rc.local. Also no change. This first log was captured at the first series of graphical artifacts that appeared randomly on screen prior to it crashing:
About 20 seconds after this was captured, it became unresponsive. I then captured a new log in the hope that the cause may be in kodi old.

I am still convinced that it is a hardware problem. The various OSMC versions released since I first received the unit in Feb have made little difference in the overall performance issues as I can still only get around 5-10 minutes use out of the unit. I first reported on this issue on 26 Feb Vero 2 Problem

Unless you can see something else that we can adjust, I think we should call it with this unit. As per landspeeder’s posts, I have tried different TV’s, 2 x PSU’s and all versions of OSMC on fresh installs since release.

Hi guys,

We may have an issue in replicating the problem.

I received @Landspeeder’s unit back yesterday, and had a chance to test it today and see how it’s going. I have powered the unit using a UK power supply and it booted immediately in to Kodi without any issues.

I attached the supplied remote dongle, an Ethernet cable and booted up. I didn’t have an issue booting the system. I saw Landspeeder has not really configured this system extensively. It has a Movie share mapped and scraped, and a hostname change. Other than this, it still runs the default OSMC skin. This is good, as it eliminates a lot of variables.

I copied Big Buck Bunny to the NAND (/home/osmc), and added an autoexec.py to Kodi to continuously play the video while I did some other tests.

import xbmc

This is the file that I used: http://download.blender.org/peach/bigbuckbunny_movies/big_buck_bunny_1080p_h264.mov.

I have looped it for four hours so far. I haven’t seen any graphical glitches or frame drops. The thermals look OK:

cat /sys/class/thermal/thermal_zone0/temp

62C is good considering we are playing a 1080p H264 movie for hours back to back.

During playback, I then installed ‘stress’

sudo apt-get update
sudo apt-get install stress

I started by running stress -c 4 which creates four CPU bound processes. Despite near 100% usage on all four cores, the video continues playing without an issue.

I then introduced two IO bound processes as well with. This spins the CPU on sync().

stress -c 4 -i 2

After around forty minutes, I found a screen of static and some noise. The device had overheated. But I had stressed VPU/CPU and NAND for some time to get this result. After doing this, I immediately unplugged and replugged the device and it booted without issue and playback loop resumed without any problems. We need to do some work on the trip points to prevent it getting that hot. I can’t see however how you are able to run in to an issue so quickly, and so frequently.

I’ve re-run the stress test again, and had it going for an hour without issue. The temperature is now:

cat /sys/class/thermal/thermal_zone0/temp

The video is still playing smoothly despite the stress test. The system load average is:

07:17:02 up 6 min, 3 users, load average: 5.97, 3.18, 1.35

I did not test @Landspeeder’s HDMI cable as there was not one in the parcel I received.

I did not test @Landspeeder’s power supply as he says that he has also tried a known, good, Vero 1 (original) one. This will be able to power the Vero 2 adequately.

I will now test another customer’s device to see if I can learn anything more. I will also try with the US power supply which was shipped back as well.


1 Like

Most playback testing has been done via SMB of DVD.ISO files - with a few BD.ISO and BD.MKV tossed in (that all work fine on any other OSMC device)… however the glitching will happen even when just navigating the menus. This glitching grew worse and more frequent with time. It was very infrequent at first. What I mean to say is that WHEN the glitch occurred it could be moments from a cold boot before OSMC was even on the menu screen, during a fresh install, while navigating a menu, thirty seconds into a movie, or an hour+ into a movie.

I tried 4 HDMI cables - 1 that has been working with my Vero1, 1 that has been working with my RP2 OSMC, a fresh short Amazon Basics, and the one hooked up to a family members set.

I actually thought you would boot it up and be greeted with a failure within a couple of minutes based on the last few days of testing.

Perhaps a poor soldier joint somewhere that is currently making contact due to the shipping jostling? I am at a bit of a loss.

Hi Sam,

I just had a quick go at testing the temps prior to glitching. It didn’t get above 61C when it glitched the first time (whilst scrapping). Afterwards I was able to immediately induce the static and screen lockup within seconds of initiating the stress test. This happened on three separate attempts. I’ll have a further play with it tomorrow and let you know if I can get any different results.

Note: Also using OSMC skin. No add ons installed and stock setup with CEC disabled.

Still working on this. Will have something for you tomorrow.


Thanks Sam

Sam I occasionally get a lockup when using the on screen keyboard and manually changing a video name to look up with a scraper. It freezes and makes the frozen noises when i am backspacing mostly. I need to turn the Vero 2 off and then on at the powerpoint. Maybe this is the same issue?

Hi Wayne

I doubt it. A log will help find out the cause of your issue, but users here have been reporting a freeze after just a few minutes of use after powering up their device.

I’ll keep a close eye on your issue nonetheless. The mention of scraping is interesting.


Hi Chris

What brand of TV are you using? I’m just curious as some clocks are generated slightly differently depending on the set.

I notice a lot of commentary about scraping. Even in the last post. It would be interesting if you could disable that temporarily.

I’m building an SD card version of OSMC for Vero 2 that you can try and I’ll post here when it’s ready. I wonder if the NAND is causing an issue.

Meanwhile – I’ve been playing with @Landspeeder’s hardware and still not found a conclusive problem yet. I’ll do some tests on his NAND tomorrow.

If we can’t find the issue, then we’ll send out some new units, no problem. What I’m trying to do, is try and work out what’s up so I don’t ship you a unit and you find yourself in the same situation.



G’day Sam,

I’ve used both a Samsung and a Sony TV.

WRT scraping, the freeze occurs irrespective of what I’m doing eventually. I have found that scraping will consistently induces the freeze for testing purposes however video playback will also cause it; it just takes a few minutes longer. As your last post showed me how to test the temp, I wanted to induce the problem whilst monitoring the unit to see if heat was the issue. Apparently it isn’t going by the temp results I was getting so now I’m stumped.

I understand your intent and I am happy to wait a while longer whilst you run additional testing. If there is any testing that you want me to do on my unit, let me know. Just be aware my command line ability consists entirely of cut and paste.



Hi guys,

Apologies for delays here. Unfortunately Samba decided to break upstream at a rather bad time and I have been all over the place (with the Android release).

As it stands, I still can’t find an issue with @Landspeeder’s device. I’ve watched TV on it over the weekend for a couple of days now streaming from an NFS share and I even enabled scraping to see if that was the cause.

Everyone who has reported this issue seems to have either a Samsung or Sony TV. Can @Guy vouch for that?

I was going to produce an image that runs from the SD card to rule out a NAND issue, but before I do that (we can kill two birds with one stone), I’m looking to see if there’s any obvious reason why these sets are playing up.

If I can’t find issue with these three devices, I will return a new unit instead. I appreciate your patience. I just do not want to return you another device which doesn’t work for you.