Problem freeze OSMC!


For some weeks, I have a problem with the navigation OSMC, it freezes when I avigue with some plug-in and in my hard disc or USB key.

I use Aeon Nox Silvo.

Here is my log:


Well my best suggestion is to uninstall all the none supported 3rd party addons which are know to deeply impact the system and to verify if the problem still exist afterwards.

I’ll check that. I removed most of the plugin and it stuck to appeared when I browse my key usb.

I also have some mistakes with “extendedinfo script”.

I put another log, There are other errors:

These messages are suspicious:

16:52:19 1491.746338 T:1732191216   ERROR: COMXImageFile::ReadFile special://masterprofile/Thumbnails/7/7555f780.jpg m_image_size zero

A zero length jpg in thumbnail cache suggests that kodi was powered off while writing to sdcard (or there has been some other corruption).
Posting complete logs (How to submit a useful support request - General - OSMC) may provide further information on is there is sdcard corruption.

Well I do not know why I have these freezes, but I am obliged each time to cut the power and turn on my RPI is perhaps for.

My last log, I see many mistakes, but to 2:39:44 p.m. this is where it freeze

kodi.old.log (big size) :

As the last mesage in log is:

14:40:00 10518.448242 T:1487926256  NOTICE: AddOnLog: PVR IPTV Simple Client: EPG file path is not configured. EPG not loaded.

does it help if you disable IPTV PVR client?

I thought it would solve the problem, but I had a new freeze when browsing my key usb

Log does not show the exact time of the freeze:

No idea ?

May wanna try that

I have already tried, that does not seem to come from plugin.

Well your last log file you provided still shows those add ons, so not sure if you tried that in between

I do not think it comes from the plugin,

here is the last freeze in wanting to install script.extendedinfo

I still have this problem and I see nothing in the .log that explains this ?

Please remove ALL manually installed repositories and addons and try again.

How did you try to install the extended info plugin?

I installed directly from the settings. it occurs when I move into playlists, when I look back in a saga or playlist, it freeze.

Do you have these issues without the aeon nox silvo skin?

Yes, I tried without and it does not change. I think I have this problem since the transition to Jarvis.

I do not understand why the log shows nothing. Did I should activate something in component-specific ?

I wonder if the problem is not generated images ?

Might be worth trying this test build: April update causes System freezes - #152 by sam_nazarko

I think the problem was youtube-dl, I updated, I wait to see if I’m out of freeze !