Problem with 4k resolution and some 4k videos

I have Samsung UE55MU7002 and after I set the resoultion in OSMC to 4k, the screens turns black like there’s no signal.

Also when playing the recommended 4k demo movie, it plays just fine, but after it finishes, the singal is lost and I have to reboot my Vero 4K.

I have the newest software no addtional devices attached to the TV and I’m using the cable provided with Vero 4K.

Thanks and best regards

try to set gui to 1920/1080 60p and refresh on start stop

gui is not in 4k

Yes – that’s the correct approach. We will then automatically switch to 4K resolution when necessary.


If you still have problems with particular videos, try setting Force 422 colour subsampling in Settings-System-Display.

Do you have an AVR between the Vero and the Samsung display?

I’m also having difficulty with the proper settings for 4k movies.

I have my Vero 4k+ directly connected to my Vizio UHD 4k TV using a Certified Premium High Speed HDMI Cable, 4K@60Hz, HDR, 18Gbps, 36AWG, YUV 4:4:4 cable. Resolution is set to 3840x2160p, Refresh rate is set to 29.97. All other settings are default.

I watched “Transformers The Last Knight” 4k Amazon Prime movie and the colors popped and the dark scenes had a lot of contrast to make out little details. I hooked up my external drive to the Vero and played the same movie, here are the specs.

I know it could be from improper ripping of the movies (which I know nothing about).

The colors did not pop and it crushed a lot of the blacks where you lose detail and contrast. I’ve read a lot of other posts about the Vero not being able to handle 10bit and not passing all the HDR/UHD metadata for the file.

What should my settings be so I can get the best 4k picture now, until the Vero can handle proper 4k metadata?

Don’t do this. This will cause problems.
Please follow the advice above.

So the proper setting should be 1920x1080p?
What should the Refresh rate be (29.97 or default 30.00)?
All other settings default?

1920/1080p 60h

It will switch to corresponding movie resolution when it’s above this setting, only when set refreshrate is set to stop start

I set the resolution to 1920x1080p, but I can’t find where to set the 60Hz or the setting for “stop/start”

Did you select expert menu?

I don’t believe I did, where do you set that?

Left of screen
See wiki link

My settings level is Advanced. Is this what you mean?

Yes, now select expert

But for resolution it’s not needed

Sorry for dutch setting

Got it set to expert, thank you.

Got it set now to 1920x1080p 60Hz.

The “Delay after change of refresh rate” is set to off.

What is “Force 422 color sampling”?
Doesn’t 4k use 444?
Also what is “Use limited color range (16-235)”? it is set to ON.

The settings are oke. 422 is extra for certain tv’s. No need for now. 16-235 is mainly for tv’s.

Some users with LG displays may find that they need to set ‘Force 422 colour subsampling’ under Settings -> Display for reliable 4K playback.

Use limited colour range (16-235) instead of full colour range (0-255). Limited range should be used if your display is a regular HDMI TV and does not have a PC or other mode to display full range colour, however if your display is a PC monitor, then this setting should be disabled for correct Blacks.

Now try that 4k movie to see if it better

I’ll try the movie again later and let you know, thanks for all the help.

Videos are actually encoded as 4:2:0. The player will generally upsample to 4:4:4 or 4:2:2 before sending the signal to the TV. Some TVs find it easier to handle 4:2:2.

Tried the 4k again and to be honest, the Bluray 1080p has a better picture. The 4k just loses colors and is washed out. Now if I go into the videos settings while the movie is playing and adjust the brightness and contrast I can get better quality, but i would have to do this every time i watch a 4k movie. One of the main reasons besides being able to play H265 format movies was to be able to also play the 4k movies too. It seems like the Vero 4k+ just isn’t ready for 4k yet. Hopefully soon.