Problem with TV &Music Library and 4k Playback

I have a couple of problems that have just recently shown their ugly head.

  1. I can no longer view any of my TV Library programs (Which used to work ok), when scanned for new update, it simply ignores any new content. When viewing TV Library it states (Storage not available). I have checked NAS settings and nothing has changed as the Film Library is still working and updating ok.
    I have checked the TV database addon and that seems to be ok.

  2. Play back of 4K movies suffer from an intermittent problem, of giving me a black screen for about a second during playback. This can happen either once in a movie or about 12 times.

I wonder if someone could possibly look into this to see if my playback settings need tweeking, I have a Samsung 4K TV and a NAS drive that stores all the stuff.

here is my log file


  1. Try installing the python versions of TMDB scrapers and update your sources to use them.

  2. Try swapping out to a different HDMI cable and see if that makes the problem go away.

Your Vero hasn’t updated to the latest version. Is this on purpose?

Thanks for your replies.
Change HDMI cable is a good shout, never thought about that.
As regards Updates, this is set on auto, so I have tried manual but I get
“ERROR Connectivity issue while updating…”
New log…

Ok, not sure if it is the issue (as error message sound different) but first try the hotfix that is detailed in Question 1 of the v19 FAQ (linked below)

If that doesn’t work we need to check via CLI

Thanks for the hotfix suggestion, this seems to have worked.
It has now upgraded to the new Matrix version and all seems to be working well, except the problem with displaying Tv Shows. I remember recently my Synology NAS had a big new version upgrade recently, and think this may be the problem. I have checked the permissions on the NAS and TV shows Dir, and Movies Dir seem to have the same permissions, but ill recheck them all. Its strange because both used to be visible, and working, before the NAS update.

Well guess we need to dig deeper.
Access the command line (see below) and run showmount -e

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC


Export list for
/volume1/TV Shows 192.168.8.***
/volume1/Movies 192.168.8.***
/volume1/Music 192.168.8.***
/volume1/video 192.168.8.***

Found the problem !
After the Synology NAS software update, it had reverted the directories of Tv Shows and Music to not have access to the files. After resetting permissions to allow “map to admin” this allowed access to the directories !

Thanks to everyone for their help !

Merry Xmas !
Solar !