Problem with TVHeadend ts-recordings

When I want to start a recording from tvheadend, then I have to wait for 20s or more until the video is starting. Audio is avaible immediately. The problem is similar to this Vero 4K thread: TVHeadend, First 15-20secs. This first occured with KODI 18.4. TVHeadend (4.2.8-34) is running on a Raspberry Pi 3b+.

Problem with:

  • Vero 2
  • Raspberry Pi 3b
  • Only with h264 ts-recordings, mkv-recordings and mpeg2 play fine

When I turn off hardware-decoding, the recording starts immediately.

On other Kodi platforms (Android, Linux amd64, Windows 10) there was never a problem with the playback.

Debug-Logs: https://paste.osmc.tv/nonefefitu
Example recordings in Kodi.log:
2020-01-10 17:20:19.831 Bares für Rares
2020-01-10 17:21:11.735 Kunst + Krempel

Best regards

Thomas

I will check this shortly

Sam

Is there any progress with fixing this?

Greetings

Thomas

1 Like

Hi Thomas,

Can you please try the latest staging?

Sam

Hi Sam,

no change in the start behaviour. First only audio, then after 20 secs buffering and finally after 25 secs the recording starts. What changed, is that the player-info shows 0 fps. Before, it was only in the first 20 secs.

Best regards

Thomas

Debug-Log: https://paste.osmc.tv/yomokofefu
Video starts around 10:49:25 (Bares für Rares)

I’ve in the past the same issues, but step by step it was better, first step last year with the x sec buffering, and now after the Jan Update it’s works fine, also for the “old” bad samples (records TV Headend)
Michael

Hi Sam,

skipping is not reliable anymore. The intervals are very random. An I can not play mkv-recordings after your fix.

Thomas

I am looking in to this. Should have a better solution by the evening.

Hi Sam,

it seems, that your last fix, which make things worse (see my last post), is now part of the march update. Is there a way to go back to Kodi 18.4?

Greetings

Thomas

Yes – you can reinstall from https://osmc.tv/download.

I will try and reproduce this issue.
Is it possible to reproduce it on any Live TV recordings?

Sam

Hi Sam,

here the debug-log from a mkv-recording:

https://paste.osmc.tv/sivamevimo

recording: pvr://recordings/tv/active/Wetterbericht-2020-03-24_19%3a25
at 18:36:58

It did not start, only the rotating circle until i press stop on the remote. (18:40:58)

Thomas

I’ve found the problem and I’m working on it now.

With the osmc june release, the problem is finally solved.

Greetings

Thomas

Thanks for confirming. We backported some changes from Vero 4K/4K+.