TVHeadend, First 15-20secs

Ok so when I schedule a recording, the first 15-20secs might have 1-3 picture frames but has audio in background.

I tried the .ts file from server to laptop playing on VLC and media player and there is no lagging of frames

So I linked the vero4k to the .ts directory to play through video and not associated with TV section. and it does the same, also tried a file with a higher bitrate in same folder and this played fine.

So at least i know networks fine, but what else could cause this?

Is this an MPEG2 stream? We are probably waiting for a key frame before displaying anything.

hi sam,

its just a recording of HD channel that records to a .ts file

I would need some more information (MediaInfo, debug log and a sample) to look in to this

No probs, ive set it to record songs of praise, i`ll check its doing it on that, then just let me know, where to get the data you want and where i can upload the video for you to check

I had this exact same issue, and for me it was fixed by the following commit which is part of the next release:


Sam, is there a patch to update them files via ssh?


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Cheers Sam and jahutchi

Perfect opens file instantly no jutters

Can i remove the bellow now?

  1. Edit the file /etc/apt/sources.list
  2. Remove the following line: deb stretch-devel main


1 Like