Problem with USB IR receiver and Harmony remote

Here is my problem: I just built an RPi2 and I can’t get my Harmony 720 remote to work. OSMC recognizes the USB IR receiver as an RC6-MCE but I can’t find the correct profile in the Harmony app to work. I could use some help. I’ve tried several different profiles. Any suggestions would be greatly appreciated. I’m not good with Linux so I hope there isn’t much file configuration involved.

I just use the PC media center profile from with in the harmony programming software. This has worked for me every time.

Andy

I’ve tried many different profiles but none have worked. OSMC seems to have detected the receiver as an RC6-MCE receiver and ice tried switching to different remote types from within OSMC, but none have worked. What remote type do you use in OSMC and which brand and model of PC do you use in the Harmony app?

I have a harmony 650, I use a manta usb ir receiver. I use a custom built PC running windows 7. I don’t do anything special with OSMC. Plug in ir receiver, fire up PI let OSMC install. When installation complete. Remote works perfect.

Did the receiver also come with a remote? If so, can you post a picture of the remote? If not, maybe a link to the receiver that you have?

I can’t find the remote but I saw it in the list of the MCE remotes for Kodi. It’s listed as an Unbranded MCE remote. It works fine in Windows 7 as I used to use it for Boxee. I’m switching to an RPi2 for the shear size - I’m tired of having a huge tower for my HTPC. I wish I hadn’t removed the profile from Harmony but I was thinking I would have to for OpenELEC/OSMC. Any help would be greatly appreciated. I’m at my wit’s end. It looks like it sees the receiver but I don’t know how to verify it. I’m really sure it defaulted to the “rc6-mce-lircd” remote profile but I’ve tried various ones now that I’m not sure what to do next. I’ve tried so many MCE profiles in the Harmony setup but none have worked so far. It’s very frustrating when I know others have gotten this to work.

It might be this one in the harmony software:
Computer>>Media Center PC>>Chinavasion>>CVSB-983

This is according to the kodi wiki:
http://kodi.wiki/view/Unbranded_MCE_remote

I’ve tried that one too but it didn’t seem to work. I’ll try it again though.

Tried it again but it didn’t recognize any of the button presses the remote sent. I found a Kodi profile in Harmony but I’m not sure what model to set it for.

Check out this thread, http://forum.kodi.tv/showthread.php?tid=95063
Worked for me. Good Luck!

This is not for a Windows pc…it’s for Kodi running in OSMC on a Raspberry Pi2. I will try it anyway and see if it works.

This is the IR receiver I use http://twistedmelon.com/shop/?show=manta-tr1. No the IR receiver did not come with the remote. The remote is a standard Logitech 650 http://www.logitech.com/en-us/product/harmony-remote-650.

Embreeb
This is not for a Windows pc…it’s for Kodi running in OSMC on a Raspberry Pi2. I will try it anyway and see if it works.

The remote believes that the pi is a HTPC, KODI/OSMC thinks the same way. That is why you setup the remote to communicate with a HTPC.

I tried running lsmod to see what was running but it didn’t seem to show any entry for the receiver. I’ll admit that I’m not anywhere near an expert at Linux, so I could use some help to determine if OSMC actually sees the IR receiver. I originally had OpenELEC on it and lsusb showed an entry for the receiver but didn’t show any vendor info, just a blank line next to the ID for it. I knew it was the receiver because I tried lsusb with and without the receiver plugged in. Any help would be appreciated.

@guran: I tried the thread you posted but it didn’t work either. Kodi/OSMC didn’t respond to any commands from the remote. I’m not sure what to do now. Kodi is based on XBMC, which is what Boxee was based on, and I got it to work in Windows 7, so I can’t figure out why it wouldn’t work here. I only wish I could tell what the system is detecting the IR receiver as.

It’s probably worth seeing if the receiver is working. If it’s really from the “unbranded mce remote”, the chinavision profile from harmony should work and send keyboard commands. Try this:
1-turn on debug logging in kodi
2-ssh in and enter this command:
tail -F /home/pi/.kodi/temp/kodi.log | grep OnKey:

3-press some of the keys on the harmony (in device mode, not activity mode)
4-you should see the keyboard commands that are received

You should note that support in kodi for the unbranded remote is not great out of the box and a custom keymap is needed for it to really work well. You can use the keymap editor add on to make things easier if you want once you confirm that your it receiver is actually sending commands to kodi.

I tried that but it couldn’t find that directory.

Also, I tried installing lirc but after I did, the Remotes section in MyOSMC only shows “hardware” and “lircmd”.

OK, I found the correct directory for the kodi.log, but when I ran the ‘tail’ command and pressed buttons on my remote, it didn’t register anything.

For future readers of the thread, the proper command is:
tail -F /home/osmc/.kodi/temp/kodi.log | grep OnKey:

From other people who have this same USB IR receiver, mceusb may not support this particular one. I’m not sure what to do, except for maybe buying a more compatible receiver. Any suggestions?