Problems since update to Kodi 18.2


since the update to Kodi 18.2+ I got a few weird problems that I did not have with the previous version:

  1. Crashing often with channel switching (TVHeadend 4.2 running on the Vero as localhost). Very often I see the sad smiley face after switching to another channel. I will upload a debug log after crashing.

  2. Very annoying and serious: It is nary impossible to control the Vero with my Harmony Smarthub Bluetooth remote - sometimes a keypress isn’t even recognized, sometimes the cursor jumps at lighting speed after a keypress. I re-paired everything already - still the same. It is very frustrating if you try to scroll through a long list of channels - sometimes it starts to jump a dozen pages at once.

This needs to be fixed, really.

  1. The Vero and the lighting in the room is controlled via my own Smarthome system (ioBroker and the Kodi adapter). The lights are controlled (dimmed) with the actual Kodi state (play, pause or stop).

This does not work anymore - once I press “pause” the state stays at “pause”, no matter what I do - hence the lights stay on. I assume the reason for this is the same as problem 2 above.

I press the key “play” |“pause” once but the keypress is then send to Kodi multiple times - so if I press “play - pause - play” Kodi gets “play - pause - play - pause” - the media plays fine but the state is still set to “pause” until I press “stop”. I also assume that “play” and “pause” are the same commands - they are just toggling between two states.

I assume that if problem 2 is fixed, problem 3 goes away as well.

Hope I could explain it as good as possible with my english knowledge.

cheers, Dieter

What profile are you using? I know others are using Harmonys (via Bluetooth) without issue. Perhaps @Smurphy can advise.

Thing is - when a new version comes out, I never update right away because of the “fine” tuning that needs to be done.
I have 3 girls + wife at home - and if the Vero+Kodi does not work, it is hell on earth :wink:
So no, I won’t be able to help out here this time. Sorry.

1 Like


I’ am using the Vero/OSMC profile from Logitech. As I said, it worked with 17.x without much problems. Now it’s a mess.


Thing is - the Vero updated itself - I did not do anything except confirming and hiting ok. And yeah, I do know that feeling, my lady is not amused at the moment, to say the least :slight_smile:

Anyway, something is wrong with Kodis input handling since I’m not the only one (I refer to postings in the forum with similar problems).

I don’t think the OSMC profile is very good.

We have some improvements with repeat filtering and this will be available in a few days.

It is impossible for OSMC to update itself without your consent.
You have to accept the prompt and you would have received a message stating that it is a major system upgrade.

If you know how to use SSH there is a fix you can try now.


Thats good to hear :slight_smile:

That’s not what I wrote - I did reading the upgrade notice very carefully and was looking forward to the new Kodi 18.2 so I did confirm the update and hit OK - from my standpoint there was no reason to not update the system (I’m in IT since 1986 so I should have known better).

Yes, I do know how to use ssh :wink:


Try this: Remote "Double-Clicks" Following April 2019 Update - #29 by DBMandrake


Thank you very much, this fixed the issue - the kodi state problem is still there but not your problem I assume - I will open an issue with the (iobroker) adapter dev.

Quick and easy support, I’m glad that I decided to buy a Vero :wink:

Glad to hear this. I don’t know a lot about iobroker – so it will be best to check with the developer.