Problems with HDMI CEC w/ Philips TV

Hi,

I recently purchased a Vero 4k, which is connected to my 2009 Philips TV set (Philips 32PFL9604H).
As described in another posting, the Vero 4k replaced my Rasberry Pi2 with current LibreElec.

In addition to the “Randomly blue/green tinted picture” problem, which I never experienced before on my previous Raspberry-LibreElec-set-up, and which I for now mitigated with this this workaround I’m also experiencing another HDMI-related problem, that is, that my Vero is randomly losing the HDMI CEC connection to the TV-set.

When I change my TV-set to the HDMI channel my device is connected to I can navigate through menus etc. through HDMI CEC and start videos etc. and everything is working smoothly. However, quite frequently (but not always) when watching a video the HDMI CEC connection appears to get lost, meaning, that the device does not react any longer to commands through the remote control of my TV set. Sometimes, it will pick-up the connection again but most of the times I have to change my TV set to another channel and change back to the HDMI channel in order to re-connect HDMI CEC. I never experienced this problem with my previous Raspberry-LibreElec-set-up. My wife really likes the HDMI CEC functionality and hence I really would appreciate help on this front.

Thanks much, Markus

Tried already a different HDMI Cable?
Tried to poweroff (disconnect from power) both devices for 3 minutes?
Any other device that could influence CEC (blueray player, playstation,…)?

If all that is excluded I suggest to enable debug logging and check what is recorded in the log in the moment you loose CEC

Thanks fzinken,

Re. 1: I’m currently using the HDMI cable that came with the Vero 4k. I give the one previously used with the Raspberry a try.
Re. 2: no, haven’t done that… will give it a try
Re. 3.: yes, there a Philips 2.1. Home Entertainment System (Philips HTS7201) and a Chromecast are connected to the same Philips TV-set as the Vero 4k… but this was the same set-up as used before with the Raspberry and I never experienced any problems.

Best, Markus

My bet is the HDMI cable.
None of the provided cables that came with the 2 Vero 4K’s I bought worked with CEC.

Have powered-off all devices for at least 10 minutes and replaced the HDMI cable to a branded cable (loglink) that I have previously used with my Raspberry without problems.

I cannot watch telly… I’ll report later whether this solved the problem.

With that said, I just saw that someone else experienced the “Randomly blue/green tinted picture - #44 by gerifoka”-problem with a Philips TV and also experienced problems with HDMI CEC that “stops randomly, like instantly after boot or after 5-10 minutes”. Maybe these problems are connected?

Best, M

What happens if you remove the Chromecast? There were reports at one time that Chromecast was creating issues in some CEC setups.

Thanks, will also test that (however, the Chromecast never caused problems in my previous set-up).

M

If you still have problems debug logs should show CEC issues

Sam

Hi @sam_nazarko,

I did post into the Philips tinted picture topic. That is now fixed with rc.local. Now the CEC issue that needs to be resolved. Pulling mains does not help. Changed HDMI cable, no fix. How can I help? Please help to explain to provide the needes logs. I have Vero4k and 52pfl9704/12.
What I can add too, that on RPi3(Libreelec8.2.2) if this happens during booting TV and RPi3, that for the arrow buttons the picture starts to shift I push the “back” button, then screen flicker and CEC controls are OK again. With Vero it does not help.
Did test a few things.
TV on Vero on CEC working (after off/on cycle on easylink in TVmenu) RPi3 works with CEC, change to HDMI of Vero CEC does not work (when it does not it shifts the picture pushing arrow buttons). Switch back to RPi3 CEC still always work. HDMI 1= RPi3, HDMI 3= Vero. I’d did swap and change HDMI, no effect.
Fair to say there are occasions, when CEC on Vero works again temporarily, when switching back from RPi3 (hdmi1), but CEC freeze after a bit (no screen flickering, just stops reacting, while with KORE app still able to control).
If I restart Vero via SSH or KORE, while TV kept on, CEC function does not restore.

Another test, TV on, Vero on, RPi3 on. CEC working on both. I restart Vero, CEC do not work on both Vero, nor RPi3, only the picture shift.
Rebooting the RPi3 via KORE, when Vero killed the CEC, will restore CEC functionality. If then I reboot with working CEC the Vero after screen comes up 2-3 seconds the CEC is gone again for both RPi3 and Vero.

I do have the latest available FW for the TV.

Sorry for the long post.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Hi @sam_nazarko,

I did upload the logs with the Osmc log uploader.
I had shared the links with you.
Log taken right after the reboot when CEC did not work. I navigated Vero with KORE and did the upload. Followed the instructions enabling debug logging, etc.
Let me know if can help anything further.
Thanks, Geri

See CEC suddenly stops working - #8 by kid63. It may be related.

Hi, I was away and wasn’t able to provide feedback:

I cannot reproduce the problem anymore after changing the HDMI cable and powering off the TV set and the Vero at the main for more than 10 minutes. I haven’t removed the Chromecast.

However, I have to mention that I ran an update BEFORE providing this feedback. So, I’m not sure whether the update contributed to mitigating the problem.

I was wondering whether the update made some changes to my configuration, related to Sam’s post:

I’m saying this because another strange thing appears to be gone: the language of my TV-set is set to German but I prefer to have the language of my Kodi set to English. The strange thing was, however, that after having re-set the language of Kodi to English it literally gradually changed to German over the course of some minutes. This strange behavior is now gone, and I checked that “set language from TV settings” under peripherals is disabled but I’m not sure whether this function was enabled before (if so I for sure had not enabled this function. What does the function do?).

I’ll give an update if anything changes.

Thanks, Markus

It happened again. Seems to be rather sporadic, which means that I will probably have to run the debugging log for quite a long time to document the event.

Do you have thoughts about this:

  • will the size of the log file become a problem?

  • shall I activate "verbose components for input devices (JSON-RPC, CEC, HTTP, for remotes, smart phone remotes, web remotes, etc) "?

  • Is there a way to hide the display of CPU usage etc. during debugging? (found the answer to my question here: 1) created an “advancedsettings.xml”, 2) changed “2” to “1”, and 3) rebooted the Vero)

Thanks, Markus

Hi Sam, the problem reoccurred while I was running debugging. I read the instructions but I’m not 100% sure how to upload the log.

  • For instance, which logs do I have to pick under my OSMC / Log uploader?
  • How do you know that it is me who submitted a log through OSMC > Log Uploader? I just used the Log Uploader but did not receive a unique identifer etc. but just a window directing me to "http://paste.osmc.tv/ "

Thanks, Markus

You need to use Component Based Logging with CEC enabled.

I won’t. If you don’t get an identifier it may mean that your log file is too big.

Perhaps when the issue occurs you could try:

  • Stopping Kodi (sudo systemctl stop mediacenter)
  • Running ‘cec-client’ and showing us the output of that

Hi Sam, just happend again. I have captured the output of “cec-client” before and after CEC stopped working:

Best, Markus

Doesn’t seem to be a difference. I’m not sure the connection is breaking on the OSMC side…

Hi Sam, it just happened again and debugging was running.
I sent you the logs via private message.

Best, M

Hi Sam, here is the log:

http://paste.osmc.tv/judifurowa.vhdl

and here is the output of “cec-client”:

http://paste.osmc.tv/axazanakup.coffee

Best, Markus