PS3 BD Remote and OSMC

Hi,

I cannot get working PS3 BD Remote (old version) with OSMC. I pair it without any problems.

At that moment only left/right/up/down/enter keys are working.

Then I installed new keymap.xml and input.conf from http://forum.kodi.tv/showthread.php?tid=50717&pid=1317022#pid1317022

(I fixed bluetooth addr in input.conf).

At this point mote keys are working, but not all. For example, pause and rew keys work, but fwd and “tirangle” key are not.

I tried to user “keymap config” add-on, without success - it does not “see” the triangle key and others on remote.

I installed package xbmc-eventclients-ps3 but it does not change anything. Finally I installed evtest and it shows every key pressed on ps3 remote. That is its output for “triangle” key and some other:

Event: time 1455310637.261140, type 4 (EV_MSC), code 4 (MSC_SCAN), value 9000d
Event: time 1455310637.261140, type 1 (EV_KEY), code 357 (KEY_OPTION), value 1
Event: time 1455310637.261140, -------------- EV_SYN ------------
Event: time 1455310637.380007, type 4 (EV_MSC), code 4 (MSC_SCAN), value 9000d
Event: time 1455310637.380007, type 1 (EV_KEY), code 357 (KEY_OPTION), value 0
Event: time 1455310637.380007, -------------- EV_SYN ------------
Event: time 1455310638.224076, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90070
Event: time 1455310638.224076, type 1 (EV_KEY), code 358 (KEY_INFO), value 1
Event: time 1455310638.224076, -------------- EV_SYN ------------
Event: time 1455310638.406701, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90070
Event: time 1455310638.406701, type 1 (EV_KEY), code 358 (KEY_INFO), value 0
Event: time 1455310638.406701, -------------- EV_SYN ------------
Event: time 1455310639.121920, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90070
Event: time 1455310639.121920, type 1 (EV_KEY), code 358 (KEY_INFO), value 1
Event: time 1455310639.121920, -------------- EV_SYN ------------
Event: time 1455310639.390843, type 4 (EV_MSC), code 4 (MSC_SCAN), value 90070
Event: time 1455310639.390843, type 1 (EV_KEY), code 358 (KEY_INFO), value 0
Event: time 1455310639.390843, -------------- EV_SYN ------------

What I noticed is that the “silent” keys have the codes greater than 0xff. I found bug report about just this case (but not with kodi).

And now I don’t know what to do next.

I haven’t seen this stuff before, but, reading that linked thread in conjunction with your comment leads me to ask whether you did all the work (especially the ‘patch bluez’, as the associated comment show that you don’t get all the key values without doing it)
Derek

I’m not sure if such a patch ever exist. The mentioned patches are for the bluez v4, but the bluez-5.23 installed in the current version of osmc. The files layout and content was changed a lot between that versions and it is impossible to apply the patch for bluez-4.

One more thing. Some kind of PS3 remotes support is probably included into bluez=5. I was able to found the references in its Changelog:

ver 5.20:
Fix issue with LED handling of PS3 controllers.
ver 5.14:
Fix issue with marking PS3 controllers as trusted.
Fix issue with authorization of PS3 controllers.
Add support for DualShock 4 controller detection.
ver 5.13:
Fix issue with PS3 controller detection.
Add support for data transfers to L2CAP testing tool.
ver 5.12:
Add support for PS3 controller setup and pairing.

Now I’m just wondering if anyone on the Earth have PS3 BD remote working with the latest OSMC release?

Ok, I found another topic describing this problem:

As fas as I understand that problem does not have any solution. It does not seem to be solved in nearest future either.

OE from the other hand supports PS3 BD remote (according the topic), so either I have to change remote or migrate to OE. I like this remote actually. ;-(

I just get the same remote, and same problem. No REW, TRIANGLE or slowstep working. Any news about that?

If you can get the keys through evtest, then you should just need to stop Kodi and use irw to generate a compatible LIRC configuration.

1 Like