PVR: No channel groups

Hello. I wonder if anyone can help me get channel groups working in the PVR.
I have a Vero 4K+ and its up-to-date.
I use TVHeadend as my backend (on a PC).
Kodi on both Windows and MacOS correctly shows all of my channel groups.
OSMC does not show any channel groups.
I have done a fresh install of OSMC and the problem persists.

Any ideas?

Which skin are you using? Estuary shows the groups across the top of the EPG. With the OSMC skin you need to get the side menu out by pressing Back then Left from the EPG or Left, Left from the channels list. Then you should see the option Group.

I am using the Estuary skin on all platforms.
The issue is only with OSMC on the Vero 4k+.

Today I tried multiple reboots and clearing PVR data multiple times. Occasionally I saw some groups, but never all of them and usually none at all.

How many groups do you have? I’ve only set up 3 (in TVH backend) and they work fine. I just set up one more using Kodi and seems to work fine.

I have 21 groups at the moment. That’s just 1 for each provider. No categories etc.
I really don’t know how OSMC on the Vero differs from other platforms, but that’s the only difference I can think of.

I can’t think how OSMC’s Kodi would differ from any other platform - I don’t think there are any differences in the PVR functions. Maybe @sam_nazarko knows.

It doesn’t differ.

What version of Kodi are you using on other devices and what version of the PVR add-on?

On Windows and MacOS I am running 20.0-RC2 with 20.6.0 addon.
Whatever the latest stable version is, that also worked on those platforms.

I just decided to load up another Vero 4K that hasn’t been kept up-to-date. Its running OSMC 2021.12-1 and 19.0.3 version of the addon. Groups appeared right away, albeit with the 16 group limit that was fixed at some point and further fixed in Nexus.

For the record, I’m running 2022.10-1 and 19.0.6 without problems. Sunday you should get the final Matrix update to OSMC. Let us know if that changes things.

Maybe the version of TVH is important? I am using the latest master via this Docker image based on the popular linuxserver.io image…

https://hub.docker.com/r/thealhu/tvheadend

After a couple reboots all of the groups that showed up instantly on the 2nd Vero are gone too.

Are you using TVH 4.2 or 4.3?

My understanding is that 4.3 is still not fully released and is experimental. While it does have some improvements, it’s been under development for some time and isn’t officially supported.

I don’t think there will ever be a 4.3 release. As I understand it all of the original devs are gone and its being kept alive by pull requests.

4.3 really needs to be the “supported” version.

I don’t understand how TVH HTSP and the Kodi client work, but I do know that I only have the groups issue on the Vero.

EDIT: Yes I use 4.3 and I don’t want to switch.

When I updated to Nexus on Linux, the channel numbers were wrong. I had to turn off ‘use channel numbers from backend’ then turn it on again. Maybe you could try that with ‘synchronise channel groups’.

Yes I have tried that. On at least one occasion its partly fixed the issue, showing some of the groups. What’s interesting though is when I get partial groups, all of the groups show in the group manager, but are inaccessible in the EPG etc.

I wonder if its a Linux problem rather than OSMC/Vero? Windows and MacOS are fine.

Wouldn’t surprise me. The linux version of the HTSP add-on for Nexus didn’t appear in the repo until a week after the Nexus release. Supports your theory that tvh isn’t getting much love.

I will try Kodi under WSL and see if it has the same problems and report back.