Quality issues with 4k playback

Has anyone experienced quality issues, specifically an overly dark image when playing 4k content?

The content in question is a 4k 10bit bluray rip and the image seems excessively dark and no amount of adjusting the in play brightness and contrast makes a difference.

I appreciate this is quite likely caused by the quality of the rip/encode, but is it something anyone else has come across? I should add that my TV doesn’t support 10bit, but this hasn’t been an issue with other rips.

I have tried another couple of rips with the same results, so I have to assume the problem relates to the video being 10bit and my TV not supporting it, beyond re-encoding the video, is there anything i can do form within the confines of OSMC to resolve or at least mitigate this?

The problem is most likely either one of two things:

  • your TV is advertising YPbPr output when it actually wants an RGB signal
  • your TV is advertising 10-bit / HDR support, when it doesn’t support it properly.

We can make it possible to override this in a future update.
Can you try the video on another TV and see if it’s the encode or the TV?

Does running echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb help?


What are the implications of running that command if the TV is not compatible with a 4k RGB input?

The reason i ask is that I am reasonable sure it isn’t, for example my PS4 Pro is set up for 2160p YUV420 and 2160p RGB is greyed out and in brackets says its unsupported.

Of course, some or all of this may be connected to my HDMI switch, but i did a lot of fiddling last night and not sure i want to start fiddling with the various connections in my set up just now (at this time of night)

With regards to trying it on another TV, unfortunately i don’t have another 4k set to test it on, however i do have a MacBook Pro, and testing the files on it suggesting the encode is good because putting both devices to the exact same point shows a very dark image on the TV, but a crystal clear one on the MacBook

It’s not persistent, so if you lose display output, you can reboot and things will go back to normal.

But you said that disabling hardware acceleration improves things in another thread; so it may not be related. We have video improvements coming soon, so stay tuned.


I don’t recall that as its not a feature i have played with yet, at least not on the Vero 4k anyway.

For the avoidance of any doubt, i quickly swapped a couple cables so the Vero is connected direct to the TV and the image was just as dark as previous, which at least suggests the switch isn’t to blame, I will try that command now.

It’s no magic bullet but may work: someone said it didn’t fix the problem for them; and someone else said that it did; so it needs more investigation. But it’s important to know whether this is a quality issue; or just an issue with brightness / colour.



Excuse my ignorance as its likely the cause, but i cannot get that command to run in the command line (logged in locally)

What happens when you run it?
Run it as root (sudo -s first).

SSH may be more convenient.

got the command run, sadly it hasn’t made an impact on the video quality

Did it trigger a resync?
Do you have no other display you can test on?

It may be worth uploading a small sample so I can look at the clip and see if I can reproduce the issue here


Sure, I have a couple 1080p monitors I can try it on, but I will need to come back to you on that as I am at work tomorrow and won’t get a chance to check until tomorrow evening

Sorry i meant to add that yes, it did cause a resync, i exited back to kodi and run the same movie with no improvement

You need to do it during playback for the purposes of testing here.
Let me know when you get a chance to test on another monitor.


I assume that’s what you meant by running the command via ssh instead of logged in locally?

Sam, I have tried your suggestions of another screen, specifically a 1080p Asus monitor from about 5 years ago and the same problems exists on it.

I tried forcing it to output RGB using your command (vis SSH) during playback and it indeed caused a re-sync but it didn’t address the problem.

Before i tried the monitor, i also tried firing it to run in 1080p on the vero by disabling the updated refresh rate on start stop and again, no dice.

I think your next suggestion was uploading a sample, what would be the best way to do that?

Chuck a video on Dropbox and I will look into it


In progress, although for a 60 second sample, it is 500Mb :slight_smile:

As requested, the public link to the sample


Just to update you, I tried the same file with my minix box and although it struggled to decode the video, what it did show looked ok in terms of brightness, contrast and colour etc…