Questions on my new Vero4k+


#1

i just received my new vero 4k+… dang! that this is small and powerfull :smiley:

i connected the vero to my denon x3400h receiver (media player hdmi port).
the receiver connected to my c7 oled (hdmi arc out -> hdmi arc in).

my media files hdd is connected with USB to my router, which then serves my media files over the network to all my devices. like a NAS.

now my first question:

kodi can’t find that NAS. i checked a few tutorials on how to share the storage over SMB (which i do for all my android and windows devices, with KODI), or NFS… but strangely all those tutorials keeps talking about windows and NAS servers. but my setup is neither nor… how can i find my network storage?

i’m really a noob when it gets to networking… on linux even worse :(:confused:

now to my second question:

i followed a guide on how to setup the audio settings on kodi. i have a 5.0.2 atmos setup right now. the guide told me to configure kodi for 7.1, allow passthrough, enable all the different types (dts, and so on)… and then it told me now to NOT enable “sync playback to screen”.

as i read, for kodi to do the upscaling 1080p to 4k, this option should be enabled.

now i’m not sure what to do… how can i check that it is doing the upscaling correctly?

because there’s another thing going on with the GUI. if i set it to 1080p 60hz, the left Kodi menu (the blue one that pops up) doesnt show up entirely. as if the Screen was zoomed in too much. if i set it to 4k resolution it’s ok, but i have only 30Hz available…

i hope you guys can guide me in the right direction,

thanx a lot


#2

Hi,

What is the make and model of the NAS?

No – just enable ‘Adjust Refresh Rate’
Your TV will be a better scaler than Kodi.

Set 1:1 aspect ratio or Just Scan on your TV. The exact setting name will depend on the brand of your TV.

Sam


#3

hey Sam,

thanx for the quick reply

it’s like i said: it is not a NAS. it’s a HDD storage attached to my router. it just gets treated like a NAS. it even says “Fritz-Nas” on the device name.

ok, i will try those 2 options. give me a second :slight_smile:


#4

The Fritz is quite old I think, so you will need to set SMBv1 to access it under Settings -> Services.

Keep in mind that there are security risks from this.

Sam


#5

hum… i powered the vero off, now i can’t turn it back on. weird :neutral_face:

nope, i access the fritzbox on my other kodi devices with the SMB setting at SMBv3…


#6

See File sharing with a NAS, media server, windows share or other device.

How did you power the device off?
You need to use the Suspend option instead of Power Off, if you’d like to wake it up with your remote.

Sam


#7

over the kodi menu on the bottom… “power off”

i have a red light. already unplugged the vero… even without power it shows the red light :thinking:


#8

What’s connected to the USB ports? Something may be powering the Vero via USB.


#9

You need to select Suspend, not Power Off, to standby it and resume it.

Yes – it sounds like he’s powering Vero from a hub.


#10

ok… standby it is :slight_smile:
you are right, it was the hub i bought with the vero

so let’s try the adjust refresh rate thing


#11

just scan on my lg c7 oled worked :slight_smile:
looks like it’s upscaling correctly 1080p -> 4k. the screen looks smoother, tho i don’t have a way to test it.

as for the storage issue: the guide you posted, i had read it but things like: “You make a directory in the filesystem then attach the shared directory to that ‘mountpoint’, usually under the /mnt directory.”… it’s just chinese for me :blush:

is there a more step by step guide i could follow?

i’m truly sorry

thanx for your effort


#12

Here’s a couple of useful links.

Here is a cheatsheet and some tutorials for how to navigate in a Linux shell: Cheatsheets and Tutorials for users new to Linux based operating systems

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/


#13

ok, thank you bmillham, i will look into it tomorrow :slight_smile:

one last thing:

i have a dolby atmos test disk which has a few files in a m2ts file format.
kodi can’t handle this format, correct? the folder shows empty tho it’s not

cheers guys.

see ya tomorrow. thx for all the help and work you’re putting into this project :muscle:


#14

If it’s a disc, then you could rip it using a tool like MakeMKV. If they are files you could use MKVToolNix to re-mux them to mkv.


#15

M2TS should play fine. If the disc is encrypted you need to install the AACS keys manually (for legal reasons)


#16

Have you sorted out your network share?
If not Kodi doesn’t see SMB shares by default if you try to browse for them you need to input the SMB address manually,
any problems shout out and I will post up my (for me) foolproof guide on setting up SMB shares in Kodi.


#17

Yes Buckeye,

i had to put in my Router IP Adress to find the SMB share.

I will have to test 4K Playback since it’s supposed to be not as fast as the other share types.

I’ll keep you updated.

For now, THX for your reply :slight_smile:


#18

As i suspected, 4K Movies buffer a lot.

Probably the HDD + the USB 2.0 Port on the Router.

I’m going to Connect the HDD to the USB 3.0 Hub on the Vero, and read the guide on how to share the HDD over the network.

I just hope that i can still acess my movies with OpenVPN when i’m away from home, without having to set everything up again :confused:


#19

After a bit of testing, my 4K Movies play well from my HDD attached to the USB 2.0 Port of my Router.

I found out port 1 and 2 are 1Gbit Ports, 3 and 4 only 100mb. Don’t know why since i configired them for maximum throughput on the Router menu :cold_sweat:

But now i have a New issue, that’s worse than the 1st:

It turns out when i watch let’s say a 4K Movie through the vero, then exit. Then Browse again through my shares, my Router restarts…

first i thought there was an issue with a LAN cable, changed it. Not fixed.

Then i thought there might be too many devices connected to the LAN Ports (tho i havent experienced this behaviour before buying the Vero). I removed most of them and let only the Pi and the Vero connected. Still the same issue.

Then i contacted the Router support. They told me to try connecting a powered USB Hub to the Router. I tried the one i bought with the Vero. still the same issue.

Now i don’t know what else to try…

Thing is, before i bought the Vero, playing from the TV Mediaplayer i didnt have this.

Could somebody help me please?

Cheers


#20

Connect the USB Disk to the Vero and share from there instead of over burden your router