Random system freeze during playback

Hey all,

since the last update (March update) I’m encountering random freezes during playback of files (it appears to be at no fixed time). The picture freezes, sometimes the audio “hangs” (as in a static long noise) or the audio drops completely and the box gets unresponsive. It shows as offline in Yatse and I can’t control it via CEC or the remote that came with it. It’s also impossible to SSH into it when it froze (no route to host). The only thing I can do to get it working again is remove the power plug and plug it back in again.

It might be a similar problem to this reported by @G4eva: Random freezes Vero 4K - #13 by fzinken

Logs I generated directly after the problem happened last time:

Unfortunately I was not yet able to reproduce the problem consistently, so I don’t have any logs with debug enabled, but this seems to be a full system crash anyway.

Can this be a heat problem? My Vero is getting very warm to the touch on top (not untouchably hot, but very warm) and the problem seems to occur more during the end of playback of a file (however this might be a coincidence). So far it only happened during playback and not during “menu time” (unit runs 24/7) unlike the problem @G4eva reported.

I’m decently familiar with computers (MSc in Information Systems) but have no deeper knowledge of Unix so I am not able to troubleshoot further without assistance. So if I can provide any more logs please let me know!

Appreciate any help and best regards

Edit: FWIW: After the March update went through I got a sad face directly after the main menu showed up, followed by a reboot of the system after this everything worked normally. But I recall @sam_nazarko saying in a different thread that this is expected behavior in Kodi 17 after an update. Just FYI.

Yes, one of my problem… Last night get freeze and this morning there was that noise…

1 Like

Can you try installing the February image and let me know if you still have problems?

It could be power supply related: is your device plugged directly in to the wall?

I’ve tried both, and with all crashes randomly

Is it plugged in directly?
Will post some more suggestions when I’m not mobile


In one there is the power supply of the true and the other that of hdd, both plugged directly!
Now the vero emits a whistle that continues for a while even after removing the current

Hi Sam,

sure I can try this tomorrow. Can I backup and restore my current settings for this to avoid setting everything back up again afterwards?

As for the sound: When it freezes the sound is coming from my audio system (think of a broken CD player).

I tried plugging it directly into the wall as well as a high-end extension chord (with fuse and filter), seems to make no difference. But the problem definitely only occurs since the March update (I watched way more content directly after receiving it (on February image) than since the March update, and had it happening 3 or 4 times already with the March update).

I will install the February image tomorrow and report back if it helps.

Hi guys,

I’d like to reduce as many variables as possible.

So if you have any attached peripherals other than the OSMC Remote, please try and remove them for the purposes of testing. I’d also be interested in knowing what you have attached beforehand.

You can indeed. This is possible via My OSMC -> Updater -> Backups.

If you are able to try another 5V, 2A PSU, then it would be interesting.

We’ve shipped a lot of these, and with consumer electronics, some will not work as expected. This seems to be quite isolated however. It’s possible your hardware is faulty, in which case we will replace this for you. But I’d like to run through a few things first.



I have (and had never before) nothing attached except the remote.

I still have the PSU of my Cubox i4 Pro which should work with the Vero. I’ll check it, afaik it’s 5V, 3.5A

That power supply would be OK.
The barrel may not make perfect contact but it should be OK.


I can unplug the hdd, but i haven’t another suitable power supply, just 12V 2A

@sam_nazarko: I just installed the February_2 release of OSMC on my V4K and successfully imported my backup.

So far everything is working fine (still with the original V4K PSU), except I cannot get CEC to work again. I had the same problem upon release and first receiving of the box and it was fixed with the installation of the first update (I think it was from January_X (maybe Feb_1?) to Feb_2. The “Peripherals” section in the settings is greyed out.

Any advice on how to get CEC back up and running again? I will watch some stuff in the evening and report back if I get the freezing problem with the original PSU & the Feb_2 image.

Yes – CEC was broken in the February release. I suspect: sudo apt-get update && sudo apt-get install vero3-libcec-osmc will restore that functionality.


Yep, that did the trick. Thanks! I will now test if I get the system to freeze again. As said, it has to be regular usage, since I don’t have a way to reproduce the freeze.

Will report back!

Tried a different hdd, crash… Tried with an usb hub, crash… Tried with 2 hdd and hub, crash…

grab-logs -A http://paste.osmc.io/osikelaxay
dmesg | paste-log http://paste.osmc.io/udabimuvuk

Now I try to limit the download bandwidth

If you remove the HDD and disable torrenting, does the crash go away?


This morning there was active just smb and ssh, torrent disabled and hdd unplugged, arrived at home and everything was ok… This evening i’m gonna try to plug the hdd to the router

EDIT: If you want’ i’ve opened the ssh of my modem, i can give you my address and you can try directly… Until it crashes lol

This is extremely dangerous if you use the standard port and password!!!

1 Like

i know but now i’m at work and i’m trying some things… Usually is disabled

Change your password!

You will get hacked almost immediately!

We had some occurances where botnets scan pis with osmc installations and try to login with default credentials!

Edit: If you did this before, I’m not surprised you have problems.