Randomly blue/green tinted picture on Sony KDL-32EX600

Since last week I am the proud owner of a Vero 4K+. So far super happy with it. However, I have one problem, which has been described a number of times in this forum, but for which I cannot immediately find a solution. Maybe it’s my way of browsing the forum?

The problem is that I randomly get weird colors on the TV screen. Mainly greenish.

The TV I’m using is a 10 year old SONY KDL-32EX600. Still a little too good to throw in the trash so I hope I can fix this.

(Oh btw, I’ve already done the november update)

Thanks for the help :slight_smile:

You’re most likely trying to play videos that use Dolby Vision single layer profile which Vero basically plays back, but cannot decode and pass on correctly.

But without MediaInfo of affected files we can’t say for sure.

1 Like

Ok, is there a way I can provide you with some more details. The problem exists when playing all files.

Please keep in mind that I’m not that technical :innocent:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Thank you very much in advance for the response.

Before the color changes, the TV shows a black screen for a second.

Hopefully this is the data you need?

Link with logs → https://paste.osmc.tv/boxadocugi

Thank you. Try setting Settings->Player->Videos->Accelerate MPEG4 to ‘Always’. If no good, post logs again but without invoking the Bookmarks menu.

1 Like

I’m not sure if I understand this correctly?

I’ve took another log, if you do need an other one, please let me know.


A. What I also noticed is that this problem also arises in the menu itself.
B. When the screen turns off for a moment and turns back on with the greenish color, I see that the screen is slightly larger than usual. The edges are outside the screen.
C. This may have nothing to do with it at all, but I get the impression that OSMC doesn’t remember the settings I change. And it always forget the network he’s connected to when rebooting.

That suggests a HDMI connection issue. Do you have another HDMI cable to try?

1 Like

After cleaning 3 HDMI cables and 4 different ports, I think the problem is partly solved.

I saw the flicker 2 more times, but much shorter and the image recovered almost immediately. Afterwards, the image was always larger than the screen, after which I had to adjust it back in the settings.

I will follow up on this in the coming days and hopefully I can mark this thread as solved afterwards :wink:

Thanks for the effort !

It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off`

If the overscan changes, it’s likely because Vero is changing resolution (overscan settings are saved for each resolution). Things are much simpler if you set your TV to not overscan and don’t adjust overscan in Kodi.

That’s odd. I find telling my router to reserve a IP address for devices, based on their MAC, makes for a more reliable connection.

1 Like

I’ll just wait and see for the next few days. I didn’t have this problem with the Raspberry Pi. I also had to set up the overscan.

In the Sony TV I have almost no settings that I can change in this regard.

As for the network, I do think I should probably check the router again here.

Did you check the advice detail above?

From the manual (Manuals for KDL-32EX600 | Sony USA ) of your TV
Display Area - Full Pixel - Displays pictures in their original size when parts of the picture are cut off

1 Like

Ok, now I really feel like a chicken. :rofl:

So the settings are there. I’ve been watching TV on this device for 10 years now and I didn’t know that you had to set this for every HDMI port. OMG I feel so stupid right now :partying_face:

Thanks again for reminding me the details !

If I don’t have any problems watching a movie tonight, then this thread will be set to [solved] by tomorrow.

Fingers crossed and I really appreciate your effort.

To my great regret I had to conclude that the problem is still there :roll_eyes:
I don’t understand why I didn’t have this with my raspberrypi 3b+.

I will eventually have to buy a new TV, but it still works perfectly at the moment. Well, with the exception of… :zipper_mouth_face:

Try this: with the GUI on your preferred resolution, go to Settings->System->Display and with Settings Level set to Standard or higher turn on ‘Lock HDMI HPD’.

1 Like

I watched a series for an hour just to notice the problem. Haven’t seen any problems so far. I’ll let you know tomorrow when I’m sure the problem doesn’t come back. Thanks again !

1 Like

I’m going to be very careful with my answer, but I think this solved the problem. I really don’t know what this could have to do with it, but the important thing is that I was able to see a movie without the greenish screen.

For now (and hopefully forever) this problem is solved for me.

Thank you all again for helping me resolve this issue.

I really appreciate this !

1 Like

And here we go again. After the recent update I’ve got the green/blue screens again. Changed kabels etc, just like last time, but it didn’t solve my problem. Think I’m gonna put the laptop back on again. :scream:

I have a log but I don’t see anything strange here. https://paste.osmc.tv/utewawicug

What is strange is you have ‘Force RGB output’ set to On which should not be necessary. (Stranger is that Vero is not honouring that setting :thinking: We’ll need to see why that is.)

Anyway, since your TV doesn’t do ‘deep colour’ (10/12 bit depth video) I suggest you turn RGB output off and turn on ‘Force 422 colour subsampling’. Can you do that, re-boot and post logs again, please.

Thanks for the quick reply.

When the green/blue screen occurs and I change the setting “Force 422 colour subsampling” the screen turns black for a second and then I get the normal screen. From disable to enable or enable to disable. It always solves the problem. (Not really a solution :sweat_smile: )

The logs :