Raspberry 3B wifi not working

I have read a lot of threads about it but I haven’t been able to get it working. Some time ago, it was connected by wifi and it was working perfectly. But, for no reason, it stopped working so I decided to connect it by cable and now i need to connect it by wifi again.

Why isn’t working?

Hard to say from that alone.
What happens if you try and connect via My OSMC?

It only shows Wired but no Wireless.

Hi,

https://osmc.tv/wiki/general/accessing-the-command-line

issue the following commands:

sudo rm -rf /var/lib/connman/wifi*

sudo reboot 0

Thanks Tom.

It says:

osmc@osmc:~$ sudo rm-rf /var/lib/connman/wifi*
sudo: rm-rf: command not found
osmc@osmc:~$

sorry typo, should have been: rm -rf, will update my post.

Thanks Tom.

Nothing happened :slight_smile:

Hi,

Have you tried connecting to wifi via the commandline

If that doesn’t help provide logs or do a fresh install.

And for future reference:

Isn’t very helpful for diagnostics.

Thanks Tom.

I tried “grab-logs -A” if it helps:

https://paste.osmc.tv/buvidifexe

I see this:

Failed to start Broadcom 43xx bluetooth HCI.
Startup finished in 3.656s (kernel) + 31.304s (userspace) = 34.960s.
brcm43xx.service: Unit entered failed state.
brcm43xx.service: Failed with result 'exit-code'.

but i don’t know what it means.

connmanctl technologies shows:

connmanctl> technologies
/net/connman/technology/ethernet
Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False
connmanctl>

Hi,

I would back up your settings and try a fresh install, if issue persists; then its a hardware issue.

Thanks Tom.

It’s a new installation. So that means that is a hardware problem?

Hi,

probably, a debug log would be able to tell us more:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Tom.

Is this what you need?
https://paste.osmc.tv/ocodedasoh

Hi,

I would try a new SD card.

Also it may worth trying with the Latest Raspbian image, if the wifi still fails then its definitely a hardware issue.

Thanks Tom.

After several hours trying things i think it’s a hardware issue. Everything updated and checked.
“sudo iwlist wlan0 scan” command returns: wlan0 Interface doesn’t support scanning.

I’m not sure if i can do anything else or should i buy another rp3…

Hi,

Other than trying raspbian, I can’t think of anything else to try.

Thanks Tom.