Raspberry Pi 3 and Osmc

I got a Pi 3 about 1 month ago. I am running OSMC On the Pi 3. worked ok for the first week. After that. have had power issues. It would run a few minutes and the sad face comes up then pi restarts it is getting short now about every 30 seconds. I have the 2.5 amp power no low voltage icon on screen . I have reinstalled OSMC still not working.
Thanks

How can you be sure it’s a power issue if the power warning isn’t displayed?

I’m thinking there is some kind of problem with the March update.

I have 2 rpi:s running OSMC, and my brother has 1, all running the March update. All three systems started behaving odd, crashing, not connectable with yatse, plugins not starting etc. in the same day…

I’m thinking two could be a coincidence, but three?
I’m not surprised one of the systems would go bananas, I’ve messed with all kinds of system settings, installed scripts and what not. But the other two are almost untouched. A few plugins from the original kodi repo, that’s all.

The fact that there are not dozens and dozens of people on the forum seeking support for such an issue makes this unlikely.

Without logs though, nothing but speculation can be made and, as a support team, we prefer not to speculate.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Well after some reading, this: Skin changes lost after a reboot - #79 by Yaffle seems to be the problem, similar symptoms and dozens and dozens of people complaining. But video and audio settings were reset as well, on all three systems. Kinda odd it happened on the same day, isn’t it? One of the system wasn’t even being used for a few days.

I’ve grabbed logs. But didn’t think grab-logs -A would automatically upload everything, including my personal information for everyone to see, without asking me first. So I chose to send them to Sam directly and asked him to check and remove the paste since the log contains sensitive information.

In what way is the fact, that your pi is behaving odd and crashing, similar to the problem with resetting skin on reboot?

1 Like

OK, and the developer of the OS advised you that your issue was…?

Exactly how is this apple comparable to …

… this orange, which describes a completely different set of symptoms?!

Edit: please don’t make wild speculations on problems you don’t understand. I’m sure OP would appreciate you not using his thread to do so as well. I will now refrain from further derailing of the thread until diagnostic logs are provided for further debugging.

1 Like

If you read carefully again, you can see that people wake up to see the the settings have reset, and also someone mentions they are getting a sad face, that’s a crash, isn’t it?

@ActionA
Behaving odd = reset of settings and not connectable with yatse
crashing = see above
plugins not starting = orange

:wink:

Haven’t received a reply from Sam, but here is what I wrote to him yesterday, before I knew that this was an issue:

Hi Sam,

Both my brother and I started having issues with osmc behaving strange, not sure if it was after March update?

Problems are skin settings resetting, websocket connection not working. IPTV stopped working, Sad face. So I thought I’d ‘grab-logs -A’ and was surprised that they automatically got uploaded to paste.osmc.io. Would be nice if I was prompted to save locally (so I’d have the chance to edit out personal info) or upload.

I’ve requested a change of my password but would you please remove paste xxxxxxxxxxxxxx

I can also mention that my brother hasn’t made any changes at all to osmc outside of kodi GUI.

Again, apples and oranges… The settings reset issue is not related to a kodi crash issue…

Logs (sanitized to your liking), or I’ll wish good luck to you…

1 Like

Quite a few people with skin reset problem and among them maybe one who’s getting crashes (more likely from upgrading via ssh with “upgrade” instead of “dist-upgrade”). In my humble opinion neither this nor your problem are related.

Sorry @marks for unintentionally hijacking your thread. I was trying to help to the best of my knowledge but all of a sudden everything was about my issues with OSMC.

I’ve created a new thread and hope you find a fix for the issues you are experiencing soon.

Cheers

Had same problem with sad face and lightning bolt popping up too. Checked my power supply and it was dropping just below 5 volts, should have been ok but it seemed to fail when voltage dropped. Connected to my lab power supply and adjusted voltage up a little bit at a time. All the problems went away if gpio stayed 5.2 or above.