Raspberry Pi 3 announced with OSMC support

Becoming a reseller would do the trick to get one, weeks fewer :sweat_smile:

I’m getting strange behavior using the OSMC_TGT_rbp2_20160130 image file with the Pi 3, the green LED flashes 5 times slowly then 4 times quickly over and over, the display is only displaying the fullscreen rainbow square. Doesn’t seem to be a hardware issue as the Pi will boot with the latest image of raspbian from the raspberry pi official website.

Am I using the correct image?

Hi David

As outlined in the blog, you’ll need to update to the latest version of OSMC which will enable support for your Raspberry Pi. There will be a further update to enable the new Pi 3 functionality (LED, WiFi, BT) soon. After this is added, we’ll produce a new, directly compatible image for Pi 3.

Sam

So do I need to update with the SD card in a Pi 2 then transfer the SD card to the Pi 3 as the Pi 3 won’t boot to allow me to update. Not sure I like the new SD card slot on the Pi 3, I’m used to the Pi 2 having a springy type holder rather than just a push fit.

Yes, that would be the easiest way to get up and running for now.

Sam

Sorry to be a pain, just done a fresh install on a Pi 2 ready to transfer to the 3, but I’m now getting “Update error check log for details” on startup and “Add-on error check log for details” if I do a manual check. My log files are here if you have any time to check them http://paste.osmc.io/gukumereza

I have also tried the card in the 3 again after doing the fresh install just in case the update was picked up, I’m getting the same behavior with the LED’s but no Rainbow square on the TV now.

Have you searched? I am mobile, but you should find the solution quite easily, it’s been mentioned several times today.

Sam

1 Like

No I hadn’t to be honest, my brain was linking the problem to the Pi 3 which I didn’t think would be being discussed yet. Thankfully Australia has come to my rescue, damn leap years.

Thank you Sam

Regards Dave

Hi Sam,

Do you have anywhere to download your latest versions as boot.tar.xz and root.tar.xz?
I make a dual-boot Recalbox + OSMC NOOBs image and want to run the latest OSMC in it.

Those are NOOBs files. They’ll be updated when the new hardware enablement update is released.

Sam

Sam

I’m giving up for the evening, got OSMC updated through the Pi 2 by changing timezone. Restarted, checked for updates again just to be sure, none were available. Transferred the SD card to the Pi 3, on boot I just get a red LED on solid and the green LED flashes twice. There is no picture being outputted although my TV and AV receiver do recognise the video output as 1080p. Tried booting with no ethernet plugged in, and with ethernet, neither way worked but there were no lights on the port with ethernet plugged in. Transferring the SD back to the Pi 2 results in good boot sequence.

Regards Dave

So, If I understand this right:

You need a Pi2 to update the image on the SD card before it will work in a Pi3?

I don’t have a Pi2, I’ve tried with the latest image from the downloader (2016.01-1), but that doesn’t boot.

Is there a way I can get this to work now, or should I just wait.

Hello !

What about support of HD audio ? Is the pi 3 can passthrough dts HD or DD HD ?

Thank’s for the job Sam, OSMC is really my favorite mediacenter !

I see no Updates even today

What updates you refer to?

The update for 2016-2-1 to be ready for the Pi 3 or I’m wrong are they talking about the update from 2016-1-1 to 2016-2-1 what doesn’t worked on the switchyears? If this so I didn’t say anything.

i’ve buying new raspberry pi 3 on osmc store and price is £39,30 GBP. In €51,75 EUR…
in other website like it.rs-online.com is only € 36,92 … why the price is so hight in osmc store? is it possible to delete the order?

Any ideas how to enable the wifi? I cannot see it anywhere

I have refunded your order as you requested in another post.

The situation regarding HD audio is unchanged