Raspberry Pi 3 Stuck on splash screen

Alright. So:
I was trying to download OSMC to my raspberry pi 3 but When i was running the installer and my sdcard was connected via a MicroSd-USB Adapter it did not detect an sd card, and it worked with USB. But when i was trying to boot up from the Pi, It was stuck on the splash screen From the start.

I think i did the instollation wrong. Anyone send me a guide please?

Did you follow the instructions? You do know that even if you are installing to a USB stick that you still need an SD card for the Pi to boot. You mention that your SD card was not detected, so maybe it’s bad.

1 Like

Did you try running the installer as admin? I think this was needed at one point (maybe still is)

It is fine now… I have to buy a new sd card because THE INSTALLER DESTROYES MEMORY CARDS.

I suspect that if the installer destroyed memory cards we’d hear a lot more about that. You probably just had a marginal card.

What is that??

You memory card was probably already dead (dieing) when you tried to install to it.

Nope… It was all working. It was brand new from walmart.

Then can you explain just how the installer destroyed your card? (By that I mean why do you think that the installer did any damage)

The system cant format it, The pi shows SADFACE, partition manager shows 226 gig but it was an 8 gig card, my phone does not detect it…

Sounds to me then like the card failed. New hardware CAN fail.

How do i fix it??

I want to have OSMC by thursday on the Pi3.

If the card has failed, return it to Walmart and get a new one.

But i dont have the packaging and the reciept. So i cant return and i dont think its a hardware failure.

No – it doesn’t.
You got a bad card.

You said yourself that the card isn’t detected in your computer at all.

It could even be a bad adapter.

1 Like

Nope… The card worked fine before the instollation. Let me tell you what happend.
With a microsd-USB adapter the installer detects it as a USB flash drive. How do i know? It failed with the sd card option. So when i FINALLY got it to boot up, it failed to mount rom. So i installed on a flash drive and erased the card. Did not boot up. So once it FINALLY accepted the SDcard as a SDCard… yeah… It took forever to boot up, so i pulled the plug and well… hard reset-ed it. Sadface and failure… All because it did not boot up… so… and the pi does NOT have a power button…

That sounds like a faulty card.
Symptoms of SD cards not working correctly are:

  • Read-only behaviour, or changes made not persisting
  • A filesystem corruption error

If you would like to be a good quality SD card purpose manufactured for OSMC, then you can find one in the Store. It has an unlimited lifetime warranty.

Maybe your adapter is bad. All the installer does is partition the drive, format and copy files to it. If this caused the card to fail, then obviously either the card or the adapter is bad.