Raspberry Pi/KODI is freezing during movie play

Hi All…new to the community. I have been having my raspberry pi 3b+ freeze up while playing movies that are stored on a NAS and need some guru to take a look at my Log file and see what the problem may be. Thanks!


Please use the OSMC logging system.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I did that and I got this generic URL:


That can indicate the log is too big. Please reboot twice first.

rebooed 2 times…and just got the url:


I’m not seeing anything obvious in that log. It would be helpful for you to reboot twice, play a video until it displays the issue at hand, and then upload the logs as you did last time.

Here is one that just happened, and it happened pretty quickly(rebooted 2x before it happened):


I would take a look at your connection between your NAS and RPi. If you have powerline adapters, a wireless bridge, or similar, start by rebooting those. Maybe reboot the NAS as well. If that doesn’t clear it up then check your connection speed with iperf…

I dont have any powerline adapters or wireless bridge. I am hard wired in with CAT 8 cables. May reboot the NAS but its brand new. Here is the latest error:


Try the speed tests as suggested above. Also, what kind of power supply are you using? A bad power supply can cause strange problems.

One other thing, you are using Kodi SMB mounts. You might want to consider using fstab/autofs mounts instead. And if the NAS supports it, use NFS instead of SMB.

If you have a large library Raspberry crashes a lot for me. SOP A PC running windows is much more stable

I have not found this to be true personally. There can be stability problems with bad hardware or with some plugins or skins, but I have some RPi’s that go months between reboots with zero stability issues.


My home I have HDhomerun on my KODI’s which crash daily.
My vacation home which I have the same system with out HDhomerun they can run a day or two crash less. But they still crash. At my home using KODI on a PC can go weeks with out crashing

My point is that there is not something inherently unstable about the RPi hardware. I have five of them in service at my house and only one is prone to crashing. The one that is unstable is due to an issue with the A/C at that location and not the RPi. There are things that people can do to make them less stable (improper PSU, bus powered USB devices, overclocking, etc) but I don’t see how you could really blame the RPi on that.

If your PC can only go weeks without crashing then there is probably issues to be solved. The PC I use as my backend has only crashed once that I can remember in the five years or so that is has been in service running 24/7 (standard PC hardware, no server grade stuff).

Well my library has 6500 movies and over 50,000 TV Show episodes makes mine unstable

My library isn’t as large as yours:

Active Profile: Master user
Library Statistics:
            Albums: 4187
           Artists: 5285
             Songs: 48849
            Movies: 1184
         Moviesets: 232
           Tvshows: 323
          Episodes: 16091
       Musicvideos: 720
            Addons: 250

But isn’t not bad and I have no problems at all with crashing. I’d suggest that you look at any addons you may be using. Those are normally the cause of strange crashes.

This sounds an awful lot like the issue I had. Turned out the router the nas was connected to (asus rt88u) tried to actively manage the traffic, but couldn’t keep up. I solved it by connecting nas and vero4k to an 8 port gb hub. See this post for the whole story: Random freeze / quit to menu on high bandwidth content

I just read all of that. It sounds identical to my problem. I have a Asustor As4004T NAS with 2x Seagate IronWolf Pro 10TB NAS Internal Hard Drives and I am getting freezes during movie play. I know it’s not the Raspberry Pi because I have a 2nd media player (WDTV) and it started freezing up as well and it is connected to my network. I just added a Netgear 8 port switch that has everything hooked into it in the same room (TV, Computer, NAS, raspberry PI, Western Digital media player ) and I’m still having freezing problems during movie playback. I was having freezing issues before I bought the netgear 8 port switch.

My cables are CAT 8. I really do think it is the Asustor NAS since it is the common denominator here. I am using NFS in Kodi and also on the NAS but i have not configured fstab based nfs share mounts since you tried it and it did not do anything for you. Article here:Configuring fstab based NFS share mounts

I have been fiddling with all this for days. Just about ready to give up.

Have you actually run an iperf test as suggested? Are you using shielded plugs on the connections to your devices?

I have not done a iperf test. I am new to the raspberry pi and it looks complicated to run that since they both need to be on each device and ran from a command prompt or a shell. I have a asustor As4004T and it has its own proprietary OS running on it called ADM. Here is the description:

ASUSTOR Data Master (ADM), an operating system developed by ASUSTOR. Designed around the use of Apps, ADM’s intuitive web-based interface allows for easy organization and a user-friendly experience. This user manual will introduce you to all the rich assortment of preloaded applications (Apps) on your NAS.

So with this OS, how do I put it on there and run it?