RaspberryPi4 usb boot


I’ve been testing the beta version of osmc on a raspberry pi 4 (OSMC_TGT_rbp4_20210414).
Ignoring already known bugs, it runs great as usual.

I am trying to move existing installation (or install a new one) on the usb-ssd drive connected to the raspberry and boot from there but with no success. The case is an argon one m.2 and raspberry has been configured to boot from usb. the disk gets detected as sda.

I tried the osmc installer but the OS got installed on the SD card instead of the usb drive and i also tried copying the partitions of the installed SD to the USB drive while editing cmdline and fstab (to force mount / partition even if osmc doesnt mount / via fstab)

Anybody managed to do it, or know if i 'm missing something?

Excuse me it this is the wrong place to post my question since the version is still a beta

USB only boot isn’t supported at this time, but you could have an SD with bootloader files and USB boot that way (already supported by OSMC installer)

Thank you for your reply Sam.
Congratulations on osmc btw.

Tried it via the osmc installer (selecting local build) but it eventually left the ssd intact and installed the operating system (/boot and /) on the SD.

It could be the image or maybe I should have deleted the empty /dev/sda1 partition already existing on the m.2 ssd or the disk didnt activate fast enough for initrd to detect.

Will try again later and let you know!

Hi there,

I’ve the same problem. OSMC will only be on the sd card, nothing is written on the USB-drive.

Did the preseed.cfg file get generated?


Hi Sam,

there is a preseed.cfg file on the sd card, if you mean that.

This is the content of that file :
d-i target/storage string usb
d-i network/interface string eth
d-i network/auto boolean true

Greetings Cillit

Thanks for that. It will be fixed in the next image.

1 Like

If I understand right, the testing image linked in the post here (OSMC_TGT_rbp4_20210414.tar.gz) is not yet the image with the fix, is that correct? I just tried installing it and got the same behaviour as the original post. I see there is a changelog in that post but am not sure if the image includes those changes.

That’s correct – that image doesn’t incorporate the fix.

Should the fix be included in the August '21 release? I still get “Install failed: could not mount bootfs” when trying to install the new image on my RPi4. I put the image on my USB attached m.2 SSD using the Raspberry Pi Imager, as the m.2 ssd did not show up in the listing with the OSMC Windows installer.

Yes - this is fixed. You still need an SD card for booting.

You should write the image to SD and boot with USB attached.

1 Like

“Yes - this is fixed” Is it? Unable to boot from an image written to the SSD when a Pi4 is SSD boot enabled does not sound fixed to me.

Do you know if a future release is likely to have full boot from SSD working?

I have been waiting ages for the Pi4 version to be available so waiting for a properly working version is preferable to booting from SD card.

1 Like

As Sam wrote, you still need to boot from an SD card, ie the /boot partition must be on the SD card.

I’m happy to accept a PR on this.

Using PINN I can install and boot OSMC with no SD card installed in my Pi 4.

WIth the autoboot.txt option set, it will then boot directly as if OSMC is the only OS on the drive.

EDIT: I have also tried copying a working SD copy of OSMC with rpi-clone. However, it fails on boot as it is looking for root on /dev/mmcblkp02.

1 Like

That’s because we need support for UUID label booting in the initramfs. Then we could support USB only boot.

I would be happy to accept a PR to enable this functionality

I have an NVM M.2 SSD in a ANYOYO USB enclosure. I succeeded by first moving the root partition to the SSD as per this blog (OSMC OS on USB SSD disk - Joachim Burket's Page).

Then created space for the SD’s boot partition BEFORE the root partition on the SSD and cloned the boot partition from the SD to the SSD. Removed the reference to mmcblk0p1 in /etc/fstab and the SSD booted nicely as my PI 4 has boot order 0xf41.

Nicely done! There has been some progress on this and I think Sam planned to start a testing thread soon.

For anyone else trying this, we’ve found not all USB caddies can do it. We might need some user feedback to make sure all necessary drivers are included in the bootloader.

1 Like

You might want to be wary if installing updates.

Dumb question, but could you please provide steps for this part: “Then created space for the SD’s boot partition BEFORE the root partition on the SSD and cloned the boot partition from the SD to the SSD”?