RC GPIO /IR remote working?

Does anyone have an IR remote working in the RC, or is it just me who doesn’t?

Forgot to say, this is on a Pi2.

Yep, I have mine working perfectly after I added the keyboard.xml as described in this thread: USB remote not working on boot.
Note that I’m using exactly the same IR Remote as you can see on the picture in the beginning of the thread with a PI (not the PI2)

Now it’s time to teach my Harmony One the keys so I can stick to a single Remote Control device again… :slight_smile:

Thx Cloggy for the link - reading around a bit, I understand the USB remote works differently?

edited the title to indicate this is a GPIO / lirc issue.

dmesg doesn’t show lirc loaded.
config.txt has dtoverlay=lirc-rpi-overlay.

Anyone else have this issue?


I’m using a Harmony Remote via IR and GPIO. Working find for me. Make sure to copy your lircd.conf to /home/osmc.

What does this command return?

sudo systemctl status lircd_helper@lirc0

Here’s mine:

osmc@osmc-LR:~$ sudo systemctl status lircd_helper@lirc0
* lircd_helper@lirc0.service - lircd remote support
   Loaded: loaded (/lib/systemd/system/lircd_helper@.service; static)
   Active: active (running) since Sun 2015-03-15 12:15:23 CDT; 11min ago
  Process: 207 ExecStart=/bin/sh -c /var/run/lirc/lircd-%I.sh (code=exited, status=0/SUCCESS)
 Main PID: 227 (lircd)
   CGroup: /system.slice/system-lircd_helper.slice/lircd_helper@lirc0.service
           `-227 /usr/sbin/lircd --driver=default --device=/dev/lirc0 --uinpu...

Mar 15 12:15:23 osmc-LR systemd[1]: Started lircd remote support.
Mar 15 12:15:25 osmc-LR systemd[1]: Started lircd remote support.

hi gmccauley,

yep, xbox-lircd.conf copied to ~lircd.conf

I found a post which mentions adding modprobe lirc_rpi to rc.local, here: Rpi2 OSMC Alpha 4 and IR GPIO (thx. DBMandrake)

dmesg now shows lirc.

osmc@osmc:~$ dmesg |grep -i lir
[ 6.245700] lirc_dev: IR Remote Control driver registered, major 247
[ 6.298511] lirc_rpi: module is from the staging directory, the quality is unknown, you have been warned.
[ 7.260548] lirc_rpi: auto-detected active low receiver on GPIO pin 18
[ 7.260975] lirc_rpi lirc_rpi.0: lirc_dev: driver lirc_rpi registered at minor = 0
[ 7.260992] lirc_rpi: driver registered!
[ 8.605744] input: lircd as /devices/virtual/input/input0

Here’s the output:

osmc@osmc:~$ sudo systemctl status -l lircd_helper@lirc0

  • lircd_helper@lirc0.service - lircd remote support
    Loaded: loaded (/lib/systemd/system/lircd_helper@.service; static)
    Active: active (running) since Sun 2015-03-15 17:44:30 GMT; 2min 10s ago
    Process: 307 ExecStart=/bin/sh -c /var/run/lirc/lircd-%I.sh (code=exited, status=0/SUCCESS)
    Main PID: 317 (lircd)
    CGroup: /system.slice/system-lircd_helper.slice/lircd_helper@lirc0.service
    `-317 /usr/sbin/lircd --driver=default --device=/dev/lirc0 --uinput --output=/var/run/lirc/lircd-lirc0 --pidfile=/var/run/lirc/lircd-lirc0.pid /etc/lirc/lircd.conf

Mar 15 17:44:30 osmc sh[307]: lircd: WARNING: you should specify a valid gap value

Still no response from the PI2 using a harmony remote sending xbox IR codes.



I enabled lirc gpio in the my osmc menu and placed my lirc.conf in the home folder. Worked with no problems. xbox dvd kit remote on pi.

I have an lircd file from raspbmc on my pi 1.Can I use this for OSMC on my pi 2?

It should work as long as the keypresses are defined as KEY_*****

Thanks for that. I tried and everything worked except for the ‘KEY_ENTER’ command.

I went through the irrecord process again and generated a new lircd.conf file. It didn’t work either. I compared both the old and new files and there’s no difference in the codes between the two files.

It would seem that KEY_ENTER doesn’t work in osmc. Should I be using a different command?



See the osmc remote template in /etc/lirc for an example of the correct key names for basic functions.

BTW you can just edit the key name in your lircd.conf - no need to re-record.

Thx all - I got it working.

Odd lirc doesnt load on startup and needs modprobe lirc_rpi added to /etc/rc.local


1 Like

You don’t need to manually modprobe lirc_rpi - just enable GPIO IR support in the Pi settings module in OSMC settings :wink:

After updating Raspberry pi 2 on 27 Mar IR remote stopped working. Pin out of GPIO is
Pin 1 is DATA, goes to RPi pin 12 (GPIO 18);
Pin 2 is GND, goes to RPI pin 6 (GROUND)
Pin 3 is POWER, goes RPi pin 1 (5V)

Check where you enable ir support (PiConfig) and there are selections for in and out pins, chang in to 18 and out to 17, these defaulted to the wrong pins but has since been fixed. Unfortunately it won’t change what’s already there

Thanks for fast reply, unfortunately didn’t work.

Did you select your remote in MyOSMC remote tab? Not sure what you updated from but remote selection was added to MyOSMC. If you did then let’s start from the beginning, what is the exact remote you have?

It is samsung aa59-00666a, Before on the osmc I would select kodi/lirc.conf when I did it this last time it no longer displays option. I did notice that the file is now in the etc folder.

So were you using the Samsung-lircd.conf file that came packaged with Raspbmc/OSMC? Have you gone into MyOSMC remote tab and selected the samsung conf file then pressed apply?

no i been using the lirc.conf file that I made, when using raspbmc. It had worked fine till selecting manual update in osmc, which is when I notice the change in the osmc remote showing other remote for options.

I don’t know if this matters, but I am having the WIFI problems with the wifi driver also. So when I updated the pi I used the wire and remote was working. However when I went back on the wifi it stopped working.