USB remote not working on boot

I had this exact problem with the RP1, to be honest its why i bought an RP2. The usb remote i have worked for a few weeks, and now every boot it refuses to work until i unplug it and plug in back in. Anyone have any idea whats going on here?

What remote is it?

This one.

Hi, I have exactly the same USB remote and when I have the issue you reported, I just reboot the Raspberry PI+ and then the problem is solved. What I noticed is, that when I see on my Audio (Onkyo) that HDMI is initializing after rebooting the PI, the issue manifests itself. A subsequent reboot w/o the indication that HDMI is initializing solves the problem.It would not surprise me if it has something to do with CEC.

Hope this helps…

Not really but many thanks for your reply. Sometimes a reboot helps but usually not. Has to be a simple fix for this surely.

Hello i have the same remote, but i use also a wireless keyboard.

So, sometimes in ALPHA 4, IT DOESNT WORK. I have to reboot via Keyboard and than it works.

Try also to change the battery


Battery is only a few weeks old, additionally it always work is the USB is unplugged then re attached, but this is an UTTER nuisance.

For me it works well.

I advise you to plug in a wireless keyboard to support the remote.

I can confirm this issue too. I observed the same problem.

Forgot to mention that I changed to OpenElec as the Volume-/- button with this USB Remote Control doesn’t work with OSMC Alpha4 (which is pretty annoying). I hope this will be resolved in the imminent OSMC RC version to be released tomorrow night (if everything goes well… :smile: ).
And yes, the behavior with this USB remote is the same on OpenElec.

It’s fairly simple to edit the file that controls what remote presses do.
The command ‘irw’ in a terminal will show you what the system is seeing when you press a button. ( Ctrl-c to exit )
The file remote.xml in /home/osmc/.kodi/userdata/keymaps/ is the one to edit.

Has anyone tried setting HDMI_IGNORE_CEC=1 in /boot/config.txt?

IF* there is any relation to CEC, perhaps disabling CEC in the pi’s settings could help with stability?


It probably won’t change in release unless someone with this remote comes up with the needed button mappings. I don’t think any of the dev team use this remote. Most are using a gpio setup.

As far as needing to unplug/replug it sounds like a timing issue relating to lirc/usb initialization, from what I can see no DEBUG logs or syslogs have been submitted

I have the same remote and have the same problem, but I’m still running Raspbmc.

This is the log section where the device is opened, but doesn’t function:

11:59:35 T:3037995008    INFO: Found input device /dev/input/event0
11:59:35 T:3037995008    INFO: opened device 'HID 1d57:ad02' (file name /dev/input/event0), m_bSkipNonKeyEvents 0

This is the log section where I remove the remote and plug it in again because it wasn’t working:

12:00:49 T:3037995008    INFO: input device was unplugged HID 1d57:ad02
12:00:55 T:3037995008    INFO: Found input device /dev/input/event0
12:00:55 T:3037995008    INFO: opened device 'HID 1d57:ad02' (file name /dev/input/event0), m_bSkipNonKeyEvents 0
12:00:55 T:3037995008    INFO: Found input device /dev/input/event2
12:00:55 T:3037995008    INFO: opened device 'HID 1d57:ad02' (file name /dev/input/event2), m_bSkipNonKeyEvents 0
12:01:00 T:3037995008   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x0000, modifier: 0x0
12:01:00 T:3037995008   DEBUG: OnKey: return (0xf00d) pressed, action is Select

That’s the first “OnKey” entry in the log, even though I mashed plenty of buttons on the remote before I unplugged it.

Oddly, I used this remote for a month before this issue came up. However, it seems to be present with both OSMC and Raspbmc

Sorry to barge in on this thread, but I thought this information might be useful.

No thats great, hopefully a developer will see that and be able to help.

Also i experienced the exact same thing. About a month of it working fine, then this.

Bump on this, hoping this issue will be addressed in the next version.


Indeed, none of us have this remote so can’t help you here. Provided it really needs remote codes, and not key presses, lirc should let you record a config.

Thanks, but this is obviously an issue with USB rather than with a specific device.