RC install freezes at 10%

I apologize for posting this to the wrong topic initially, but I don’t know what “… using flag in the title, for specific issues” means.

I installed the RC for the Raspberry Pi (not 2) via the Linux installer and the SD card booted, formatted the disc and began “Installing files.” It gets about 10%, I’d say, and stops. I left it there for a good half hour with no change…

I am installing the Alpha 4 release from the installer now and it seems to be working fine (at 22% and climbing) - I had initially installed this from the disk image, so I wanted to make sure it wasn’t the installer.

I’m getting the same issue. My guess is it’s network related. I tried using the windows installer on the RC, and plugged it into my RPi with a wireless dongle, and it froze at ~10%. I then downloaded the disk image and flashed with Win32DiskImager, and got the same result - even though I’d never entered my wifi details into the disk image.

I then plugged the RC into a wired network, but unfortunately didn’t have a TV near there. I waited 30-60 minutes before unplugging it and connecting it back up to a TV, and got some “kernel panic” error - it won’t boot.

Have you tried a different sd card?

Check your power supply and SD card. OSMC doesn’t need a network for installation (unlike Raspbmc), but low power to connected peripherals can cause issues


I’m getting the same result. Tried 3 times reflashing with the installer, and twice reflashing from the image itself but always stops at “installing files” at around 10%.

I also tried a different power cable, connected it directly to a 1A USB plug and tried a different SD card. I can’t see a log file on the card.

When I power down and try again it starts the installation process again, with formatting then installing again and freezes at the same point.

Where would I find a log file or something that might help troubleshoot?

Check in the boot partition (the one you can see in Windows) for a file called install.log

There’s no install.log

A 1amp adaptor is not sufficient for a Pi 2. A hard freeze during the installer is almost certainly going to be caused by insufficient power - the Pi 2 is a lot more demanding than the earlier models on power, and the new installer uses more CPU power.

You could try the install without any extra USB devices connected (if you have any) - if that works it’s definitely power related.

It’s a Pi1, with OSMC RC

I would still try a better power adaptor. These images have been tested in house and boot fine so the only difference between our test devices and yours will be hardware related.

OK I tried with a 2.4A adaptor, and even tried with another RPi1. Still halts at 10%. No install.log.

How do you know it’s 10% ?

The latest installer does not display a percentage, only a progress bar. Are you sure you’re installing the latest release ?

Is your Pi 1 a model B or a B+ ? If a model B is it 256MB or 512MB ?

rbp1 and rbp2 images are not interchangeable. You must use the image specific to the device you are using. Not sure if you were already aware of this or not. Just making it clear here.

Same issue here on Pi 1 a (256MB) and OSMC-RC… All alphas before worked flawlessly…

Stuck at this position of the progress bar… no log-file on SD-card…

Just tried this:

Got the Windows installer from the osmc.tv site
Chose Raspberry Pi 1
Chose RC
Thing copied fine to the SD card
Put the thing in the Pi and booted up.
Ran through install without issue.

To the guys in the topic that are having problems, which installer are you using? and have you downloaded the latest one from osmc.tv?

I have the same Issue on my PI B. SD Card was prepared with the latest Mac Installer.

Same issue here, tested both Mac OS X and Windows installer, newly downloaded.
RPI model A, SD card, wired connection, no other peripherals connected

Need to know the following things from the people reporting this “10%” problem:

  1. Did you re-download the latest installer
  2. Which installer - Mac/Windows/Linux
  3. What install type - SD, USB, NFS
  4. Exactly what model of Pi - A, B 256MB, B 512MB, B+ or Pi 2