'Read rate too slow for source' (or similar) message during fast-forward of 720p X264 video


#1

Hi @sam_nazarko, et al,

Over the last two nights, I’ve seen the following whilst fast forwarding (tapping the Osmc remote’s Right key) whilst playing 720p X264 video:

‘Read rate too slow for source’ (or similar).

I’ve not experienced this message before, and so far not during normal playback. Cpu loads and drive throughput look fine (checked via ssh).

I’ve not yet updated to the latest release, and nothing in the setup has changed at all since the bluetooth A2DP drivers were removed 15 days ago (YouTube playback - random blank video with 'input not supported' monitor message)

Everything’s been fine until yesterday (although the system froze after an ‘update is ready’ message was displayed just as I was starting playback).

Playback is from a veracrypt partition on a 6TB usb 3 hard disk (the main drive I use with the Vero). This drive, with the same version of veracrypt, has been in use since May last year.

sudo uname -a :

Linux Osmc_Vero_4K 3.14.29-132-osmc #1 SMP Mon Nov 26 00:05:01 UTC 2018 aarch64 GNU/Linux

Logs uploaded to:

Https://paste.osmc.tv/yosozejuga

Many thanks in advance,
RR


#2

What is the underlying filesystem on the drive?

Sam


#3

Hi Sam,

It’s NTFS. Same setup as in use for many months.


#4

Hi RR

Can you show me your fstab mount again. I suspect you’ve done this before – apologies.

NTFS throughput via FUSE leaves much to be desired.
If you only wish to access the disk in an RO manner, there is a potential for speed improvement; but we are in need of some testers.

Cheers

Sam


#5

Hi,

Sure.

Drive is already mounted RO to ward off corruption.

Can you remind me of where fstab is? I can’t locate it in my bash history, so probably haven’t provided this to you before now.

Do you want an example of the veracrypt mount command from the bash script I use? I’m not automounting the veracrypt side of things via fstab.


#6

Btw I’ve just realised it’s past 2 a.m. Happy to leave this until a more practical time for you to look at it.

The core command in the script which mounts the veracrypt partition, after osmc automounts the drive itself, is as follows

veracrypt --non-interactive --mount-options ro --mount --password="$thepassword" -k "" /dev/disk/by-id/usb-WD_Elements_XXXX_XXXXXXXXXXXXXXXXXXXXXXXX-0:0-part1 /mnt/vc/veracrypt3


#7

/etc/fstab


#8

Ta,

cat /etc/fstab

# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root  /    ext4      defaults,noatime    0   0

#9

You are not mounting the drive via fstab. It’s being mounted by the veracrypt command.

The encryption is probably slowing things down, and with the additional overhead of ntfs I’m surprised you haven’t had problems before.

You could test the read rate of the drive using dd. Something like this:

dd if=/mnt/vc/veracrypt3/some_large_file.mkv of=/dev/null status=progress

and share the results.


#10

Hi @bmillham ,

Yep, I’m not mounting via fstab, only via a bash script.

I made an error earlier; the files are 1080p not 720p.

I’ve run the dd test on a 3.27GiB mkv

3500524032 bytes (3.5 GB, 3.3 GiB) copied, 167.014 s, 21.0 MB/s
6875074+1 records in
6875074+1 records out
3520038132 bytes (3.5 GB, 3.3 GiB) copied, 167.923 s, 21.0 MB/s

(Assuming you don’t need each individual progress entry, but I have them if needs be).

21 MB/s isn’t blazingly fast, however the setup is unchanged since last May, and i have files with far higher bitrates than this. Very odd.

Also, I can’t currently reproduce the issue by randomly seeking back and forth through the files.

[Edit] Here’s a screengrab of dstat during playback of the same file


#11

That speed is horrible for a directly connected drive! I just tested from my Vero 4K (not +) and get

6348455936 bytes (6.3 GB, 5.9 GiB) copied, 177.384 s, 35.8 MB/s

Does the problem happen on new files only or also on ones that you’ve played before?

Have you updated veracrypt lately?

mediainfo on one of the problem files may help.


#12

These files have been on the disk for a long time.
Via usb 3 the drive averages 140MB/s (I know the vero is usb 2)

21MB/s should still be more than adequate, should it not?

I haven’t updated veracrypt since it was installed.

Tomorrow I’ll run a dd test on a non-encrypted drive (also ntfs). Thanks for your assistance at this late hour.


#13

A better test would be to copy one of the problem files to the non-encrypted drive and see if it plays OK from that one. Then we would know if it’s the file or the encryption causing the problem.


#14

Sure, I can do that. It’s very difficult to replicate the problem, unfortunately.
It can’t be coincidental that I’ve only seen the same error twice, two nights in a row, on the same setup I’ve been using for 8 months. Intrigued to see what’s at the bottom of this one!


#15

21MB/s should be good enough to watch a 4K film.


#16

Possibly interesting refresh rates in your file, can you post a MediaInfo?


#17

Thought so.

I’ll ssh via a pc and check top, dstat and other tools during playback tomorrow (can only open one ssh at a time on this tablet)


#18

Cool – keep us posted.
Have a good night.


#19

Will do, probably late afternoon or evening tomorrow (insomnia isn’t getting any better…)

Thanks for the assistance @bmillham and @sam_nazarko


#20

Have a good night yourself (do you ever sleep?!)