'Read rate too slow for source' (or similar) message during fast-forward of 720p X264 video

#41

I keep meticulous notes on changes I make in my systems (was a coder by trade before recent severe illness).
I cannot locate any changes that account for these messages apparently spontaneously appearing after all these months.
Coincidences happen; humans are pattern seeking creatures; however, two nights in a row - there has to be a trigger.

I’m glad veracrypt has pretty much been ruled out, given that two or three others are seeing the same issue (and reports of it on non vero hardware also).

#42

Trust me, you won‘t find it. I am onto this problem for 6 months now. The fact that even now I am unable to recreate it on purpose says it all. It is mostly random and the message never makes sense anyway.

Then I spent my time finding a way to disable that message. No luck either. I just want the message gone but there simply is no option for that, even in advanced settings.

Asking for help is frustrating too because people believe you have a problem with the speed of your connection or hard drive. People don‘t read what you write, even Sam didn‘t really. IT IS NOT A SPEED PROBLEM. But even if people read that, they have no answer because this message is usuall associated with buffering problems on internet streams (usually illegal ones), not with local streaming.

So in the end, there is not much you can do besides making one change at a time and then play content for some days or weeks to find a pattern or not.

I actually gave up some weeks ago…l until I read your post and it got me started again,

1 Like
#43

Sorry to hear that it’s been a long and fruitless quest for you. I know the frustration of trying to recreate elusive bugs, and not being able to discover the underlying cause.

One thing I must say though, @sam_nazarko works absolutely tirelessly, and has come through for me in more ways than one, many times.
I haven’t regretted my vero4k purchase for a second. It’s by far my most highly used gadget.

#44

Yes Sam is great, that is why I didn‘t want to bother him with this problem any longer. Because I really doubt it has anything to do with osmc or the Vero 4k.

Kodi 18 is coming soon and we should test if the message still occurs there. aif so, then we have many additional options because nobody is going to fix something in Kodi 17 NOW… or even try to have a look on the matter,

1 Like
#45

I completely agree.
Looking forward to Kodi 18, if only for possible Netflix apps due to drm support…

1 Like
#46

Hi guys,

Are we now just talking about the display of this message?
Because if we are, I can tell you why it is appearing.

There are changes to buffer far less aggressively by default and only ramp up when we are busy. This was introduced around July (IIRC). This coincides with @Nickelig’s 6 months.

So any marginal bandwidth scenario will present it.

I think we should adjust the Slow Source message to reflect the recent changes to buffer handling. We can also defer it to logging; as that is going to be requested in the event of a playback problem.

I’m cautious to remove this if there are problems, however.

Sam

2 Likes
#47

I’ve seen this message with no actual playback problem since I bought my Vero 4K in November of 2017. Again, I’ve seen it when the entire video has already been cached (timeline bar on Titan skin displays cache ahead in a different color), so it can appear when there isn’t even any network usage required.

I’ve always written it off as a very hard to reproduce Kodi bug. It only happens a couple of times a month, doesn’t affect playback (other than the message display), and isn’t anything I even considered reporting as a problem.

It should always be logged, of course, but not displaying the message would be nice. If the source really is too slow for the request (either regular playback or a skip forward), then the video will stutter, and the user will see the “Buffering” message. I have never seen the “Buffering” message when the “Slow Source” message appears. Or, add an option to control the display of the “Slow Source” message.

2 Likes
#49

Thanks Sam, you now got the issue. It is about the message itself and nothing else.

It would be awesome if you could make an option for the message. No need to remove it completely (as it is probably important for internet streams) but really annoying if there isn‘t an actual issue. Maybe an option to remove it from popping up on local disks / local network playback.

No idea what changes with Kodi 18 but the message can really be a turn off. It is super annoying and bothering me alot when it happens. And knowing my network is super stable and seeing that everything is working smoothly and very responsive, this message is a huge downer for me.

1 Like
#50

I’ll remove this message; or rather, make its display more relevant.

4 Likes
#51

For me the message lead to another full hard disk integrity check, and a bitwise comparison of the drive against its (manually) mirrored backup (the same process which I undertook before the stuttering issue due to Bluetooth audio drivers was resolved).

On 6TB drives, even via usb 3 on a reasonable PC, this took two days.

If the message is genuinely misleading, then suppressing it would be welcome. If there’s an underlying issue, however, then (speaking as a developer) I’d like to know about it.

#52

Yes the message is very misleading and had me spent so many hours looking for a problem that does not exist.

Anything that pops up during playback is very intrusive and can‘t be easily ignored.

I might suspect that my usb gigabit lan adapter might cause an „marginal event“ as Sam called it but really the performance itself is brilliant. And the same probably for people who use an ntfs formatted disk via usb, which might also cause an „marginal event“. Both have in common that the data goes through usb instead of the internal lan port, so maybe there lies the marginal event… but regardless, the message should not be there.

Thanks Sam for removing the popup. Looking forward to this update :slight_smile:

1 Like
split this topic #53

A post was split to a new topic: Audio/Video Stuttering on a single movie

#54

Will the issue be resolved with the Kodi 18 release? The message is really annoying again and I really hope you remove the message with Kodi 18. I understand you didn‘t fix it with the current old build but I hope the message will be gone with Leia.

#55

It’s not actually an OSMC issue…I see this on my PC running Kodi 17 as well. I agree it’s annoying, and the OSMC team might find a fix for it, but if they don’t, I certainly don’t blame them for not fixing a bug in code that isn’t theirs.

#56

It will be fixed.

1 Like
#57

Hi

Hopefully the issue is now addressed

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

#58

I actually never had the issue after updating to Kodi 18, but maybe I just had a lucky streak.

#59

Hi,

I’ve not upgraded past the December release - is this an issue?

Also, I’m still having intermittent outages with the power supply here; as a result I’m using any electronics as little as possible, which will delay testing. Apologies for this,

RR

#60

This was an issue before the April update to Kodi 18. I frequently experienced this with the last Kodi 17 update (December) but I have not seen it since updating to Kodi 18. But like I said above, maybe it was just luck.