Really basic remote questions - volume up/down?

For others trying this an easier way is to edit /etc/lirc/osmc-remote-lircd.conf and change KEY_REWIND and KEY_FASTFORWARD to KEY_VOLUMEUP and KEY_VOLUMEDOWN if you save it as osmc-remote-lircd_VOL.conf or whatever it will never get overwritten. You can now choose the modified conf file in MyOSMC

I’m going to add support volume up and down during playback using arrow keys

1 Like


If it is on FF/REW instead, then it can be global, not just in the fullscreen playback screen. I never use FF/REW - I wonder if others do…



is there the possibility that the Kodi17 do not longer look on the /.kodi/userdata/keymaps ?


No, this should still work

it works in the current Kodi 17.0 Beta 5, on my install.

I currently have my system mapped so that on the OSMC Remote:
a) Full screen video: up/down=volume up/down
b) Full screen audio/visualization: up/down=volume up/down and left/right=prev/next song

On my VERO 2

I created the file ~/.kodi/userdata/keymaps/customkeymap.xml
with the following contents:

   <key id="166">volumeup</key>
   <key id="167">volumedown</key>
   <key id="168">skipnext</key>
   <key id="169">skipprevious</key>
   <key id="166">volumeup</key>
   <key id="167">volumedown</key>

When using this configuration on my Vero 2, it works well IMO.
The only problem so far, is that many skins do not automatically use the Visualization screen when playing music. This could be a good option for the OSMC skin setttings.

Muting would be another nice option. A “long press” would probably be the best way to handle it.

Note: That config file may not work with a Vero 1 remote. I have no way to test that.

Sounds like a great solution Spinner! But how can I create this file?

There’s some info on editing files at the Wiki. If you still have problems let us know what you tried

I’ve solved it with the keymap editor add-on.

This way I didn’t have to mess up my brand new Vero 2 device with creating files myself.

Thanks a lot!

I have a follow up question there. So I modified the up/down arrows in ~/.kodi/userdata/keymaps/remote.xml for VolumeUp and VolumeDown (on my Rpi3). It works like a charm, no problems here. However, I would like to have the rewind/fast forward buttons have this function globally. So I set the “forward” and “reverse” in the “global” section to VolumeUp and VolumeDown and I can control the volume anywhere. However, unlike the arrow buttons, the rw/ff buttons do not repeat automatically, i.e. I have to press 50 times to get the volume from 50% to 100%. How can I change this? @sam_nazarko this isn’t a hardware feature of the OSMC remote, is it?


I don’t quite understand the question.

We have a pretty aggressive repeat filter in OSMC. Are you saying that repeat presses aren’t coming in when you think they should be?

Yeah, so at the moment, I have Volume up/down set to both up/down and rw/ff buttons. For the rw/ff buttons, I cannot press+hold to change the volume, but rather have to press repeatedly. For the up/down arrows, it works as expected.

Okay, I see what you mean.

Can you post your remote.xml, and explain how I can easily test this out? Then I’ll see if we can make some improvements here. It’s going to be a busy weekend, so I might not be able to get back to you until Monday afternoon.



Sure, it’s quite long, so I uploaded it on my dropbox: Dropbox - Error

I just took /usr/share/kodi/system/keymaps/remote.xml and changed 4 lines:

Lines 28-29: (Global section)


Lines 189-190: (Fullscreen video section)


To test it, just play a video and try to change the volume with the up/down and the forward/reverse buttons - they should show the same behaviour, but for me, they don’t, as described above (forward/reverse do not repeat when keeping them pressed).

Thanks and don’t worry, I can wait till Monday :slight_smile:


Long presses of up/down control volume by default. Try reverting your up/down added mappings ten try long press of up and down arrows, I think you’ll find they still control volume on long press

To prevent confusion…
I just removed my custom keymap to test that on Krypton v17.
Long presses don’t do that on my Vero 2 with OSMC RF remote.

Unfortunately I don’t have a Vero 2 or an RF remote. I do know it works on my PC with a media center remote

1 Like

Yeah, I suspected it was a device specific config.
I thought I may as well test it to see if it’s changed with recent updates, in the hope I could delete my custom mapping.
If I remember correctly the OSMC remote’s input is handled differently in some way.

Have you had a chance to look into this, @sam_nazarko?