Reboot required after reindex


#1

For the last month or so my Vero 4k has started playing video in background, which is a stunningly useless feature. More specifically, if I select a new file that has been added to the library, an indicator appears to tell me it is playing, and how far it has progressed, but the screen stays on the menu rather than switching to the movie. A reboot or Kodi restart cures the problem, but I’m sure that should not be necessary. If there a skin or video playback setting that triggers this?
I checked on the Kodi Forums in case it was a more general error but can’t see anything relevant. Has anyone else seen this issue? Software is current 4K OSMC release.


#2

Hi,

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Tom.


#3

Which skin are you using?

Sam


#4

I have been experiencing the exact same issue for a few months. I press play and the play icon shows but the film doesn’t actually become visible or audible - but does seem to be playing silently and invisibly in the background… Only a reboot fixes it.


#5

Which skin are you using?


#7

Hi Sam. I am using Estuary. It all worked fine until 2-3 months ago and I am not aware of changing anything.


#8

I’ve just tried switching to the new OSMC skin to see if it makes a difference and now when the error occurs it displays “Buffering…” in the top right corner. But it never actually starts playing. That may give some more insight


#9

We need logs in order to have any clue what the issue may possibly be.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/


#11

OK the error is still happening so hopefully this log captured it.

The reference is [https://paste.osmc.tv/epofoqovot]


#12

Hi,

You can have debug logs on all the time and have it not show on the display, until you capture the error. Enable debug logs and set debug level to 1 in advancedsettings.xml:

<loglevel>1</loglevel>

Thanks Tom.


#13

Hi Tom

Sorry but my knowledge of Kodi is quite limited. How do I find and edit advancedsettings.xml?


#14

Hi,

Tom.


#15

For the short time, you could just enable debug logging via Settings -> Logging and deactivate it after reproducing the problem and uploading the logs.


#16

I carefully set up logging and read new files into the library but could not trigger the fault. Will leave logging on for a few days. Skin is OSMC default. Build is latest production release plus SMB and VNC.


#17

Hi Sam

Assuming I did it correctly then that is what I did for my log file [https://paste.osmc.tv/epofoqovot]. Has it captured my starting and stopping a film, that did not actually play? The buffering message seems related.


#18

Hi,

Did you reboot before uploading logs? If so it looks like debug logs were not enabled.

No settings file to load (special://masterprofile/advancedsettings.xml)

Doesn’t look like the advancedsettings.xml file has been created correctly.

Please issue:

cat /home/osmc/.kodi/userdata/advancedsettings.xml | paste-log

And post the provided link.

Thanks Tom.


#19

Hi Tom / Sam

Sorry if my log didn’t work.

Do you mean that I should enable logging as per Sam’s suggestion but then

reboot before uploading logs

Perhaps I am being dim but I thought the link to creating an error log suggested:

  1. Enable Debug logging via OSMC
  2. Reboot
  3. Wait for error to occur
  4. Upload log via OSMC

Should I have rebooted again between steps 3 & 4?
Also should I have enabled all the sub options in the debug log menu?
I must admit the instructions were a little vague to me although that could be because I am definitely a Kodi newbie.


#20

Hi,

No what mean is did you reboot after capturing the issue?

Thanks Tom.


#21

No, I didn’t reboot after capturing the issue.

Are you saying I should reboot twice - once when I enable logging and again after the issue occurs but before I submit the log?


#22

Hi,

Sorry was missreading the log, this stands out:

18:58:35.450 T:3846529792    INFO: CNFSFile::Open: Unable to open file : 'volume1/Video/Movies/Lady Bird (2017)1080p BluRay H264 AAC.avi'  error : 'open call failed with "NFS: Lookup of /Movies/Lady Bird (2017)1080p BluRay H264 AAC.avi failed with NFS3ERR_NOENT(-2)"'
18:58:35.450 T:3846529792   ERROR: Open - failed to open source <nfs://192.168.0.136/volume1/Video/Movies/Lady Bird (2017)1080p BluRay H264 AAC.avi>

Can you play that movie locally or on any other device?

Also you should have more luck with fstab mounted shares:

Thanks Tom.