Reboot required every day prior to playing 4k

#1

Ok, so this is a weird one. It’s not a deal breaker since it’s so easy to remedy, but it would be nice to find a fix. Issue is that every day when I go to playback any 4k movie, they start for about 5 seconds then immediately go to stuttering/buffering and its hopeless. No issue with 1080 stuff. Whats weird is that a simple reboot of the Vero and everything is quite literally 100% perfect. Rinse/repeat every single day though… and it’s identical scenario on both my Vero 4k+ and Vero 4k. Here is an overview of my setup for both rigs…

-Stock OSMC images, fully up to date (no customization beyond settings below)
-Source for years is NAS NFS share over AC wifi mounted with AutoFS
-Kodi set to 1080p 60
-Adjust display refresh rate set to start/stop

I will work on getting some pre and post reboot logs, but I just wanted to get this started in case it was a known easy fix. Thanks all!

#2

Nope. Logs needed, please.

1 Like
#3

Next time it does this I would (without rebooting the Vero first) go to the MyOSMC app and disable the wifi, wait a couple minutes, and then turn it back on, and then try to play the same video again. If that clears the issue then you might look for any available firmware of setting tweaks on your router/access point.

#4

Good idea to try… I do have a high end router (Asus RT-AC88U) with the latest FW, but still something to try. Since I have already rebooted today, I will get logs and also try this tomorrow. Thanks Gents!!

#5

Sorry for the delay… I wanted to give it a couple days to do what it does…

-2 day idle (only usually takes one though)
-Fired up a UHD. Slideshow, then buffering
-Collected logs: https://paste.osmc.tv/baqaborila
-Turned off wifi adapter, turned back on, tested, no change
-Reboot
-Fired up same UHD. Smooth as glass and can even skip ahead quickly without incident etc
-Collected logs: https://paste.osmc.tv/zuwasipusu

As stated before, identical issue on both my 4k and 4k+ (these logs were collected from the 4k+)

Thanks gents, Cheers!

#6

What are the WPA settings like for SSID: teknishn

#7

WPA2-Personal AES

#8

It does seem like the issue gets worse progressively. For example… 24hrs of idling, start movie, it will actually play clean for 20s before going to buffering and freezing. After 48hrs of idling… it just starts right out into a slide show and buffering within 5 seconds.

One more note on the router… its an Asus RT AC88U. I also had the same issue on my prior router which was an Asus RT AC3200.

#9

I’d suspect a WiFi issue.

What we could do as a quick workaround for you is turn off networking during suspend, and turn it back on when you wake the device

Would this be satisfactory?

#10

Does rebooting the router also clear the issue?

#11

Sam, I did test disabling wifi adapter, give it a few, re-enable, then try to run movie… it didn’t help. The reboot does every time though. But yes, to answer your question, I have no problem turning the network off during suspend… or turning suspend off for that matter if that’s another option.

bmillham, I will try that out, but I will need to wait until tomorrow for an effective test since I recently rebooted

#13

A couple of points:

1 Your Vero is talking to the router on both 2.4 GHz and 5 GHz and using the same SSID for both bands. But I also noticed this:

Sep 08 16:44:07 osmcht wpa_supplicant[469]: wlan0: Trying to associate with 38:d5:47:bd:ac:b8 (SSID=‘teknishn’ freq=2427 MHz)

and later

Sep 08 22:31:09 osmcht wpa_supplicant[469]: wlan0: Trying to associate with 38:d5:47:bd:ac:b8 (SSID=‘teknishn’ freq=2412 MHz)

It looks to me like the router is automatically channel hopping, at least on 2.4 GHz. The first one it chose was channel 4, which is an “in-between” channel and likely to perform poorly. I’d suggest that you choose a fixed channel and have separate SSIDs for 2.4 GHz and 5 GHz.

2 If it’s configurable on the router, try to turn off the group rekeying function. It’s not required here and I’ve seen it cause instability problems in the past.

#15

Interesting. Ok, the Asus routers have a feature that basically combines all the radios into a single ssid, and I do have that enabled. I will kill that and setup on 5ghz only and re-test. I’ll post an update tomorrow after I give it a day to idle etc.

Thanks guys!

#17

Do you by any chance have your osmc go into standby mode after long inactivity ? I had a similar problem due to some issue where osmc would crash during standby mode, and kodi is restarted but standby mode was not exited correctly. Result was that kodi reacted a bit sluggish, and playing content would stutter. Only way to fix it then was, start to osmc standby mode and exit it again, or by rebooting.
However I didn’t experience this problem anymore since I completely reset my user profile and only installed those addons I really used…

#18

Ok, gents… happy to say the wifi changes fixed the problem. I split 5 and 2.4 up and manually set the channel to one that had no activity in the area. Also disabled group key interval. Its been idling for ~24hrs and it plays smooth as butter.

Thanks again, you guys rock!

1 Like
#19

Glad to hear this

#20

I have the same issue as described. It mainly happens on the 4K remuxes with 50+ Mbps video bitrate and TrueHD audio. After reboot of my OSMC Vero 4K+ no issues.

I am using Plex for Kodi plugin and the Vero is connected wired with gigabit switches to the switch where the NAS is located.

#21

Could you please create a new thread and provide full details, preferably with full logs.

#22

How can it be the same issue if you are not using WiFi?

#24

The part that is the same is that I need to reboot my Vero everytime I watch something with 4K high bitrate material or it will just buffer all the time. And seeing a reboot of the Vero fixes it, it will be most likely something in the Vero causing it. Next time I am watching this type of material will check/keep the logs before rebooting.