Received OSMC wifi-ac adapter - ISSUES


#1

Frustrated. I got the Edimax 7811utc adapter (8812au) up and running easily. The official adapter is giving me a hard time. Sometimes when I boot, after the blue boot up screen, I get a black screen.
When I have gotten the adapter to work, I’m connected, but with no internet.
I am using the exact same setup and power supply I had with the 7811utc (I have it working again)
I have blacklisted the built in wifi and rebooted so the osmc adapter is the only one.

What could be wrong?

Thanks.


#2

Sounds like a possible power supply issue.
If you’re not using a MySQL shared library, I can’t think of any other reason why you’d experience the black screen issue

Make sure you’re on OSMC’s latest update and using a good 2.5A supply. Tablet / phone chargers aren’t good enough. This is why you also had problems with the 8812au in your other post.


#3

I am using a mysql database on the network. the other problem which i didn’t mention, is that the driver doesn’t seem to be picked up during boot (it seems to wait for a network connection due to the mysql database). I plugged in the 7811utc again and remove the osmc adapter, and things are working fine. unless the osmc adapter has significantly different power requirements I can’t see it being the power supply


#4

rebooted with the 7811utc (8812au) installed, the driver is picked up perfectly during boot, no black screen, connects to the mysql database.

the official osmc adapter…can’t get it working.


#5

As @sam_nazarko suggested, it really sounds like it may be a power issue. Different dongles have different power requirements. The easiest thing to try would be a powered USB hub.


#6

I’ve tried 3 diff supplies. A samsung tablet, samsung s7 phone charger, the usb port on an apc surge protector (2.1A), an Aukey quick charger (2.4A). They all work with the 8812au. They all boot to a black screen with the osmc adapter. I did have freezing issues with the 8812au and the samsung tablet charger, but it works fine on the apc surge protector usb and with the Aukey.


#7

And none of those are power supplies, they are chargers. Either try a real power supply, or a powered USB hub.


#8

The Pi has an indicator when it is undersupplied. I have not seen it.

Like I said the 8812au is working fine with 2 different adapters. If the official osmc adapter has special requirements , then it should be made clear prior to purchase.


#9

None of those meet the official specs for the Raspberry Pi 3.

The OSMC WiFi adapter needs a good power supply. I’ve seen issues before with underspecced PSUs causing problems, particularly with USB peripherals.

The 2.5A PSU isn’t a guideline, it’s a necessity, particularly when powering external peripherals.

The official OSMC adapter requires that you are powering your device with an adequate power supply.
The same applies for other adapters.

If you are not doing so you will see issues with the 8812au as well, such as corruption or problems when RIL components are stressed (video playback).

We make it no secret that you need a good power supply for the Pi to operate correctly.


#10

alright guys, you win. been using the pi3 for a few years with these chargers but who knows maybe my peripherals were not high power

ordered this one


#11

added a 5lb bag of quinoa to get free one day shipping. :grin:


#12

Cool, please let us know if it fixes the problem.


#13

It’s better than what you had… but again, the reviews don’t all seem to suggest it delivers enough
power.

But with Amazon you get easy returns, so let us know.


#14

Are there any proven good adapters available in the us?


#15

The OSMC one might be a good choice: OSMC Pi Power Supply

On my Pi2 (with OSMC AC dongle) I’m using the MCM Pi power supply.


#16

I saw enough bad reviews (among many good ones) to cancel the order. For the life of me I can’t figure out why this device was designed with a “standard” microusb port when its power requirements are non standard (5.1V/2.5A). Bought the official one instead (on ebay)

http://www.ebay.com/itm/252305919009


#17

Ok, received the official raspberry pi 3 adapter, and I’m getting the same issues with the OSMC adapter. The 8812au adapter works just as it used to (will check on whether videos freeze up).

a few things happen with the osmc wifi ac adapter that don’t with the 8812au

  1. Sometimes at boot, the adapter isn’t picked up, and it waits for the network in order to connect to the Mysql database i have set up

  2. When I set up the osmc adapter to connect to the 2.4 GHZ band, I get both a LAN AND internet connection, but when I set up on the 5ghz (ac) connection, I get a lan connection but no internet (as reported in settings)

  3. When I reboot after the adapter is set up, I get a black screen.


#18

I’m out of ideas. I have the same dongle on a Pi2 using a shared MySQL database (files shared via NFS) and do not have problems. Hopefully @sam_nazarko will have more ideas.


#19

I’m updating to the July update (I had reinstalled), hopefully that helps.


#20

Good news. Looks like the July update fixed it.

So it looks like
july update + bad power supply didn’t work (obviously)
june version + good power adapter didn’t work
july update + good adapter does work

Not sure what is different in the July update

I will update if I have any more issues, thanks for all the help.