Received OSMC wifi-ac adapter - ISSUES

ok, it’s still working, even on 5 ghz but…

on both 2.4 ghz and 5 ghz, i had a problem where every few seconds, when running an iperf test, i would get 0mb transfer. i assumed this was due to background scanning so i disabled it.

disabling background scanning solved the issue for the 2.4 ghz side. When i do iperf, every second i get the expected transfer rate. on 5ghz however, still every few seconds i get a 0mb transfer rate, as if the connection is dropping out for a few seconds.

any ideas?

Usually disabling background scanning is all you need to do.
Try changing 5Ghz channel.

Also check link rate

Same problem for me with official osmc usb wifi. Ok on 2.4 Status : connected
on 5 (static IP) status : No internet. I can see connection in dd-wrt

Clients
MAC Address Interface Uptime TX Rate RX Rate Info Signal Noise SNR Signal Quality
box-internet-AP wl1 0:08:34 39M 104M HT40 -60 -92 32
80%
osmc-usb-wifi-on-windows wl2 0:06:03 351M 292M VHT80 -69 -92 23
62%
osmc-usb-wifi-rpi3 wl2 0:07:13 40M 6M VHT80PS -67 -92 25
66%
windows-laptop wl2 0:08:04 585M 325M VHT80 -76 -92 16
48%

all computers are in same room:
I tried VHT160, changed channel, no way to get my 5ghz working. no hardware issue, the key has been tested on windows PC

I bought 4 usb adaptaters for all my rpi3… 2 days wasted on this… for something noted ‘ready to use’ on the webshop.

Very disappointed

Hi,

Have you tried adding:

BackgroundScanning = false

to the general section of /etc/connman.conf

Thanks Tom.

Thx but it doesn’t fix the issue.

My config is
router internet box > netgear x6 (repeater bridge) dd-wrt
windows test :
ok conenction direct on router (2.4)
ok connection on dd-wrt (2.4 and 5)
osmc pi3 test:
ok connection direct on router (2.4)
NOK connection on dd-wrt (2.4 and 5) dhcp or static IP

Thx for your help

Hi,

The osmc dongle comes with an auto configuration setup, which in this case seems to have failed. Try:

sudo cp /lib/firmware/mt7610u_sta.template.dat /lib/firmware/mt7610u_sta.dat

And reboot. You should now have a working a connection, if not or not quite the expected speed; Some further tweaking can be done:

I think setting the wireless mode to 13 & setting country code should be enough.

Thanks Tom.

Hello Tom, thx for the trick :slight_smile:

wireless and country code worked.
Successfull with open wifi network, now I have to find settings for wpa aes key coz if I activate it I can’t connect

In comparison with my laptop internal ac wifi or iphone 7, the transfer rate is not huge but I guess for the price I’m satisfied and and can stream 1080p

Thanks again
Eric

Hi,

My router is setup as follows and I have no connection issues:

WPA2-Personal & aes.

Thanks Tom.

You should get about 230Mbps in real world usage with good signal. This should be more than enough for 4K material.

Sam

@Tom_Doyle how should configure the file for wpa2 personal aes settings?

all my tries have failed

thx for your help

Hi,

In the mt7610u_sta.dat only change CountryCode and wireless mode, leave rest as defaults. Now set up the connection via Myosmc including the wpa2 password.

Thanks Tom.

Yes that was my first try but no success. Just got “connection failed”
I tried just WPA rather than WPA2 but no change

Hi,

Try this via the commandline:

sudo rm-rf /var/lib/connman/wifi*

reboot and try and setup the connection fresh.

Also whats the router?

Thanks Tom.

I followed this link Configuration for 5GHz WiFi dongle TP-Link T2UH with driver mt7610u_sta in XBian · GitHub
and set
AuthMode=WPA2PSK
EncrypType=AES

finally working after reboot for now

My router is internet box and the repeater bridge is a netgear X6 under dd-wrt

Glad to hear its sorted.

fail again after a reboot today… that will drive me crazy hhh

Hi,

Should be more stable via MyOsmc as this uses Connman, did you try clearing the wifi settings and reconnecting via MyOsmc?

Thanks Tom.

yes I tried. But I think the connection wifi is done, maybe more about gateway or dns issue… coz when randomly working status internet conection is ok. but main time statut connection is no internet

Hi,

Are you using dhcp? if so try a static IP.

Thanks Tom.

yes I tried both dhcp and static ip. Random working was only with DHCP mode. never got it working with static IP