Received OSMC wifi-ac adapter - ISSUES


#61

yes I tried both dhcp and static ip. Random working was only with DHCP mode. never got it working with static IP


#62

Hi,

Is the wifi stick the only usb device attached?

Thanks Tom.


#63

Did this only become a problem after an update? We recently updated to ConnMan 1.36 and some users reported some issues.


#64

I tried on usb hub with power supply and directly plugged on raspberry pi… same
usb device, I only have this wifi adaptater and usb keyboard plugged.

@sam_nazarko, I received my wifi adaptater 3 weeks ago and had this issue since the first day


#65

What PSU do you have?
Can you post a log (run an Ethernet cable temporarily) when you lose the connection?

Sam


#66

it’s official raspberry pi psu and dlink usb hub.
I don’t lose connection, wifi is connected but I can’t ping the gateway and it’s indicatedon wifi settings screen “no internet conenction”.
If I plug ethernet, wifi indicates wlan0 (connected)


#67

Hi,

I think it may be the WirelessMode, I believe any values after 10 are for AC; so you can try 11 through to 14.

Also you may need to adjust CountryRegionABand= values need to match AC Channels offered by your wifi router:

	    0: use 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165 Channel
		1: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140 Channel
		2: use 36, 40, 44, 48, 52, 56, 60, 64 Channel
		3: use 52, 56, 60, 64, 149, 153, 157, 161 Channel
		4: use 149, 153, 157, 161, 165 Channel
		5: use 149, 153, 157, 161 Channel
		6: use 36, 40, 44, 48 Channel
		7: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165 Channel
		8: use 52, 56, 60, 64 Channel
		9: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 149, 153, 157, 161, 165 Channel
	   10: use 36, 40, 44, 48, 149, 153, 157, 161, 165 Channel
	   11: use 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 149, 153, 157, 161 Channel

Thanks Tom.


#68

Mode AP
Network AC-Only
SSID dd-wrt-5-B
Channel 52 + 54
TX Power Auto
Rate 108 Mbps
Encryption - Interface wl2Enabled, WPA2 Personal Mixed

I can’t find 54 channel
CountryRegionABand is set by default to 7 so it’s ok for 52. I tried wirelessmode 13 or 14


#69

If you can’t ping the gateway, maybe you have an issue with the default gateway. You could try:

route add default gw IP-OF-ROUTER


#70

when running your command:
SIOCADDRT: File exists


#71

Hi,

Now that a connection has been established, it may be worth trying the auto-configuration again.

sudo mv /lib/firmware/mt7610u_sta.dat /lib/firmware/mt7610u_sta.bak

Then reboot.

This is shown to have worked in the link I posted back in May.

Thanks Tom.


#72

Working after retried the auto-confirguration…
I tried a reboot => OK
I tried hard reboot (unplug PSU) => OK

so I use this success connection to check “route”

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default gateway 0.0.0.0 UG 0 0 0 wlan0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
gateway 0.0.0.0 255.255.255.255 UH 0 0 0 wlan0

MAC Address Interface Uptime TX Rate RX Rate Info Signal Noise SNR Signal Quality
24:95:04:F1:3D:4C wl1 2:16:16 13M 65M HT40 -66 -92 26
68%
**7C:DD:90:B7:67:7A wl2 0:06:05 108M 108M HT40 -71 -65 -6 **
58%
28:16:AD:D3:C2:0F wl2 0:34:35 400M 324M VHT80 -65 -65 0
70%
4C:74:BF:D7:B4:C7 wl2 2:12:47 270M 216M VHT80PS -72 -65 -7
56%

the rate is not huge again half of 230Mbps announced by @sam_nazarko
If working tomorrow (XD) I will try Bluray stream

Anycase again a big thanks for your support


#73

You will get 230Mbps in an ideal environment.
Your environment may differ however. WiFi is by its very nature quite hard to troubleshoot.

You will need 40Mbps on a Pi to play back Blu-ray (1080p is max on Pi).

Sam


#74

I’m back after few more test. I think the wifi dongle was set as wifi N and HT40 that’s why lower perf than AC. on ddwrt router I used AC/N mixed mode.

If I set the ddwrt router in AC only mode, I got issue again with wrong IP address allocation (using DHCP)

not working anymore… but working perfectly on my windows XD.

Which settings should I use to force AC mode?


#75

Hi,

That’s strange, is the IP still within the correct ip range / subnet ?

Have you got wait for network enabled?

Also do you get AC if you set a static ip?

Thanks Tom.


#76

DHCP router box range is 192.168.1.20 to 100 255.255.255.0
but I get 169.254.177.12 and 255.255.0.0

I can connect in AC mode only using wirless mode=14 in mt7610u_sta

when I try to set static IP, after click on “apply”, IP address and subnet are reset to wrong IP
In addition default gateway and primary dns are empty


#77

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 wlan0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.1.1 0.0.0.0 255.255.255.255 UH 0 0 0 eth0


#78

Hi,

Whats the make and model of the router, your are running ddwrt on?

Thanks Tom.


#81

Checking with onboard wifi, when the dhcp is OK, I have “Configure Network Manually” with settings set in black police and status connected

So I guess with the wifi usb dongle I’m in manual mode for settings cause I have “Configure Network using DHCP” and it stuck on it so DHCP resolution seems KO


#83

@Tom_Doyle a netgear X6