Recommended ethernet tweaks

I would suggest mounting your shares with autofs and NFS: Mounting network shares with autofs (alternative to fstab)

Hi, thanks. Compared to mounting my shares via NFS in the fstab (as I was previously) - I’m guessing this wouldn’t give a performance gain?

I think the performance is quite similar indeed.

Thanks, yes, I still got frequent buffering error messages when starting movies from my UHD collection, or seeking, when setup like that.

I haven’t seen any anymore, do you also get it when you just play it in one run, with maybe a short pause at the start for buffering?

I recall the movies played fine (except for one file I had which I understand was a higher than usual bit rate). So functionally it was ok. It just was a bit of a chore to have the buffering delay and messages every time we started watching something, and it made fast forward/re-winding a chore.

Do you find fast-forward rewinding of a UHD mkv with HD audio works as you would expect with the built-in ethernet, i.e. without issue?

I know what limitations are, so expect to get a message when I forward or reverse an UHD movie.

I get why it would get to you though, I would suggest an usb2gbit adapter then.
But make sure you get a good one, one that has been tested and has the closest to gbit throughput.

Have a look at this topic: Can anybody recommend a decent gigabit usb adaptor?
Or: Vero 4K USB->RJ45 adapter

Hi - yes I have one already. I’ve been using it happily for a year. I was just curious to revisit whether it’s necessary for a simpler setup.

If fast-forwarding rewinding is problematic, I’m just going to carry on using the USB adapter.

Autofs changes the persistency of the mount vs fstab but once created it is the same mount so there should be no difference in performance. As for the buffer setting it would not be advised to adjust if your currently getting buffer messages. It is already as large as it can sensibly be set aside from maybe increasing the read factor (but that may also make things worse). The internal NIC is limited to 100mb/s max so a Gb adapter connected to considerably faster USB bus will under normal circumstances transfer much faster regardless of any software tweaks.

Thanks. When you say “if” I’m getting buffering messages, does that suggest what I saw is unusual?

I’m confused how anybody else could be playing UHD mkvs and not seeing these messages. Or maybe it’s just not widely reported.

Edit: And yes, definitely will be sticking with the USB adapter.

You have a set amount of bandwidth dictated by your connection, protocol, etc. and if the file you’re trying to play needs more than what you have available, then you get buffering. Some people play highly compressed UHD rips and can get away with a slower connection. That is what I meant by “if”. As far as I am aware it is completely common to have issues a very hard time playing something like a straight bluray rip without gigabit. A large buffer such as what is currently used by the Vero 4K’s in a stock configuration can smooth out variations in your network bandwidth, but it only has enough RAM to buffer a few seconds of a large rip.

I don’t agree, as I have lots of UHD 4K rips, and every one plays flawless on the 100MB connection.

I am talking here about exclusively 1:1 lossless UHD rips, which I make myself using Makemkv.

I’ve no doubt most of them play fine over the 100mb once they get going.

But when I initiate playback or try to skip/rewind there are very frequent buffering messages, and it’s not a pleasant experience (skipping ahead is rather laggy). Whether they are played from an NFS or Samba mount.

The issues all go away when using a USB gigabit adapter.

I have read conflicting opinions elsewhere on the forum too. And am still wondering - if reading lossless UHD files from an NFS share should the experience be the same whether using the built in 100mb port or a USB gigabit adapter? (ie no buffering or lag when initiating videos or skipping forward/backward)

The experiences are certainly not the same for me and while I would have been sure it is just the limitation of a 100mb port, I am now wondering if my unit is faulty.

That’s exactly what all my UHD rips are. I do slightly reduce their size because I only rip English sound and subs,

I never see this. Both starting a movie and skipping don’t seem much slower on a UHD rip vs a DVD rip.

For me, using NFS (and I’ve also tested using SMB) works 100% perfect all the time.

I would doubt that. I don’t have any real idea as to why you (and others) can’t seem to get the same performance using the 100M connection as I do.

I did have an odd occurrence the other day. My 4K did start buffering badly for no apparent reason. I was thinking it had to do with the 4.9 test build I’m running on it. It was getting late, so I decided to look more into the issue the next day and went to bed. In my bedroom I started to watch a movie on my old Rpi, and it was also buffering badly! A quick reboot of the router solved the issue on the Pi and when I tested the Vero again the buffering was also gone.

That was a new one to me. I can’t remember ever having to reboot the router because of network issues.

In practice, the Vero4K/+ provides around 187 MBytes of video cache space. Note that this is bytes.

Any rip that is around 80-85 Mbits/sec will be approaching the limits of the network connection. And being around 10 MBytes/sec, you’ll (in theory) be able to store a healthy 16-18 seconds of video in the cache. The problem is that once you get to the margins of the ethernet adapter’s performance, there will be little or no spare bandwidth available to fill up the cache.

The one thing that has been shown to improve marginal situations is to use a kernel-based mount (either fstab or autofs).

Thanks again. Yes, I also only create minimal lossless mkvs for my purposes (in my case only keeping HD audio and English SRT). I have a pretty solid network setup - gigabit lan powered by Synology routers. Content is served by an SSD Ubuntu NUC server.

Since things work fine using the gigabit USB adapter - all else being equal - I can’t think how these issues could be caused by anything other than hardware limitations of the 100mb port. Whether or not that means my unit is faulty.

Thanks. I see the error messages described above when reading from an NFS fstab mount. Here is my typical fstab entry:

# NAS - Video /nas/nas-video  nfs  ro,noauto,x-systemd.automount  0  2

The error message was always “Source device is too slow” or similar when initiating many different lossless movies (so couldn’t have been restricted to “edge cases”).

So - unless I have some silly NFS options above - the use of fstab doesn’t solve it, at least on my unit.

That would certainly be in line with the video bitrate exceeding the available network bandwidth.

For completeness, any chance of iperf3 stats (both ways), and full logs?

You could try experimenting with different NFS options like: rsize, wsize, noatime, nfsver

The same on your server and check what are the best options with an dd speed test.


My apologies to all in this thread. The internal ethernet connection seems to work fine for me now.

I experimented with it last night, for what must have been the first time in nearly two years, after discovering subpar iPerf3 results for my Anker USB gigabit adapter:

iperf3 -R -t 60 -c
 ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-60.01  sec   702 MBytes  98.1 Mbits/sec  491             sender
[  4]   0.00-60.01  sec   700 MBytes  97.8 Mbits/sec                  receiver

Note the sub 100Mbps speeds and number of retries. Both of which were consistent across multiple tests. The same ethernet connection gives gigabit speeds and no retries on a MacBook Pro. No idea why the USB adapter is not resulting in a boost over 100Mbps anymore (I’m sure I tested this in the past), but I figured I might as well try the built-in ethernet again.

The built-in ethernet resulted in near-100Mbps speed (as expected) but 0 retries:

iperf3 -R -t 60 -c
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-60.00  sec   676 MBytes  94.5 Mbits/sec    0             sender
[  4]   0.00-60.00  sec   674 MBytes  94.2 Mbits/sec                  receiver

I then tried playing a range of my 1:1 UHD rips using the built-in ethernet, and they all started fine without the buffering message I used to see. I couldn’t find a single one that triggered it. Also, I was able to skip forwards and backwards without issue. And even better; playing them via the Plex add-on (i.e. not from an NFS mount) worked absolutely fine too.

Something I need to clear up: I realised last night I had never actually tried the built-in ethernet since changing my network/NAS setup from Synology NAS + AirPort Extreme routers -> SSD Ubuntu NUC NAS + Synology routers. Many apologies - I had incorrectly implied above I had seen these issues in the current setup too.

So it seems that either software updates on the Vero, or my change in Network/NAS have significantly improved things for me, such that I’ll be using the built-in ethernet from now on.

I may still try some NFS tweaks - thanks @Theetjuh - but it no longer seems necessary.

1 Like