Red light on, Vero 4K doesn't start anymore

Suddenly my Vero 4K has no video out, and the red light is on. restarting it just shows the red light, nothing else. I attached a new power supply, as. read on this forum. it could be caused by a dying power supply, but same result: solid red light starting up.

Tried reinstalling wit Han sd card, nothing comes up on the screen and red light stays on. It doesn’t seem to get an IP address(wired connection) from my router either.

Can you take a photo of the power supply you tried?


Ok, fortunately that PSU is also 5V, so shouldn’t cause damage.
Do you have a USB cable that you could connect to a PC? The Vero can be powered by USB cable


Isn’t the Vero a usb master? you can’t connect it as a slave, can you?

Vero has an OTG port.
We don’t drive it this way normally. But it will accept upstream power.

same result, red light and no cdmi signal, no boot.

Does it appear as a device on the PC when plugged in to the white port?
If so – the internal software is corrupted (but can be recovered)

On my Mac it doesn’t mount as mass storage, but the USB listing sees fit as GX-CHIP.

Same on Windows, it’s detected as GX-CHIP, but not mass storage.

That means that the software is simply corrupted, but the device is functional.

It’s pretty difficult for that to happen. Did you try and install any custom software on the device or have a sudden loss of power?

I’ll think about the best way to get this resolved for you. You will need a Windows PC to do this.

Any news on this?

I’ve sent you the instructions on how to fix this via PM.

These instructions were tested by @thansen_dk at the start of the year when his eMMC was also corrupted and we were able to restore his device. Fortunately, you won’t need to short eMMC pins like he did, because your device is not stuck in a boot loop.

After a couple of years using the vero 4k, I am having similar issues as described in here. Suddenly, the vero doesn’t start and the red light keeps on. I’ve tried with a different PSU and also to plug the usb stick with the restoration firmware but the issue persist. There is no screen at all and the TV does not recognize it as a device ON and therefore there is no way to recover it. Maybe the steps you send in here help me to solve it.

What PSU have you tried using? Perhaps you can show us a photo.

It’s a regulable one. I set it to 5V to adjust to the same power as the original one, but the same result.

It’s possible the software is corrupted. You could connect a USB-A cable to white port and connect it to a PC and see if it’s detected.

I’ve tried using a usbC to usbA and connecting to the laptop and doesn’t seem to be recognised. At least I cannot see any new mounting drive in the laptop neither in the devices administrations.

If it is a Windows 10 system you tried, you should hear for short moment the audio signal typically played when you connect a USB device. Afterwards you should see in the device mgr a greyed icon for this unknown device:

You can right click on this item and do an uninstall if you want to repeat this procedure to be sure.