Remote CEC-HDMI broken after last update (RPi2) (libcec.so.3.0 missing)

Got the automatic update info on the screen this morning and clicked on update/restart now.
After the restart my Samsung remote (LN52A550) stopped working and I now have to use a wifi Kodi remote via IOS/Android.

The kodi.log shows:
11:53:01 19.053682 T:1958011440 NOTICE: Starting Kodi (16.0). Platform: Linux ARM (Thumb) 32-bit
11:53:01 19.053762 T:1958011440 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
11:53:01 19.053850 T:1958011440 NOTICE: Kodi compiled Feb 21 2016 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.7 (200711)
11:53:01 19.054243 T:1958011440 NOTICE: Running on Open Source Media Center 2016.02-4, kernel: Linux ARM 32-bit version 4.4.3-3-osmc

11:53:19 27.022350 T:1958011440 NOTICE: Found (1920x1080@60.000000) at 22, setting to RES_DESKTOP at 16
11:53:19 27.022610 T:1958011440 NOTICE: Checking resolution 23
11:53:19 27.138382 T:1958011440 NOTICE: GL_VENDOR = Broadcom
11:53:19 27.138563 T:1958011440 NOTICE: GL_RENDERER = VideoCore IV HW
11:53:19 27.138651 T:1958011440 NOTICE: GL_VERSION = OpenGL ES 2.0
11:53:19 27.138725 T:1958011440 NOTICE: GL_SHADING_LANGUAGE_VERSION = OpenGL ES GLSL ES 1.00
11:53:19 27.138834 T:1958011440 NOTICE: GL_EXTENSIONS = GL_OES_compressed_ETC1_RGB8_texture GL_OES_compressed_paletted_texture GL_OES_texture_npot GL_OES_depth24 GL_OES_vertex_half_float GL_OES_EGL_image GL_OES_EGL_image_external GL_EXT_discard_framebuffer GL_OES_rgb8_rgba8 GL_OES_depth32 GL_OES_mapbuffer GL_EXT_texture_format_BGRA8888 GL_APPLE_rgb_422 GL_EXT_debug_marker
11:53:20 27.796072 T:1958011440 ERROR: Unable to load libcec.so.3.0, reason: libcec.so.3.0: cannot open shared object file: No such file or directory
11:53:20 27.796314 T:1958011440 ERROR: Initialise - failed to initialise bus cec

I followed instructions to power off the TV for a while (7min), power on TV and wait another 2 min … then turn on the RPi… but still, the remote via CEC does not work
Would be great to get a fix soon.

Did you search?

Sam

I only found these:

/usr/osmc/lib/libcec.so
/usr/osmc/lib/libcec.so.3.1.0
/usr/osmc/lib/libcec.so.3

But no libsec.so.3.0

Remote was working fine until this last update.
And maybe I am spoiled by the quality of OSMC as I never really had a problem after an update.
Thanks!

If you choose to view “latest” posts on this forum you’ll find resolution to your issue from mere hours ago…

1 Like

I mean did you search the forum?

A solution was posted about three threads below yours at the time.

1 Like

Sorry, did a forum search, but it slipped. Looks my eyes are getting to old for this stuff :sunglasses:

It’s OK

Try the instructions, report back if you continue to have issues.

Followed instructions and all is fine again!

sudo apt-get update
sudo apt-get install --reinstall rbp2-libcec-osmc=3.0.1-16

Thanks

Hello,
To solve this recent CEC issue, I tried the following command on my raspberry pi 1:

sudo apt-get update
sudo apt-get install --reinstall rbp1-libcec-osmc=3.0.1-16

Unfortunately, I’m getting an error message stating the package is not available.
Can anyone help?
Thanks!

Same problem here. tried the commands but still cec is not working. I am on Samsung 48h6200. Any ideas?

I get error

E: Version ‘3.0.1-16’ for ‘rbp1-libcec-osmc’ was not found

I have connected my Pi3 to Sony Bravia TV without mouse or keyboard. I don’t have a USB mouse and keyboard but can connect to the Pi3 by SSH.

I cannot use my TV remote nor can I use Airplay. Any help of how to enable both.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request