Remote Control doesn't work properly on Kodi MACos

Very good friends !!

I am new and I hope I am in the correct category.

I bought this week through Amazon Prime, the OSMC Remote control to be able to use it only with the Kodi app (without osmc and without libreelec) on a Mac Mini with OS High Sierra … but I have a problem:

Is that the Back button of the remote does not react, it does nothing (but if the light turns on when pressed)

Is there a way to get drivers to make it work? or in what other way?
The controller works well but of course, the Back button is essential to move wonderfully well on Kodi.
I hope you can help me please !!!

Are you sure you have the real deal? The OSMC remotes are a generic HID type device and as such there is no driver needed. They show up the same as a generic keyboard does and the “back” button sends the same output as pushing the “backspace” key on a keyboard.

1 Like

Of course, It is the original remote.

Is what I do not understand, that all the buttons go well and that of Back does not react to anything … and at least for me, back is basic to move through the folders quickly and perfectly.

What can I do to detect that key? is there any way ??

So thanks for u reply!!! Thank u very much darwin!!!

I don’t do MAC so i’m a bit limited in how much I would be able to help. If the other keys are working i’m at a loss on how that particular key would be having an issue. You might install the keymap editor add-on in Kodi and try remapping it. Alternatively you could turn on debug logging in Kodi, press the back button, and then check Kodi’s log to see what, if anything it picked up.

1 Like

thank you very much darwin !!
Now I am going to test what you have told me and see but I also just realized that the Stop button and the Volume control button do not work as they should.
The stop does not do anything either and the volume buttons only advance (+) or delay (-) the playback … it is very rare!
:frowning: :frowning:

By certain darwin: what is it or where do I get it from keymap editor plugin on Kodi and try to remap it???

In Kodi, add-ons -> install from repository -> program add-ons -> keymap editor

The volume keys send + and - which is mapped in stock Kodi for keyboard input to control volume. If your using a language other than English those keys can get mapped to buttons other than what they should. Kodi isn’t great dealing with non english input devices.

I would think that @sam_nazarko should have some thoughts here as he is a Mac user as well.

1 Like

I have already tried the keymap editor and there is no way, it has not been of any use and I don’t know what to do anymore …

And I have the language in Spanish Darwin.

What works is the direction section of left, right, up and down fine, ok (central button) fine, information also fine, ready too, play too, home also fine … only stop, both volume and the back !!! Let’s see if there is luck and hopefully @sam_nazarko who understands mac knows why this happens but this already seems like an “X FILES” … and please help us !!!

See OSMC Remote Control + macOS + Kodi issue

Due to changes in macOS the remote is no longer plug and play.

1 Like

That is to say, nothing can be done @sam_nazarko??
total impossible??

You can use the USB Overdrive application (which is free). It solved the issue for that user, but keep in mind it was an earlier version of the remote.

2 Likes

perfect sam !! I’m going to provide and tell you how it went … THANK YOU MASTER !!

@sam_nazarko my friend!!! THANKS BILLION FOR YOUR HELP because it already works as it should !!!

The only thing that to make the BACK pass through pages and not go directly to HOME I have put it in the KEY ‘’ DELETE ‘’ and the STOP button, which did not work for me, I have put it in the KEY ‘’ X ‘’ and now it goes perfectly !!!

@darwindesign @sam_nazarko THANK YOU SO MUCH FROM ALL HEART !!! It has been a pleasure to read you and have your support and it is something that will be unforgettable for me!!

THANK U THANK U THANK YOU !!!