Remote control Switch-Off behavior change with latest Update on Vero 4K


Sorry but I would like to report a small annoying change in the way I am used to power-off my Vero 4K. Indeed here is what I do when I am done with watching a movie:

  • I click the “Power” button that is at the bottom left of the i25 Rii Mini bluetooth remote.
  • This used to directly open KODI’s switch-off menu from which I select “Shutdown”.
  • Once done and when the screen is black, I click on another remote to switch-off electrical power alimentation.
  • Then the day when I switch-on the power alimentation again, the Vero 4k auto-starts and is ready. This use case is fine for what I need (despite the fact that it is designed for always-on use, I don’t need a server but just a good movie player dedicated box that is not connected to anything and that is not relying on an alimentation when I don’t need it).

So since I run the OSMC’s November update, here is the new behavior when I click the bottom-left ‘Power’ button of the bluetooth remote:

  • The Vero 4K LED switches quickly from blue to red to blue
  • The HDMI signal is lost (black TV screen) for about 4 seconds
  • Eventually KODI screen reappears with the Switch-off menu

This is annoying and probably not a good thing for the system safety.


  • I used previously the “Keymap editor” plugin but now it is deactivated
  • At the bottom-right of the Rii i25 remote there is a “Home” button that has the following behavior: when I am already on the Home screen, then the Vero 4k goes to “sleep” mode: the LED turns red and TV’s screen turns black. Pressing another key wakes it up.
  • When opening the Switch-Off sub-menu from Kodi’s menu there is no problem.

Hopefully, this will help fixing something in the case that would not be an issue on my side only.

Thank you.

Sounds a bit different but maybe this sound similar

1 Like

Thank you for the information (I missed that post).

I was confident and have just logged to the Vero’s SSH server with Putty to set:


But after saving ‘logind.conf’ and rebooting that does not seem to change anything unfortunately.

Well, sorry I just missed the last step:
sudo systemctl restart systemd-logind

This works now: Thank you! :slight_smile:

Just a heads up you can make that button directly shut down instead of having to go though the menu.

Nice suggestion that I will try… (if I don’t risk to press the button by error though)
Do you mean by using the “Keymap editor” plugin, or do you think of another method?

There should be an option to do this in the Keymap Editor add-on. Otherwise you can manually do it via ssh by editing ~/.kodi/userdata/keymaps/gen.xml and replace the part that says “ActivateWindow(ShutdownMenu)” with “shutdown”.

If your remote supports long-press (I don’t know, don’t own one of those) then you could add a mod="longpress" to the key mapping so it will only happen when you hold down the key if accidental press is a concern. The caveat to this is once you add that you can’t open Keymap Editor anymore without it destroying this customization (it does not support long-press and edits anything it doesn’t understand).

1 Like