Remote for Vero 4K+ partially works


I bought an OSMC Vero 4K+ back on 2022.11.27. It arrived about a week later
and I’ve been using it on a daily basis for just over two weeks. I recently attached
a wireless keyboard to the Vero 4K+ in order to more easily add a new remote
video source entry. I had the Vero remote’s USB dongle in the left USB port and
the wireless keyboard’s USB dongle in the right USB port. After adding the new
video source entry, I detached the wireless keyboard and removed the USB
dongle for the keyboard.

When I next tried to use the Vero 4K+ to watch a video I noticed that three keys
on the Vero remote no longer worked: the “return” key, the “play/pause” key
and the “stop” key. All other keys on the remote continued to work.

I spent yesterday trying to diagnose the issue and haven’t been able to get the
remote completely working again. I searched support forum and I didn’t find an
exact match for my issue. I did find and try the re-pair sequence, but that did
not solve the issue I’m having with the remote. I also tried removing the battery,
letting the remote sit for 30 seconds and then put the battery back in. No joy.

I went to Settings → System → Input → Peripherals and the entry for the Vero
remote says:

OSMC RF Remote (Version: Unknown)

so I suspect that OSMC has forgotten my remote’s version information and
is using the common minimum for the keys on the remote. This is just a guess
on my part.

I’ve poked around the various settings, but I don’t see a way to tell OSMC which
remote I have. Actually, I don’t know what version of the remote I was sent so
if I had found a way to set the remote version I would have just tried to cycle
thru the various versions…

Thanks, in advance, for any help with this issue.


That’s nothing to worry about – we don’t tell Kodi the remote revision and it can be safely ignored. You shouldn’t need to do anything, just plug it in and it should work.

Could you upload some logs via My OSMC so I can check things are working as expected?


I would be rather curious to see logs as well since why those three keys in particular isn’t obvious. Have you tried rebooting? Have you played around at all with keymaps?

You can plug the dongle into a PC and see if the buttons are functioning there. The remote will act like a keyboard and the button inside the direction keys will be the same as the “enter key” and the back button will act the same as “backspace” (I’m not sure which your referring to when you say “return” key). The stop and play buttons will act as multimedia keys so they should function in most media player apps (VLC, MPC, WMP, iTunes, Kodi, etc.).

I rebooted the Vero 4k+, enabled logging, and then rebooted it again.
I played around with the remote a bit and then I uploaded system logs

Have you tried rebooting?
Part of the re-pair process requires shutting down the Vero 4k+ for 2 minutes
so yes I have rebooted it (several times).

Have you played around at all with keymaps?
No, I have not done anything with keymaps.

I’m not sure which your referring to when you say “return” key.
By “return” key, I should have said “back” key.

I will try plugging the remote into my MBP13 and I’ll let you folks
know what happens.

Thanks for the replies (on Christmas no less)!!

macOS does not want to recognize the Vero 4k+ remote as a keyboard. I’ll have to
find a windows machines to do that experiment.

1 Like

Can you unplug all dongles from the Vero, reboot it, then plug the OSMC remote dongle back in and see what happens. I’m not spotting anything obvious in your logs of where the problem is.

My Vero 4k+ only has the OSMC dongle plugged into a USB port (I’ve tried
both ports), an ethernet cable plugged in the back, an HDMI cable plugged
into a screen and the power plug. That’s it.

I do access all my media over the network from a MacMini that’s serving
all the Music, Movies and TV shows. Also, I’m using the Metropolis skin to
maintain consistency with all of my Kodi/OSMC setups.

I just meant that if you had another input or other USB device to do a clean reboot without any of those and try the dongle plugged in after bootup. I’m grasping as straws here since this isn’t a known issue. The OS looks to be picking up dongle as it should, the keys not working are not ones getting remapped by the OS to deal with language issues, (and your not running one of those keyboard layouts anyway), Kodi is seeing the dongle correctly and loading our special long-press keymap, and there is no userdata keymaps being loaded. Not to mention that plugging in an extra input device is fairly common and shouldn’t be problematic. Personally, I’m at a loss.

I plugged in one of my wireless keyboards, shutdown the Vero 4k+, and
pulled the power. I removed the dongle for my temporary wireless keyboard
and repowered the Vero 4k+ and allowed it to boot with no remote and no
wireless keyboard, i.e., no input devices. I plugged in the Vero 4k+ remote
dongle and retried the Vero 4k+ remote. No change. 3 keys still fail to work.

I shutdown the Vero 4k+ plus and moved the dongle and the remote to a
RaspberryPi 3B+ that I have running OSMC. I booted OSMC and tested the
Vero 4k+ remote. Same 3 keys fail to work. I’m starting to think that I have
a remote that has suffered some infant mortality.

1 Like

I’ve ordered another Vero 4k+ for a different room in the house
and I’ll continue to debug this when I get a second Vero 4k+ remote.

1 Like

Given the information derived in this thread I don’t see it being anything other than a hardware defect. I would suggest to send an email to with your order number and a link to this thread and they will get you sorted.

The USB receiver may have died.

If you provide the order # of the original order and your new order via PM I can provide an additional dongle which I suspect will solve your issue. This will save us both time.

Many thanks,


macOS devices get a bit funny with the remote controller.
You need to follow these instructions for it to work (for future reference): OSMC Remote Control + macOS + Kodi issue

As per your support request I have shipped a new receiver with your new order. You should Home and OK to pair the new dongle with the remote.

With the new receiver, the Vero 4k+ remote is back to acting
like normal.

I’ve been using the new receiver for about 1.5 weeks of
morning exercise bike rides without issue. That’s longer
than the original receiver lasted.

Thanks for sending the replacement!

1 Like

Welcome. Glad this has solved the problem and apologies for the issue in the first place.