Remote issues on 4k + , dead?

Hi guys seems my remote has died afyer 4 days. Troed a new battery and no joy. No lights flash on the vero. Tried the other usb port on the unit and the issue persists. Using my yamaha remote works fine.

Any ideas ? Thanks

The light to flash is on the remote not the Vero.
Try to pair the remote newly if it doesn’t work try with your PC

Will do. Thank you

Hi, ive tried a few batteries and repairing. Both fail

Sam, how do I organise a replacement remote control?


Sorry to hear that. Contact with a link to your thread and we’ll get a replacement out for you shortly.

1 Like


My remote is also not working. It gives a blue light on the remote itself, so there is power, but the box is not responding.

Have you tried solution from the second post?

My mistake, i apologize for saying something that ism’t true, There was no usb dongle in the Vero.Now it works fine, Sorry about this horrible mistake i made.:cry:

Hi Sam

the dongle arrived and the issue is exactly the same

trying to pair with the dongle disconnected, the remote using HOME and OK for 5 seconds does NOT display any lights on the Vero.

As I written before the lights flash on the remote not the vero!

nothing flashes anywhere…

On the predecessor remote of a Vero 4k the LED is found here:

Is that a typo? The dongle needs to be connected to pair it.

Just to be sure, see one of Sam’s instructions.

Ive done the instructions from Sams post, same issue!

So, you can see the blue LED on the Remote Control steady glows after pressing Home+OK button same time for 5 seconds?

No, there are no LEDs

Did you get a new remote? If so did you pull the plastic tab from the battery compartment? If it’s your original remote have you replaced the battery?

You didn’t answer my question before; is the dongle plugged in?

This is the original remote, it worked for about a week.

Dongle is plugged in and yes the plastic is out LOL