Remote misses multiple keypresses. Intermittent. Also no /boot

Hello - I’ve had my Vero V now for about a week. My previous osmc install was on a Pi4 so I did a backup of my previous system (on the pi4) and used that backup for the Vero V. I did not backup nor restore the gui.

I ran into problems with the Vero V after the restore when I was trying to setup NFS for my multiple drives after this. B/C I was unable to get NFS to work properly after trying multiple things, I decided to start over. I tried doing a reinstall of the operating system by downloading it, adding it to a SD card using the OSMC software, placing it in the Vero V, and then rebooting, but I’m not sure that it worked properly b/c the Video sources were still there. Nevertheless, I moved on and I got the NFS working.

I’ve had a couple problems since then. The remote will work for a bit and then it stops working for a while. It ignores keypresses and then will accept one or two. I’ve tried doing this while recording the attached log so hopefully missed keypresses will show up.

Also the Vero V indicates during boot or shutdown that, I believe, /boot is empty. That seems strange to me.

Finally, when I’ve come back to the Vero V after a day or two, I’ve gotten a message on the screen which reads “OSMC Updater Insufficient space for Update to proceed. Free some storage space and try again later.” Given this is new and I haven’t added much to it, that’s also a bit strange to me.

Here’s the log:

Thank you,

Hi Paul,

You should have seen the OSMC installer come up.
If you reinstalled OSMC, nothing would persist. Feel free to show us a screenshot of your OSMC Install media so we can check it’s been imaged correctly.

Any hard drives attached?

Can you take a photo of this? We don’t really use /boot in the same way we do on a Pi (it’s not a separate partition), and is part of the standard root filesystem on Vero V.

You should only ever restore from the same class of device. We’re going to make that tougher in future versions of My OSMC because it can cause problems.

I’d personally suggest you reinstall OSMC from scratch (we can help you if you’re having trouble achieving that) and clarify what you’d like to restore from your Pi 4 installation. Is it a library and shares or are there further changes you want to bring over?



Your setup is using SMB, not NFS… at least according to your logs.

You could try deleting ~/.kodi/temp and see if that takes care of that issue.

Thanks Sam! A few things here regarding what has happened next.

I did a reinstall. I think I must have had a bad sd card. When I did the install from a USB thumb drive, it worked properly.

Regarding the remote, it was b/c of a USB thumb drive in the Vero. As soon as I took it out, the remote worked fine.

My statement that the /boot drive is empty was incorrect. I apologize. It is a quick splash screen. It was failed to mount /boot. I believe this was b/c I copied the fstab from the Pi4 which had an extra entry at the top compared to the fstab of the Vero. Regardless, when I reinstalled this was fixed.

I transferred over manually a number of files.
All the databases for Mysql.
fstab and exports.
Probably a couple more.

I then tried to setup my drives for NFS. I think I did that properly but I’ll write more in my reply to @darwindesign in my next post.

It seems to be working properly now which is great. The only thing I don’t have setup is my TVheadend yet. Can I setup my TVheadend server, and then simply copy the tvheadend folder from userdata on the Pi4 to the Vero V?

Thanks for your help! I appreciate it.


Thanks @darwindesign for your comment and looking into this for me! I don’t want to be thinking I’m using NFS when I’m actually using Samba.

Here’s what I did for my NFS setup:
sudo apt-get install nfs-kernel-server
sudo nano /etc/exports (I’ll put my file below)
sudo nano /etc/fstab (I’ll put that file below too)
sudo exportfs -a (no errors).

I’ve mounted my hard drives on /mnt. The drives and all their data are accessible on /mnt.
“showmount -e myip” lists all the hard drives that I have.

Is there anyway other than logs to see if I’m using SMB rather than NFS (and either way, how would I do that)?

fstab is:

#/dev/osmcroot / ext4 defaults,noatime 0 0
UUID=************ /mnt/easystore4 ntfs defaults,noatime,nofail,x-systemd.mount-timeout=30 0 0
UUID=************ /mnt/easystore3 ntfs defaults,noatime,nofail,x-systemd.mount-timeout=30 0 0
UUID=************ /mnt/Seagate2 ntfs defaults,noatime,nofail,x-systemd.mount-timeout=30 0 0
UUID=*********** /mnt/My\040Book ntfs defaults,noatime,nofail,x-systemd.mount-timeout=30 0 0
UUID=************ /mnt/easystore ntfs defaults,noatime,nofail,x-systemd.mount-timeout=30 0 0
UUID=************ /mnt/easystore5 ntfs defaults,noatime,nofail,x-systemd.mount-timeout=30 0 0

exports is:


Thanks again!

Your disks are directly attached so not relevant to networking protocol in that respect. Your Kodi sources are pointing to the local mounts (which is kinda wrong in this particular type of configuration) and to SMB paths pointing back to itself…

            <name>TV Shows (4)</name>
            <path pathversion="1">smb:// Shows/</path>

Which means that these Kodi SMB paths are the ones stored in Kodi’s database unless there is substitution added. Which you have…


So on this particular machine it will see the SMB path and just open the local mount point directly instead of going through samba. So for this machine in effect you have no networking, SMB or NFS, involved in local playback and you are storing SMB paths in your shared MySQL database for any other clients. Perhaps you have configured NFS server for other Kodi clients connected to the same shared database, but unless you are doing a path substitution from the SMB paths in the database to NFS paths on each client they wouldn’t be using those. I’m not sure it would actually make all that much difference which way you configured the shares though as your going to have a much bigger speed hit from the drives being formatted as NTFS than would be present in the networking protocol used.

If you installed via the OSMC App Store and both are on the same version then yes.

Hey @sam_nazarko - I did as you suggested but haven’t been able to get TVheadend to work. I do not have access to my guide or recordings. When I click to go to addons (in the TV menu) there’s an empty list. I’ve attached a log during which I try to access the add ons as well as try to update the guide from another computer using SSH.

If you want me to do this as a separate thread, please let me know. I can’t think of anything else to try to do during the logging process so let me know if you need more info. Thank you.

You have to install the TVH client pvr.hts from Settings->System->Addons and set that up with the IP of the device running TVH and the default username and password.

I would have no idea how to update the guide using SSH. It’s stored in the .hts directory of the device you are running TVH on. If you copied that in its entirety, then you should see your recordings after you’ve set up the TVH client.

I had installed the PVR client. However I cannot click “run” on it. I had setup a configuration with the proper IP address but it doesn’t work. I’ve attached (hopefully) a few pics to show what’s going on (the first picture unfortunately cut off the “run” part on the bottom left - please note that it is greyed out):

Regarding the second point about SSH, it’s not difficult and is how I’ve done it for a long time. Just can’t now unfortunately.


Here, Run is greyed out as well, but the addon ‘just works’. Note that there’s a deliberate delay after starting Kodi before the addon starts. You could try using instead of your box’s IP.

Sorry If I’m being slow. You asked Sam if you could copy the ‘tvheadend folder’ from ‘userdata’ on the Pi4. IIRC, the folder structure is the same on Pi as on Vero, ie it sits in /home/osmc/.hts. Copying that may give you all the settings and recordings indexes as you had on PI but the path to your recordings should be the same and I’m not sure that will make any USB TV sticks work just like that - the UUIDs could be different. But you will see that in the Webui for TVH.