Remote not working - How to identify empty battery

Hi everyone,

I am using a Vero 4k (bought in june 2017) to watch the content of my Synology NAS using nfs sharing.
It’s working very well and I’m very happy with it.

A few months ago, my official remote stopped working. When it did I suddenly noticed that my TV remote was compatible with the vero 4K without the need of any configuration. So I didn’t think about contacting the support for this.

Last week I’ve switched ISP so I took this as an opportunity to remap my network and change both the vero 4k and the NAS IP adress.

When I tried to use my TV remote to suppress the old nfs path media sources, I realized I need to press a button that enables access to a “contextual menu” to do so. I also realized that this button is not mapped on my TV remote.

I failed to make my Vero 4k official remote work again, despite trying to unpair and pair it again.

As I didn’t used it for several months I did not remember how it works. From what I get from other topics, the remote should have a LED thats blinks when you press a button, mine don’t blink, so it’s either dead or out of battery (or I think so).

I did not bought new battery to test my remote because i wasn’t able to find them and was relectuant to pay delivery for a ~3€ product. Also I’ve only used the remote for approximately 3 months, and I think this may be really short to empty the battery.

I also found that my remote has the same problem than the one described in this topic the battery latch is sticking out. Here’s one picture of my remote.

I am wondering if this may cause a lack of contact between the battery and the remote and causing the remote to act as dead.

Please let me know if you have any idea about my problem.

By the way, I present you my apologies if this particular problem has already been solved on this forum.

Have you tried measuring the voltage on the battery?

Your battery cover looks like mine - it shouldn’t affect the operation.

Indeed, mine looks exact the same. But I remember that I’ve had to replace the battery from an RF remote shipped with a Vero 2 also after a few weeks. Well, since CR2032 cells are quite used often, it belongs to the standard battery stock in my household.

Ok thanks for your advice,
No I didn’t tried to mesure the battery (I don’t have any equipement to do it).
I will try to find a store which sells CR2032 this weekend.

It’s a standard watch battery.

We would send you one out for free, but it’s not possible for us to ship batteries in the mail unless they’re packed in equipment because of new regulations.

6 months is what we expect on average, but it depends on the environment, frequency of use, and distance from receiver.


Hi everyone,

I finally managed to find those CR2032 in a retail store.
Since I plugged in the new battery it’s working (I didn’t even had to pair it again).

Without your help I was probably going to assume that my remote was dead and that I should buy a new one.
So I’d like to thank you for your support.

See you.

1 Like