Remote unresponsive after update

#1

I updated to whatever the latest version is, and after rebooting (twice) my Vero 4K+ starts ok, but there’s no response to the remote. The remote light does light up when I press buttons, and the remote worked fine when doing the update.

I downloaded Kore, but can’t login as I don’t think I’ve set up it as an allowed remote, and certainly don’t know the credentials.

What can I do to troubleshoot?

#2

Have you tried re-pairing the remote?

#3

I tried it by unplugging the dongle, pressing home and OK button so the light is constantly on, and plugging in the dongle. The light blinks a few times immediately which to me means it paired correctly? But there’s no action when pushing buttons, though Kodi works fine when plugging in a USB keyboard.

#5

Can you upload a log?
Is the receiver plugged in?
Have you tried changing the battery?

1 Like
#6

Tried changing the battery and re-pairing as I described earlier, no help. Yes, the receiver is plugged in :slight_smile:

Event log is empty, or is there another log I can find?

#7

Please post a full osmc log
Let us know if you need any pointers with this

Sam

#8

Here you go!

[deleted]

#9

This doesn’t seem like a full log.

How did you upload this?

#10

That’s the dmesg log, here’s the other one:
[deleted]

#11

Your log doesn’t show the RF dongle attached.
Can you check this?

#12

It was in.

I rebooted and inserted the dongle, does it show up now in the log below?
http://paste.osmc.io/yogalajeyu.vhdl

#13

Nope. Can you plug it in to a PC and see if it shows up in device manager?
The dongle may be faulty; and the fact that it occurred after an update is just a coincidence.

When you press a button on the remote, do you see a short blue flash or a long pulse?

#14

When I insert the dongle into a Windows machine first it said not recognized, but then it installs drivers successfully. Not sure what to look for in device manager?

When I press a button on the remote, just a very brief blue flash. When I long press on HOME and OK buttons, the blue light remains on. When I insert the dongle into the Vero, there are three blinks and the blue light is off. Therefore I take that there’s some communication happening between the dongle and the remote.

#15

Yes – the three blinks indicate successful pairing.
You may be able to use the arrow keys (up and down) to scroll a web page in your browser on a PC.

Also, try a different USB on the Vero.

#16

Look at the end of the first post to see how you can test some basic functions of the remote within Windows: Pairing the Original Black OSMC RF Remote Control with a Pi/Vero2/4k/4k+.

It is important to understand whether the issue is related to the remote control or the box.

#17

Doesn’t work in Win7 following the guide in the link provided, and the other USB port on the Vero doesn’t work, either :frowning: Pairing seems to work with both Windows and Vero, but just no response to any commands.

#18

So the USB port and the remote are broken? That seems unlikely — or do you just mean that it doesn’t work in the other USB

Sam

#20

Given the dongle pairs with the remote when it’s attached to Win 7 PC or either of Vero’s USB ports. Windows PC recognizes the dongle, eventually. But the remote commands don’t reach the device it’s attached to (PC or Vero).

Not sure what that implies.

#22

Sounds like you need a new dongle.
If you open a support ticket, we can send another one

Cheers

Sam