Remount fstab shares on Vero 4k when connection is interrupted?


#1

Is there a command or way I can get my fstab shares to remount when the sever sharing them has been powered down or rebooted?

I ask this because I’m sharing from a Windows 10 PC which unlike the Vero 4K I power off when I’m not home.
When I was using SMB this wasn’t a problem as the Vero saw the shares again when I powered up my PC,
but since I switched to using fstab I have to reboot my Vero 4k to see these shares again after powering up my PC,
so is there a command or setting I’m missing to avoid having to do this all the time?

Be gentle with me or ELI5 if I’m doing something wrong, I know next to nothing about Linux and setting up these fstab shares is pretty much the only thing I’ve done with it.


FSTAB CIFS mounts - lockout on lost connection and wait timer on reboot
#2

I think something like autofs might do this.

Sam


#3

Thanks, do you know of a beginners guide to setting autofs?
I just Googled it and the couple of guides I’ve read so far are pretty heavy going and refer to NFS mounts rather than SMB, also will autofs work as well as fstab? I switched to fstab because it works perfectly with my UHD content without the need for GB ethernet.


#4

Not a beginners guide but at least quite clear instructions.

Just normally we suggest to use /mnt instead of /media as the target directory.

Alternative with your current fstab mount you could run a script that contains sudo mount -a -t cifs you then would need to find a way o trigger that script when the connection is needed e.g. via inotify.


#5

Thanks, that looks clearer than Googles first results.
I shall try it over the weekend.


#13

In the meantime the team created a HOW-TO for autofs which should help.


#14

Im having this exact problem
I turn my win10 pc off at night but vero 4k stays on 24/7. When I try to playback a win10 share the next day after turning pc back on nothing happens.

Im not sure how do use autofs. Do I just add it to my share line somehwere??

//192.168.1.88/sw2 /mnt/sw2 cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=al,password=xxx,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

I just need it to remount when I turn pc back on.


#15

Did you read the above linked tutorial? It explains how to use autofs in detail.


#16

I looked at ALL the guides I could find over the weekend but still couldn’t get it working.
I have only just managed to mount my win10 folders using fstab.

Also. Since I cant access shares when I power back on PC I try to reboot vero but it always stops rebooting on a screen which displays all my mounts. So I have to pull the power plug, which probably isnt a good thing I know.


#17

Have you opened and followed this link? Autofs is an alternative to fstab. You would remove your shares from fstab, reboot and then configure Autofs.

https://discourse.osmc.tv/t/how-to-mounting-network-shares-with-autofs-alternative-to-fstab/74228


#18

Ive read all links posted, searched google which all have very vague guides and ALL assume you know what you’re doing.

I just want to share my tv7 share from my win10 pc named altron
I tried /mnt/tv7 192.168.1.88 : D:\tv7 (I dont know what/where it means by path/to/share)


#19

First important, did you removed everything you added yourself from fstab? Because you would not have ended up with a boot issue if only the default lines are in there!
The second step is than to configure Autofs. For that you should know your share name. I doubt that D: is part of your share name and it actually is tv7 in that case it would be ://192.168.1.88/tv7/


#20

So the line would be?

/mnt/tv7 ://192.168.1.88/tv7/

(I just reinstalled osmc so its all back to stock )


#22

If the path to your share is /tv7, then that should be correct. Did you try it?

EDIT: I once again point you to read the link posted above about how to use autofs. You clearly have not read it. Give the part about SMB a good read.


#23

Oh I was doing it wrong from the start.

Where at the start the guide says edit auto.master, I add the line “/- /etc/auto.nfs.shares --timeout 15 browse” to the end of the file but then I was trying to add the next bit sudo nano /etc/auto.nfs.shares in the same file without backing out.

So I enter sudo nano /etc/auto.nfs.shares and THAT gets me into shares.
I entered /mnt/film/sw2 ://192.168.1.88/sw2/ (different folder i know but this is one of my film folders)
And it shows up in the mnt folder on my vero but I cant select sw2 to share. I can see it but I cant ope it to share.


#24

I’m sorry that I keep asking you to read the tutorial, but you clearly are not, as you are now mixing up SMB and NFS mounts. Read the tutorial from the beginning. It covers SMB mounts first.

SMB mounts are from Windows systems, NFS mounts are from linux systems. So you are using SMB.


#25

Finally got it working :blush:

restarted win pc to see if shares would playback, they did.
All good

thanks :+1:


#26

Glad to hear this.


#29

@starpony If you can would you mind detailing the exact steps and commands you used to get autofs working please?
I had a quick go with the new tutorial but failed to get it working and as I’m on a horrendous work schedule now of no days off for 2 weeks (cue the violin music) I haven’t had the time to investigate or try anything further.


#31

yo. Its not actually hard but Im not good at following instructions or any of this network share stuff.
This is how i did it. good luck :wink:
I wanted to share my ‘sw2’ folder (are these things case sensitive ?)

1:get into your vero via ssh
2: enter “sudo apt-get install autofs” It’ll download autofs (minus all my quotation marks )
3:enter “sudo nano /etc/auto.master”
4: and add " /- /etc/auto.smb.shares --timeout 15 browse" and then ctrl-X and Y and enter to save and exit that bit.

5:enter “sudo nano /etc/auto.smb.shares” (this is the place youll enter your shares into)
6:I entered “/mnt/film/sw2 -fstype=cifs,rw,credentials=/home/osmc/.smbcredentials,iocharset=utf8,uid=osmc,gid=osmc ://192.168.1.88/sw2/” and ctrl-x, Y , enter to save

7: enter your pc login and password “nano ~/.smbcredentials”
8:add username=<username> password=<password> then ctrl-X, Y and enter

9:and at the end youll need to restart autofs with “sudo systemctl restart autofs”

Now you should head over to your vero and under movies/ two little dots at the top/files/add videos/browse/root filessystem/mnt and THERE hopefully you should see your shares.

I think the devs should highly recommend autofs as the best way to view your share folders if you have win pc that gets turned off everyday as your share server. :thinking: