Remove Loading roundel

Im using OSMC to play a stack of movies for an art show After several hours playback, the loading roundel appears. Can I turn this off or hide it or delete it somehow, or edit the icon somehow?? I just want it to be black between movies.

You could choose a different skin without this feature, that might be easier.

ok thanks, any clues as to which skin doesn’t have a loading ring thing? Problem for me is it only shows up after around 8 hours so hard to test

I think your are referring to the busy indicator (the OSMC logo in white being drawn in the middle of the screen). I doubt there is any skin that doesn’t have a busy indicator. I guess you might need to find out what the device is doing at that moment! Is it the end of the “stack of movies”

No it is not at the end of a stack, it’s between some movies after its been running for 8 hours or so. Sad because it looks so good when the movies just have the black between them. Not a useful interface design, really

Kodi/OSMC was not designed for art show presentations.

thanks for the help!


cd /usr/share/kodi/addons/skin.osmc/16x9
sudo mv DialogBusy.xml DialogNotBusy.xml

To do the job properly, make a copy of the skin in the osmc addons directory, rename it, mod it and choose it in the gui. Similar to what’s described here.

Thanks Grahamh,
umm… instead of messing about editing the graphic, could I just modify the DialogNotBusy.xml so that in the spinner section the centerleft and centretop are both 110% instead of 50% to draw it offscreen?

Ok Ive been looking in Textures.xbt and i cannot see the roundel thing at all. It looks like this image i drew. Anyone know where that is???

That is not part of the OSMC skin. So either you use a different skin or that comes from an addon

A file named DialogNotBusy.xml will be ignored. I just made up the name to effectively delete it. Kodi will be looking for DialogBusy.xml. Renaming it just stops it appearing at all. So if you want to edit, edit DialogBusy. The file has the same name in osmc and estuary skins.

I think the graphic is constructed from bits. It got too hard for me - that’s why I suggested the simple option.

Did it work? I tested it when loading iPlayer which always takes an age, but I’m not sure if that’s the same roundel that’s giving you grief.

Thanks for the help, Im on the Estuary skin…

Fzinken – it is part of the Estuary skin - others have said that the other skins will also have this type of loading thing. Its totally unecessary as it pops for around 1/4 a second. Just enough time to flash …

In Estuary the file is called spinner.png , it’s in the media directory. I’m trying to replace it with a blank png so that i never have to see it.

Don’t forget the sudo systemctl restart mediacenter

thanks grahamh. Im going around in a circle now. I modified the spinner.png and the dialogbusy.xml and replaced them - and did your command to restart - but nothing changed. So to do a test i modified the kodi logo that appears. Not the omsc one.
I navigated to my usb stick and did

sudo cp logo.png /usr/share/kodi/addons/skin.estuary/media/icons

then restarted the thing. No change. I navigated to the directory and looked at all the modification dates on the files i changed using

ls -l

and i can see that the file permissions are the same as other files and that the date is different so it has changed that. But no change is visible – it is as if the Pi is getting an unchanged version of the skin from somewhere??? and not displaying the one Im modifiying? Do you have any ideas?

Ok so Im going to try it on the skin.osmc to see if that makes a difference

You could be better asking this on the Kodi forums as there are potentially more skin developers and people that like to customise stuff over there. This issue seems like a Kodi ‘feature’ rather than anything specific to OSMC.

I don’t know about the icons, but changes I make in the addons directory definitely take effect. If you don’t like my original idea just make your DialogBusy.xml look like this

<?xml version="1.0" encoding="utf-8"?>
        <animation effect="fade" end="100" time="560">WindowOpen</animation>
        <animation effect="fade" start="100" end="0" time="240">WindowClose</animation>
                <control type="group">
                        <animation effect="fade" time="400">VisibleChange</animation>
                        <control type="image">
                                <animation effect="fade" start="100" end="70" time="0" condition="true">Conditional</animation>
                                <animation effect="fade" start="100" end="0" time="240" condition="Window.IsVisible(fullscreenvideo)">Conditional</animation>

It will remove the roundel ( the second nested group control) and you can play with the fade timings to get it just how you want it.

You would probably be better off with raspbian and omxplayer with a bashscript.
There are also some efforts on gapless playback.

1 Like