Replacing remote for Vero4k

I’m having issues with my remote and feel replacing it is my only option. Is the official Vero4k remote the only one that will work or will a generic one from Amazon do the trick?

Any wireless remote that present itself as a USB keyboard to OSMC will work, while some of them might have some special keys that might not work as expected.

Alternatives are IR Remotes or universal remotes (IR or Bluetooth) while those may take more work to get working.

What is the issue?

The buttons work sporadically at best, though the blue light at the end consistently lights up. Batteries are new.
I took the remote apart and there was sticky substance between the buttons and the circuit board. Like rubber or plastic that is disintegrating. I cleaned it all using rubbing alcohol and it suddenly started working perfectly again for about 15 minutes, but now it’s back to not working well.
I also put the receiver on a USB extension cord to get further from the router in case there was interference, but that didn’t seem to help.
I currently am using the Kore remote app on my phone, but really miss a proper remote.

Change the battery.

@sam_nazarko I have tried more than one the brand new battery. It definitely is not that.

I have same problem, remote reacts randomly.
When checked from: Settings → System → Input → Peripherals, there are two components:
-OSMC RF Remote (Version: Unknown)
And that OSMC RF is disappearing and coming back every few seconds. My conclusion is that receiver is broken. I had universal remote from Rpi and its work “ok” just stop-button missing :wink:

I’d suggest uploading a log so we can check what the issue is.


Kodi has a thing called a “keymap” that allows you to assign what functions trigger with the various buttons on your remote. You can likely get your “stop” button working by installing the “Keymap Editor” add-on and manually mapping that button.

Okay, the log is at

After setting up logging, I attempted to use the remote. I pushed and held down the down arrow (the ring around the ok button) and it would go down one menu item and then stop, despite holding down the button and then down one or two menu items, etc. Completely unusable to navigate the GUI.

In the end I used the Kore app on my phone to navigate to upload the log files.

Thanks for the info. I went to the peripherals section and I also have the same 2 items, but the RF remote one is consistently there, it’s not disappearing all the time

The OSMC remote entry in peripherals loads dynamically when it see’s the dongle plugged in. If someone has an issue with it disappearing then it is probably a bad USB connection or a defective dongle. I this case it looks like you have a bad connection in the remote itself so it isn’t getting a continuous enough signal on a button hold to understand your holding it down. When something gets into the remote contacts it is a bit problematic cleaning it off without destroying or degrading the conductive film on the rubber which makes repairs difficult.

Well, that certainly tracks with how the remote worked okay for a little while when I took it apart and cleaned it. Unfortunately, the problem quickly came back so it’s just a matter of replacing the remote.

Thanks for the help everyone.

I’ve used an old phone, minus SIM and apps, with a bluetooth connection and the Kore app. The Yatse app is a paid for, more polished, option. Be aware that bluetooth with Android has it’s drawbacks/issues in Linux land. I thoroughly recommend the Rii wireless keyboard with touchpad mouse. It’s rechargeable, comes with it’s own 2.4Ghz USB adaptor and is very solidly built. (about £27).
I’ve stopped using the Vero for my normal TV because non-Amd/Intel chipsets don’t come with the DRM necessary for some UK streaming platforms.

So, I’ve got a replacement remote (a generic universal one with 2.4ghz support) and it seems to work fine except I can’t get the OK button working.

I’ve installed keymap and gone to Global → Navigation → Select Item and then chosen to edit this, pushing the OK button on the new remote. It is instantly seen and changes “Select Item - enter” to “Select Item - 16839168”. I then backed out and saved.

However, it still does act like an ok button. In fact it doesn’t do anything. I tried rebooting thinking it might be required to take, but that didn’t work.

I looked through all the various potential keymappings and Select Item seemed the most appropriate. I couldn’t find one called OK or Enter.

Any ideas? Am I missing a step?

Keymap editor will show too many numbers like this when it runs across some keys it has an issue with. Can you ssh into your box and…

kodi-send -a toggledebug
tail -f ~/.kodi/temp/kodi.log | grep -B 1 'HandleKey'

then press the OK button on your remote and let me know what comes back for that key.

This is after posting ok 3 times

osmc@osmc:~$ kodi-send -a toggledebug
Sending: {'type': 'action', 'content': 'toggledebug'}
osmc@osmc:~$ tail -f ~/.kodi/temp/kodi.log | grep -B 1 'HandleKey'
2023-02-25 20:37:28.191 T:2813    DEBUG <general>: Skipped 1 duplicate messages..
2023-02-25 20:37:28.191 T:2813    DEBUG <general>: HandleKey: long-0
(0x100f200, obc-16838913) pressed, action is
2023-02-25 20:37:32.966 T:2813    DEBUG <general>: Skipped 1 duplicate messages..
2023-02-25 20:37:32.966 T:2813    DEBUG <general>: HandleKey: long-0
(0x100f200, obc-16838913) pressed, action is
2023-02-25 20:37:39.629 T:2813    DEBUG <general>: Skipped 1 duplicate messages..
2023-02-25 20:37:39.629 T:2813    DEBUG <general>: HandleKey: long-0
(0x100f200, obc-16838913) pressed, action is

That means that Kodi is not picking up that key correctly. That entry is basically a catch-all.

Install evtest with…

sudo apt-get install evtest

and then run it by just typing “evtest” and hit enter. Figure out which device this remote is and select the number it displays. When you are in the correct entry it should respond when you press the OK button on the remote. Once you find it please post the entire output for that entry including the output from that key press.

Evtest gives me the following. None of them are obvious. Do I just go into each one and try hitting the OK button?
osmc@osmc:~$ evtest
No device specified, trying to scan all of /dev/input/event*
Not running as root, no devices may be available.
Available devices:
/dev/input/event0: gpio_keypad
/dev/input/event1: aml_vkeypad
/dev/input/event2: cec_input
/dev/input/event3: input_btrcu
/dev/input/event4: HAOBO Technology USB Composite Device
/dev/input/event5: HAOBO Technology USB Composite Device
/dev/input/event6: meson-ir
/dev/input/event7: lircd
Select the device event number [0-7]:

Yes, but I assume it is probably 4 or 5. You can ctrl+c to exit evtest and then just run it again to try another.