Reset button?

I have run XBMC on a Pi B+ for years, but of lately it has felt a bit sluggish and also prone to freezing so I changed to a Vero 4K. Since then it has frozen twice, requiring a powercycle as there is no reset button.

In all fairness, I never had the time to check whether it was just the UI or the whole unit and besides, running putty to restart just the mediacenter is beyond the capabilities of the rest of the family.

Any ideas apart from logs next time it happens?

If you have an android phone, check out Raspberry SSH
You can define custom actions for just about anything and attach to a button. Anyone in the family should be able to cope with that :wink:

Yes. I could probably use the tablet for that, but it will not work for hard hangs. I have connectbot on the tablet, but I had no idea that you could create a button?

I have the Vero 4k here, and I don’t have any issue at all.
Can uou trigger the the “ḧang”?
I have all the vero devices here (1, 2 and 4k), and while I was using the Vero 2, it started behaving weird. everytime something was done that require a little bit more power, it hang or rebooted.
When talking to Sam, he asked me to switch the power supply (The Vero 1 Power supply is compatible), and the problems were gone.
In fact, the Vero 2 power supply had an issue and was not delivering the required power. Replacing it fixed it.

It usually happens when we sit down to watch telly only to find it frozen.

I would check the Power Supply to see if that was it. Happened to me too.
Everytime the device’s power requirement went up just by a little, freeze or reboot happened.

It is the PSU that ships with the Vero 4k.

Just to weigh in on this: we’ve only had three returns for the Vero 4K as faulty since they went on sale. When testing them, I found that replacing the power supply resolved the issue. The customers were happy too.

OK. I will keep an eye on it. If it continues to act up, I will try another PSU.

A suggestion for future designs: What about a reset button. A short press restarts the mediacenter. A long press reboots the unit.

@AndersG: Are you using CEC or the OSMC remote? If you are using CEC is may not be that the Vero has hung, but that you lost CEC. When you find it hung, is the time on the home screen (assuming that was the screen you were last on) correct? If so, then it’s not hung.

If you are using CEC, try to switch your TV to a different input, and back to the Vero input and see if it starts working.

Otherwise, try to ssh into the Vero so you can tell if it’s just Kodi that hung, or the OS. If you are able to ssh in, supply logs. I’ve had my 4K since they first came out and have never had hanging problems with it. It’s on 24/7.

Quick check is to see if the time is up to date (might be hard to see if screen is dimmed.


No remote at all, I use a wireless keyboard


Good point! Yes, a regular user would probably not be able to see the difference between a hang and loss of keyboard. Will tell everyone to watch the time in case it happens again.

Also, you could check if the Vero4K remote still works when it hangs.

I have 2 Vero4K running 24/7 … in constant use by a family of 5 (LiveTV, PVR, movies, etc)
and have never experienced any hangs. Sounds like the wireless keyboard is losing connection
maybe. Could it be that the connection to the keyboard is going to sleep after a while of not being used?

I am positive that the remote will not work as it is till in the box it came in :slight_smile: Trying to cut down on the amount of remotes… But point taken. I guess the easiest is to just ssh in and see if it is till running. Has worked fine the last few days.

If you want to cut down on remotes, I actualy use a Harmony remote from logitech to handle all my devices in the living room. Cuts it down to 1 remote for all :slight_smile:

I know. Had a Harmony but gave it to a friend as no-one used it. :slight_smile: Keyboard is som much better if you have to type text.

1 Like

you could use it as a ‘stand-by’ remote - for the family (ie for when the screen ‘freezes’).
Using a different remote is a better ‘family-friendly’ option than having to powercycle.

And if the remote is still working when the screen ‘freezes’, then we’ll know the issue
is not Vero4K or OSMC.

It froze last night whilst fast-forwarding. It was sloidly flozen. No SSH either. A reset button would have been nice :slight_smile:

I know that stuff should not freeze, but then there is reality and we should not make the same mistake as Steve Jobs did when not putting a fan in the first Mac, against the recomendation of his engineers :slight_smile:

Was it tvh that froze during fast forward…?
If OSMC freezes due to network issues (i.e. No response for tvh server) then maybe it times out… and comes back after a while.
Did you wait when it froze…?
Has it only happened once in 3 months?

It has happened a couple of times. We did wait for a while, say 5 minutes and as I said, there was no response on SSH either.