RetroPie Roms Locations OSMC

I have just put the retropie program on my OSMC box. I can launch retropie, configure my controller. It launches the homepage and says 13 games available but all I can do from here is go into settings.

When I ssh in I have placed roms in both zip and unzipped format in the following places:

/hone/osmc/RetroPie/roms/CONSOLE FOLDER/roms

No games are actually showing, what should happen from here?

has Retrosmc installed correctly ?

You didn’t install as root, right?
Did you have to create thise folders or were they there already?

Toast - Im unsure, how would I check?

mcobit - I installed as osmc not root, the retropie/roms folder was installed. I copied my romdump into there which created the console folder/roms folder

Try to put the roms into /home/osmc/RetroPie/roms/consolefolder/

Not into a roms folder in the consolefolder!

Moved the roms into roms/SNES also and no luck.

I now have them in roms/…, roms/SNES…, and roms/SNES/roms in all zip and smc formats.

when I launch retropie it gives the emulation station logo, then goes to the retropi banner with no options to pick an emulator…

UPDATE - I have checekd the config file at /etc/retropie and it shows the same directory that mcobit states, but it is still not finding the files even after a reboot, also tried the scraper to force them but no luck.

If i move into the settings and try to launch the retroarch option or indeed file manager it seems to just go back to the normal screen with the rest of the options.

Shouldn’t the consolepath be “snes” (lower case)?
Linux is case sensitive!

Please post a directory structure of the $/RetroPie/roms folder.

It should indeed. I ended up with both and ROMS in both.

For anyone finding this thread I eventually found the answer.

In the config settings for emulation station the setting parse games lists only was flagged as true, changed this to false and it sorted itself out.