Retrosmc + bluetooth gamepad : booting without Keyboard

Hi !
First, please apologies if this topic has already been discussed but I couldn’t find my solution in the forum or elsewhere.
I’ve installed retrosmc with the last Kodi version 17.4 and the last update of OSMC (sept ‘17). Everything went very well : thanx for you work :slight_smile:
It went so well that I wanted to avoid using my wire keyboard and I’ve bought a 8bitdo N30 pro Bluetooth controller. I’ve configured it easily but when I unplug my keyboard and try to launch retrosmc from Kodi (with the N30 or kodi remote), it goes back to the kodi menu : no emulationstation launch ! If I want it to work, the USB Keyboard must be plugged in… a shame because my Pi 3 is above my head, on my video projector mount…
I must say that I’ve indeed tried all the 3 configurations (default, boot, background) when configuring the Bluetooth gamepad. Also I’ve activated the UDev rule and it seems to be taken in account.
Sorry for my English if I make mistakes…
Thanks again for you incredible work… and hopefully your solution :slight_smile:

Hi there ! Is there really nobody that can answer my question ? Or maybe it’s not clear ? Or I’m in the wrong place in the forum ?
Thanks you @mcobit if you know something about this and even if you don’t own the gamepad ;)…

Please, can anybody help me ? @sam_nazarko, @mcobit ?
Thanks in advance :fearful:

Edit: when trying again i noticed the same behavior, trying to start emulationstation via ssh while starting from kodi at the same time i got a black screen in ssh session, when i CTRL+c i got an error msg:

INFO: Failed to set keyboard mode

Think this might be the cause of your problem, @mcobit could use your input here, but i bet it’s a retropie issue.

I have no clue what you guys are talking about. I don’t use a keyboard on my pis.

I can try to reinstall retropie freshly. Is this only the case when using bluetooth stuff? Or is it reproducible otherwise?

Thanks guys for taking time helping me :slight_smile:
I can only answer that the problem comes only with the Bluetooth gamepad for me and I cannot say anything about other type of gamepad (e.g. usb) or other type of hardware …
if you want me to send you some logs or try anything, I’m your man (but not at home for the 5 next days).

So, did you try something ? I will try to fresh install omsc+retrosmc on another SD card (but i’m not sure if this other SD card in OK…).
Please, let me know what you observe on your side @mcobit. Thanks ! Pierre

Hi @mcobit @joakim_s ! Did you have time to try something ? Or maybe i misunderstood your proposition ? Thanks again for you help.

@pierrequere Sorry, I haven’t had time to do anything to diagnose it more, will try this comming weekend. I will reimage on my pi3, using internal bluetooth, dont have a dongle handy.

1 Like

I reimaged and reinstalled without a problem. But I don’t use BT stuff at all.

1 Like

Thanks ! I also use the internal Bluetooth so let me know. Thanks again :slight_smile:

Ok… for me the problem is not the BT but the fact that no keyboard is plugged in the USB port… I really have to find a new micro-SD Card to try. Thanks for your time :slight_smile:

I’ve installed on another card, and after alot of trouble getting the bluetooth controller to work, i can start it without the keyboard. Just bluetooth need to be repaired in MyOSMC every time i turn the controller off, wont auto reconnect. I’ve got no real idea what i did to get it working but after like 3-5 times trying to pair it and using retropie setup for bluetooth i got it working.

@pierrequere Did you use the “Testing Retrosmc 0.09 beta”-install or the “[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC”?

@mcobit Could the culprint be retrosmc_helper? since i never even get emulationstation started, no logs from emulatiostation even.

Since my second install was not 0.09, and that worked without keyboard

Ok. Might be a problem with the newer beta.
I’d say use the old method for now. The new one might have bugs and isn’t well tested.
That’s the reason it is not in the main thread.

Hi, sorry for no answering this time (very busy week !!).
I’ve initially used the “0.0.3 retrosmc-launcher” kodi extension.
@joakim_s Reading your question, i read the “[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC” and now I don’t know what to test because I only can see a 0.0.7 beta version, not a stable one…
@mcobit What method do you advise to try if I want to succeed in “launching ES without keyboard plugged on the Pi (only a BT controller)”.
Thanks again. Pierre

@pierrequere, okey, the thing i found out was that a new element in 0.09 beta was problematic for me, when i removed the retroosmc_helper and started emulationstation insted of that i got it to open emulationstation, without keyboard.

But if you used 0.07 beta, you are using the same version as i did when i did a new install on another card. And that i got working.

Thanks @joakim_s. Finally, I have used the command line (that means the 0.0.7beta version of retrosmc, right ?) and not the 0.0.3 launcher add-on method as I did initially on my first SD card.

It worked well with ssh and now, I must say that Emulation Station starts without keyboard via ssh !!
Its indeed difficult to make the BT controller working, but that’s another story…

BUT now the problem is that I don’t know how to launch Emulation Station without using the ssh command line since there is no launcher in KODI as in the previous method. And when I’ve tried to install the add-on afterwards it’s not able to launch anything directly from the KODI interface. Any idea ? @mcobit too ?
Another problem : after this new installation, I can’t see the mounted drive called ‘osmc’ on my mac to put the ROMS inside… It came automatically with the first installation method (0.0.9 if i’m not mistaken?)…

Any idea to uninstall completely retrosmc on my first SD card. I’d like to try a “fresh” install on it without losing all my KODI settings if it’s possible ?

Use MyOSMC backup function, it will backup your kodi settings, addons and all if you set it up like that.

Use a usb-stick and backup to there, when you have made a backup you can restore it on a clean OSMC install. Getting all addons and settings installed again…That means the “launcher”-addon is backed up too, but that is easy to remove, via ssh.

So either you remove the launcher addon before makeing a back up or after yoou restore the back up.

to remove the launcher addon, ssh in and run this command:

rm -rf .kodi/addons/plugin.program.retrosmc-launcher/